<!DOCTYPE html><!--[if IE 7]><html class="layout-wrapper ie ie7 lte9 lte8 lte7"><![endif]--><!--[if IE 8]><html class="layout-wrapper ie ie8 lte9 lte8"><![endif]--><!--[if IE 9]><html class="layout-wrapper ie ie9 lte9"><![endif]--><!--[if (gte IE 9)|!(IE)]<!--><html class="layout-wrapper"><head><title> Icon Usability and Design Best Practices | Toptal</title>
<meta name="description" content="The ultimate aim of icon design is to enhance the user experience. But what does that look like, and how can UI designers ensure that the icons they make will be easily understood? Designer Micah Bowers cautions against cryptic icons and offers a practical approach to icons that communicate with clarity." />
<link rel="alternate" href="https://www.toptal.com/designers/ui/icon-usability-and-design" hreflang="en" />
<link rel="canonical" href="https://www.toptal.com/designers/ui/icon-usability-and-design" />
<meta property="og:image" content="https://uploads.toptal.io/blog/post_image/120854/image_7-08408f8d87047eba159cd1b3606320f1.png" />
<meta property="og:title" content="Icon Usability and Design Best Practices" />
<meta property="og:description" content="The ultimate aim of icon design is to enhance the user experience. But what does that look like, and how can UI designers ensure that the icons they make will be easily understood? Designer Micah Bowers cautions against cryptic icons and offers a practical approach to icons that communicate with clarity." />
<meta property="og:site_name" content="Toptal Design Blog" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="author" content="" />
<meta name="DC.date.issued" content="2018-07-03" /><meta charset="utf-8" /><meta content="IE=edge,chrome=1" http-equiv="X-UA-Compatible" />
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"e3359cee6b","applicationID":"30100511","transactionName":"JV0NEUYJCQkARxgVEwReCgYbFgoWEUYYFg4JRQ==","queueTime":0,"applicationTime":186,"agent":""}</script>
<script type="text/javascript">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</script><meta content="width=device-width, initial-scale=1.0" name="viewport" /><script>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</script>
<script data-cfasync="false" src="//tribl.io/h.js?orgId=EdOAdeaAj8s34gqB05v6" type="text/javascript"></script><link href="https://assets.toptal.io/assets/front/static/favicons/favicon_ca7136.png" rel="icon" /><!--[if IE]><link href="https://assets.toptal.io/assets/front/static/favicons/favicon_68b340.ico" rel="shortcut icon" /><![endif]--><link href="https://assets.toptal.io/assets/front/static/favicons/touch_x57_f72647.png" rel="apple-touch-icon-precomposed" sizes="57x57" /><link href="https://assets.toptal.io/assets/front/static/favicons/touch_x72_516451.png" rel="apple-touch-icon-precomposed" sizes="72x72" /><link href="https://assets.toptal.io/assets/front/static/favicons/touch_x114_1798a8.png" rel="apple-touch-icon-precomposed" sizes="114x114" /><link href="https://assets.toptal.io/assets/front/static/favicons/touch_x57_f72647.png" rel="apple-touch-icon-precomposed" /><script src="https://assets.toptal.io/assets/jquery_and_modernizr-0d145eb3d4d61ecef414ecf3f7b7a330c5d9e8b1.js"></script><script>// TODO: Figure out how to override Modernizr test
(function () {
  var isIE, isIE11, noFlexboxClassName;
  isIE = /MSIE/.test(navigator.userAgent) && !/Opera/.test(navigator.userAgent);
  isIE11 = window.MSInputMethodContext && !/\bEdge\/[0-9.]+$/.test(navigator.userAgent);
  if (window.Modernizr && window.Modernizr.flexbox && (isIE || isIE11)) {
    noFlexboxClassName = document.documentElement.className.replace(/\bflexbox\b/, 'no-flexbox ie-flexbox');
    document.documentElement.className = noFlexboxClassName;
  }
})();</script><script>
//<![CDATA[
window.gon={};gon.flash={};gon.env="production";gon.signedin=false;gon.check_session_url="https:\/\/www.toptal.com\/signed_in";gon.shorten_url="https:\/\/www.toptal.com\/shorten_url";gon.geo_target_url="https:\/\/www.toptal.com\/api\/geo_target";gon.recaptcha_site_key="6LfgR1UUAAAAAJ8-zrjvTk18gKat-4CdBPSrUJoR";gon.recaptcha_url="https:\/\/www.google.com\/recaptcha\/api.js";gon.google_api_browser_key="AIzaSyDED9v55b-c1opDYMEDYBkOgDFGlBMICGY";gon.google_js_maps_key="AIzaSyDspLQumHNqilmD5UHddqqpSjwY1AJpVd0";gon.google_places_api_key="AIzaSyBcP-ExZ1pLLRX2Adlc-faZpjwC3raVQI4";gon.ga_settings={"group":"Blog posts"};gon.current_vertical="designers";gon.url_share_counter=0;gon.chameleon_current_experiments={"remove_skype_bounce_modal":{"google_analytics_dimension":null,"variant_key":"disabled"},"email_validation_change":{"google_analytics_dimension":"dimension2","variant_key":"copy_and_placeholder_text"},"bounce_modal_escape_key":{"google_analytics_dimension":"dimension3","variant_key":"enabled"}};gon.bounce_modal_settings={"show":true,"type":"fullscreen","current_vertical_role_type":"Designer","template_options":{"blog":{"bundle_name":"blog_designers","submit_path":"https:\/\/www.toptal.com\/blog\/subscription","form_vertical":"designers","blog_image":"designers","blog_type":"Toptal Design Blog","subtitle":"for the latest design tutorials and exploration of current trends.","articles":[{"url":"https:\/\/www.toptal.com\/designers\/illustration\/a-step-by-step-guide-to-designing-custom-illustrations-without-any-drawing-skills","image":"https:\/\/uploads.toptal.io\/blog\/cover_image\/120250\/list_inside_cover-illustration-ddb8de15cc6f3c6edd2d128940ae8b10.png","title":"A Step-by-step Guide to Designing Custom Illustrations Without Any Drawing Skills","author":"Tidjane Tall","author_image":"https:\/\/uploads.toptal.io\/user\/photo\/271544\/small_834a3184ed32914981f20be54b1e24e8.jpg","author_position":"Design Blog Editor"},{"url":"https:\/\/www.toptal.com\/designers\/ui\/button-design-dribbble-timeline","image":"https:\/\/uploads.toptal.io\/blog\/cover_image\/120423\/list_inside_cover-buttonhistory_widecover_2x-ea26f7bcdb179906a270d928d5f98188.png","title":"Button Design Over the Years \u2013 The Dribbble Timeline","author":"Wojciech Dobry","author_image":"https:\/\/uploads.toptal.io\/user\/photo\/424794\/small_f10f0f82d36df37ac83d547de1befad8.jpg","author_position":"Designer and Design Blog Editor"},{"url":"https:\/\/www.toptal.com\/designers\/product-design\/anticipatory-design-how-to-create-magical-user-experiences","image":"https:\/\/uploads.toptal.io\/blog\/cover_image\/120264\/list_inside_cover-0201michael_cover-801e7a036b586141c3f92525ae6883b7.jpg","title":"Anticipatory Design: How to Create Magical User Experiences","author":"Miklos Philips","author_image":"https:\/\/uploads.toptal.io\/user\/photo\/299315\/small_19de8ca05989b15dc1bf65db8c33c8c6.png","author_position":"Principal UX Designer"}]},"fullscreen":{"subtitle":"designers","bounce_modal_header_skill":"UI designers","verticals":["developers","designers","finance_experts"],"skip_skype":false,"redirect_to_hire":false,"for_projects":false,"email_validation_api_path":"https:\/\/www.toptal.com\/giorgio\/api\/company_email_validations","submit_path":"https:\/\/www.toptal.com\/giorgio\/api\/leads","default_vertical":"designers","show_company_email_text":true,"new_validation_ui":false}},"experiments":{"fullscreen":{"remove_skype_bounce_modal":"disabled","email_validation_change":"copy_and_placeholder_text","close_on_escape":true},"blog":{"close_on_escape":true}},"skill":"UI","role":"designers"};gon.current_skill_name="UI";gon.current_skill_name_overriden_singular="UI designer";gon.current_skill_name_overriden_plural="UI designers";
//]]>
</script><link rel="stylesheet" media="screen" href="https://assets.toptal.io/assets/public_styles-0d145eb3d4d61ecef414ecf3f7b7a330c5d9e8b1.css" /><link rel="stylesheet" media="screen" href="https://assets.toptal.io/assets/portal_styles-0d145eb3d4d61ecef414ecf3f7b7a330c5d9e8b1.css" /><link rel="stylesheet" media="screen" href="https://assets.toptal.io/assets/blog_styles-0d145eb3d4d61ecef414ecf3f7b7a330c5d9e8b1.css" /><script>if(!window.appinfo) {
  var thens = []
  var catches = []
  var LocalPromise = {
    then: function(callback, error) {
      thens.push(callback)
      if (error) {
        catches.push(error)
      }
    },
    catch: function (error) {
      catches.push(error)
    }
  }
  var resolve = function() {
    var args = arguments
    thens.forEach(function(callback) {
      callback.apply(null, args)
    })
  }
  var reject = function() {
    var args = arguments
    catches.forEach(function(callback) {
      callback.apply(null, args)
    })
  }

  window.onAppInfoLoaded = LocalPromise

  window.onAppinfoLoad = function() {
    document.cookie = 'appinfo_id_status=doing_request;'

    window.appinfo.grab('https://appinfo.toptal.com', {
      data: gon['application_info_data'] || {},
      callback: function(response, error) {
        if (!error) {
          document.cookie = 'appinfo_id_status=request_completed;'

          resolve({
            applicationInfo: response.data
          })
        } else {
          document.cookie = 'appinfo_id_status=request_failed;'
        }
      }
    })
  }

  document.cookie = 'appinfo_id_status=loading_script;'

  var script = document.createElement('script')
  script.type = 'text/javascript'
  script.onError = function() {
    document.cookie = 'appinfo_id_status=script_load_failed;'
    reject()
  }
  script.src = 'https://appinfo.toptal.com/script.js'
  document.getElementsByTagName('head')[0].appendChild(script)
}</script></head><body class="layout" data-view="layout#body" id="top"><div class="layout_layer" data-view="layout#layout"><header class="page_header hide_in_webview" data-role="fixed-header"><div class="page_header_line"></div><div class="page_header" data-view="layout#menu"><div class="blog-simple-header grid-row is-light_gray" data-role="main_menu_wrapper"><div class="grid-row-inner is-wide has-padding page_header_top"><div class="page_header_top-logotype_wrapper"><div class="page_header_top-logotype"><a class="logo is-big is-link" href="https://www.toptal.com/designers"></a></div><div class="page_header_top-main_title"><b>Hiring?</b> Toptal handpicks <b><a href="https://www.toptal.com/designers/ui" onclick='window.googleAnalytics.trackEvent(event, "BlogCTAs", "ClickedOnHeaderHeadline", "ClickedOnHeaderHeadline")'>top UI designers</a></b> to suit your needs.</div></div><a class="page_header_top-expand" data-role="expand_menu" href="#"><span class="page_header_top-expand_icon"></span></a><nav class="page_header_top-nav_wrapper"><ul class="page_header_top-nav"><li class="page_header_top-nav_item"><a class="button is-green_candy is-small page_header_top-nav_link is-button" data-role="companies_apply_button" href="https://www.toptal.com/designers/ui" onclick="window.googleAnalytics.trackEvent(event, &quot;BlogCTAs&quot;, &quot;ClickedOnHeaderCTA&quot;, &quot;ClickedOnHeaderCTA&quot;);">Start hiring</a></li><li class="page_header_top-nav_item"><a class="button is-small is-light page_header_top-nav_link is-button" href="https://www.toptal.com/users/login">Log in</a></li></ul></nav></div></div><nav class="grid-row has-top_border is-light_gray page_header_menu-wrapper" data-role="main_menu_wrapper"><div class="grid-row-inner is-wide has-small_padding page_header_menu"><div class="page_header_menu-items-wrapper"><ul class="page_header_menu-items" data-role="menu"><li class="page_header_menu-item is-home"><a class="page_header_menu-link" href="https://www.toptal.com/designers"></a></li><li class="page_header_menu-item is-top-3-percent"><a class="page_header_menu-link" href="https://www.toptal.com/top-3-percent">Top 3%</a></li><li class="page_header_menu-item is-why"><a class="page_header_menu-link" href="https://www.toptal.com/why">Why</a></li><li class="page_header_menu-item is-clients"><a class="page_header_menu-link" href="https://www.toptal.com/clients">Clients</a></li><li class="page_header_menu-item is-enterprise"><a class="page_header_menu-link" href="https://www.toptal.com/enterprise">Enterprise</a></li><li class="page_header_menu-item is-community"><a class="page_header_menu-link" href="https://www.toptal.com/community">Community</a></li><li class="page_header_menu-item is-blog"><a class="page_header_menu-link" href="https://www.toptal.com/designers/blog">Blog</a></li><li class="page_header_menu-item is-about"><a class="page_header_menu-link" href="https://www.toptal.com/about">About Us</a></li><li class="page_header_menu-item is-join"><a class="button is-green_candy is-small page_hader_menu-button" data-role="companies_apply_button" href="https://www.toptal.com/designers/ui" onclick="window.googleAnalytics.trackEvent(event, &quot;BlogCTAs&quot;, &quot;ClickedOnHeaderCTA&quot;, &quot;ClickedOnHeaderCTA&quot;);">Start hiring</a></li><li class="page_header_menu-item is-join"><a class="button is-green_candy is-small page_hader_menu-button" href="https://www.toptal.com/designers/join">Apply as a Designer</a></li><li class="page_header_menu-item is-login"><a class="button is-light is-small page_hader_menu-button is-login" href="https://www.toptal.com/users/login">Login</a></li><li class="page_header_menu-item is-contacts"><ul class="page_header_menu-contact-items is-replaceable"><li class="page_header_menu-contact-item is-contact">Questions?</li><li class="page_header_menu-contact-item is-contact"><a class="link is-dotted page_header_menu-contact-link" href="https://www.toptal.com/contact">Contact Us</a></li><li class="page_header_menu-contact-item"><a class="page_header_menu-contact-link is-social is-facebook" href="https://www.facebook.com/toptal" target="_blank"><span class="page_header_menu-contact-link-icon"></span></a></li><li class="page_header_menu-contact-item"><a class="page_header_menu-contact-link is-social is-twitter" href="https://twitter.com/toptal" target="_blank"><span class="page_header_menu-contact-link-icon"></span></a></li><li class="page_header_menu-contact-item"><a class="page_header_menu-contact-link is-social is-google_plus" href="https://plus.google.com/+Toptalllc/" target="_blank"><span class="page_header_menu-contact-link-icon"></span></a></li></ul></li></ul></div><div class="blog_search" data-view="quick_search#search_field" data-vertical="Designer"><form class="blog_search-form" data-role="form"><input autocomplete="off" class="blog_search-field" data-role="field" name="text" placeholder="Search Topics" type="text" /><button class="button is-tiny blog_search-submit"><span class="blog_search-submit_icon"></span></button></form><div class="blog_search-suggestions" data-role="suggestions_wrapper"></div><div class="blog_search_results" data-role="results" style="display: none;"></div></div><a class="button is-green_candy is-tiny for-page_header_menu page_header_menu-hire" data-role="companies_apply_button" href="https://www.toptal.com/hire?interested_in=designers&amp;skill=ui">Hire a designer</a></div></nav><nav class="blog-simple-header grid-row page_header_menu-wrapper is-fixed" data-role="sticky_menu_wrapper"><div class="grid-row-inner is-wide page_header_menu has-padding"><div class="page_header_top-logotype_wrapper"><div class="page_header_top-logotype"><a class="logo is-big is-link" href="https://www.toptal.com/designers"></a></div><div class="page_header_top-main_title"><b>Hiring?</b> Toptal handpicks <b><a href="https://www.toptal.com/designers/ui" onclick='window.googleAnalytics.trackEvent(event, "BlogCTAs", "ClickedOnHeaderHeadline", "ClickedOnHeaderHeadline")'>top UI designers</a></b> to suit your needs.</div></div><nav class="page_header_top-nav_wrapper"><ul class="page_header_top-nav" data-role="menu"><li class="page_header_top-nav_item"><a class="button is-green_candy is-small page_header_top-nav_link is-button" data-role="companies_apply_button" href="https://www.toptal.com/designers/ui" onclick="window.googleAnalytics.trackEvent(event, &quot;BlogCTAs&quot;, &quot;ClickedOnHeaderCTA&quot;, &quot;ClickedOnHeaderCTA&quot;);">Start hiring</a></li><li class="page_header_top-nav_item"><a class="button is-small is-light page_header_top-nav_link is-button" href="https://www.toptal.com/users/login">Log in</a></li></ul></nav></div></nav></div></header><main class="layout-main"><header class="grid-row has-top_border has-bottom_border post_cover is-post"><div class="grid-row-inner is-wide has-big_padding blog_title for-show"></div></header><article class="grid-row is-transparent"><div class="grid-row-inner is-wide"><div class="post_title"><h1 class="post_title-text">Icon Usability and Design Best Practices</h1><a class="post_title-back" href="https://www.toptal.com/designers/blog">View all articles</a></div></div></article><section class="grid-row has-top_border is-transparent has-no_border" data-view="" id="main_content"><div class="grid-row-inner has-medium_padding two_columns_layout is-wide"><div class="two_columns_layout-content"><div class="post is-full"><div class="post_meta-wrapper post_header"><div class="post_header-triangle"></div><div class="post_avatar post_meta-avatar"><img width="50" class="post_avatar-image" src="https://uploads.toptal.io/user/photo/241853/small_af8544ccbb8119b6abe6938463505ff0.jpg" alt="Small af8544ccbb8119b6abe6938463505ff0" /></div><div class="post_meta is-full"><div class="post_meta-author"><p>by <strong><a class="link is-blue" target="_blank" href="https://www.toptal.com/designers/resume/micah-bowers">Micah Bowers</a></strong> - Designer
@ <a class="link is-blue" target="_blank" href="https://www.toptal.com/">Toptal</a>
</p>
</div><div class="post_meta-tags"><a rel="nofollow" href="https://www.toptal.com/designers/blog/tags/ui">#UI</a> <a rel="nofollow" href="https://www.toptal.com/designers/blog/tags/usability">#Usability</a> <a rel="nofollow" href="https://www.toptal.com/designers/blog/tags/ux">#UX</a></div></div><ul class="social_share is-horizontal is-small is-centered_on_mobile for-blog_post_heading" data-hashtags="UX,UI,Usability" data-rss-url="https://www.toptal.com/designers/blog.rss" data-url="https://www.toptal.com/designers/ui/icon-usability-and-design" data-view="layout#social_share" data-youtube-channel-url="https://www.youtube.com/channel/UCNqm_euTHZz3o5OnKhUS-oA"><li class="social_share-item is-counter" title="Total number of shares"><span class="social_share-item_num" data-role="counter_num">0</span><span class="social_share-item_text" data-role="counter_text">shares</span></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;twitter&quot;}" data-type="twitter" title="Share on Twitter"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/twitter_83c6d4.png" width="50" /></a></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;facebook&quot;}" data-type="facebook" title="Share on Facebook"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/facebook_dc66c9.png" width="50" /></a></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;linkedin&quot;}" data-type="linkedin" title="Share on LinkedIn"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/linkedin_b923c3.png" width="50" /></a></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;google_plus&quot;}" data-type="google_plus" title="Share on Google Plus"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/google_plus_355fb0.png" width="50" /></a></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;stumbleupon&quot;}" data-type="stumbleupon" title="Share on StumbleUpon"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/stumbleupon_fc7c35.png" width="50" /></a></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;pocket&quot;}" data-type="pocket" title="Save to Pocket"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/pocket_e4260c.png" width="50" /></a></li></ul><div class="post_meta-extra"></div></div><div class="content_body" data-insert-middle-content="true" data-view="content#body"><p>Imagine yourself driving to work—favorite podcast playing, travel mug in hand, and nothing but clear roads ahead. A cautious driver, you peek down and notice an unfamiliar light glowing on the dashboard.</p>

<p><img src="https://uploads.toptal.io/blog/image/126545/toptal-blog-image-1530484257347-19fc51ee097678dcfff271204b308915.jpg" alt="Confusing icon usability for tire pressure management system " /></p>

<div class="pop_out_box is-full_width" style="font-size:1em; text-align: center">The icon for the Tire Pressure Management System (TPMS) is a bloated cross-section that scarcely resembles a tire.</div>

<p>Something like a mix between a light socket and a bubbling witches cauldron, the little light appears important, but you’re not sure what it means. A glance at the gauges reveals nothing abnormal, and the vehicle seems to be running fine, so you decide to deal with it after work.</p>

<p>Later that evening, your workday done and dinner on the horizon, you approach your vehicle in the office parking lot and—”You’ve gotta be KIDDING ME!”</p>

<p>The front driver’s side tire is flat as a pancake. If only you’d known that the little icon from earlier was a warning from your vehicle’s tire pressure management system, you would have addressed the problem and avoided unnecessary grief.</p>

<h2 id="icons-must-provide-clarity">Icons Must Provide Clarity</h2>

<p>The world of physical and digital products is inundated with icons and for good reason: Images convey meaning with a speed unmatched by words. In fact, MIT neuroscientists have found that the human brain can process an image in as little as <a href="http://news.mit.edu/2014/in-the-blink-of-an-eye-0116">13 milliseconds</a>.</p>

<p>Unfortunately, there are times when the icons we encounter are poorly crafted, leaving us perplexed and frustrated. When designed carefully, however, icons improve usability by reducing ambiguity and communicating functionality.</p>

<p>The ultimate aim of <a href="https://www.toptal.com/designers/usability/turning-usability-testing-data-into-action">icon usability and design</a> is to enhance the user experience, not confuse it. But what does that look like, and how can <a href="https://www.toptal.com/designers/ui">user interface designers</a> ensure that the icons they make will be easily understood?</p>

<h2 id="skillful-icon-design-improves-product-usability">Skillful Icon Design Improves Product Usability</h2>

<p>Icons are abstractions. They simplify objects, ideas, and commands into graphic symbols that may be quickly identified by the human eye. So, what makes icons useful, and how should they make the user feel?</p>

<h3 id="icons-are-easy-to-see-and-use">Icons are easy to see and use.</h3>

<p><em>How it feels:</em> “That was easy. I looked at the screen and quickly found the icon I needed. I clicked it, and it worked as expected.”</p>

<h3 id="icons-add-cohesion-to-the-experience-within-a-product">Icons add cohesion to the experience within a product.</h3>

<p><em>How it feels:</em> “These symbols clearly mean something, and they help me navigate and operate this product.”</p>

<p><img src="https://uploads.toptal.io/blog/image/126546/toptal-blog-image-1530484267111-8254c2ee69dc6c741c1a931c7169a999.jpg" alt="Universal icon design for security enhancing icon usability" /></p>

<div class="pop_out_box is-full_width" style="font-size:1em; text-align: center">The Chinese icon for "Security" is instantly recognizable to non-native speakers thanks to its authoritative hat, uniform, and posture. (<a href="https://ultimatesymbol.com/volume.php?vid=364&amp;start=0&amp;ct=36&amp;cid=148&amp;tot=549&amp;cameFrom=EPS">China Public Information Symbols</a>)</div>

<h3 id="icons-work-as-cross-cultural-context-clues">Icons work as cross-cultural context clues.</h3>

<p><em>How it feels:</em> “I don’t know the language, but I do know what that symbol means.”</p>

<h3 id="icons-enhance-and-extend-a-brands-visual-storytelling-abilities">Icons enhance and extend a brand’s visual storytelling abilities.</h3>

<p><em>How it feels:</em> “This brand is personal, yet professional. They care about being helpful in even the smallest of details.”</p>

<h2 id="cryptic-icon-design-makes-products-painful-to-use">Cryptic Icon Design Makes Products Painful to Use</h2>

<p>When icon design is given little thought or icon sets are hastily assembled as an afterthought in a product’s development, complications arise and lead to a poor product experience, miffed users, and a tarnished brand.</p>

<p>What are cryptic icons, and how do they make users feel?</p>

<h3 id="cryptic-icons-are-poorly-associated-with-their-actual-functionality">Cryptic icons are poorly associated with their actual functionality.</h3>

<p><em>How it feels:</em> “Wait, I thought that icon would do something different. What just happened?”</p>

<p><img src="https://uploads.toptal.io/blog/image/126547/toptal-blog-image-1530484278645-2527ce4ed252d5f99e0ac781325d7eda.jpg" alt="Snapchat screenshot icon design meaning" /></p>

<div class="pop_out_box is-full_width" style="font-size:1em; text-align: center">These Snapchat icons let users know when screenshots have been taken of snaps and chats. Unfortunately, the graphic is a poor representation of a screenshot, and the three color variations create confusion.</div>

<h3 id="a-cryptic-icon-set-provides-multiple-options-that-appear-too-closely-related">A cryptic icon set provides multiple options that appear too closely related.</h3>

<p><em>How it feels:</em> “Which one of these icons does what I want it to?”</p>

<h3 id="cryptic-icons-are-culturally-confusing">Cryptic icons are culturally confusing.</h3>

<p><em>How it feels:</em> “Whoa! I’d never click on something so scandalous.”</p>

<h3 id="cryptic-icons-jolt-users-out-of-the-intended-experience">Cryptic icons jolt users out of the intended experience.</h3>

<p><em>How it feels:</em> “I thought this app would help me budget my money, but these icons look silly. Is this product the right fit for me?”</p>

<h2 id="guiding-principles-for-world-class-icon-design">10 Guiding Principles for World-Class Icon Design</h2>

<p>Now that we understand icon usability and how icons can either improve or hinder product usability, let’s examine a set of guiding principles that <a href="https://www.toptal.com/designers/icon">icon designers</a> can use for virtually any icon design project.</p>

<ol>
  <li>Work hard to understand the features that icons will be associated with. If you don’t understand, don’t guess. Ask.</li>
  <li>Avoid designing one icon at a time. Instead, approach icon sets as a whole. Ask yourself, “Is the set cohesive? Are there icons with double meanings or confusing associations? Is the set a good representation of the brand?”</li>
  <li>Bypass the computer, and start early icon ideation with simple sketches.</li>
</ol>

<p><img src="https://uploads.toptal.io/blog/image/126548/toptal-blog-image-1530484295958-7e8dfff16172348a84159132e880e533.jpg" alt="Icon design concept sketches" /></p>

<div class="pop_out_box is-full_width" style="font-size:1em; text-align: center">Hand drawn thumbnail sketches are an effective way to explore multiple icon design concepts and capture ideas quickly.</div>

<ol>
  <li>Don’t reinvent the wheel. Aim for universally understood symbols, and don’t be afraid to utilize existing icon sets that are widely used and available on sites like <a href="https://fontawesome.com/cheatsheet">Font Awesome</a> and <a href="https://material.io/tools/icons/?style=baseline">Material.io</a>.</li>
  <li>When using stock icon sets, feel free to customize for brand alignment or added character, but don’t sacrifice clarity.</li>
  <li>Use text labels where appropriate to boost icon usability. Text by itself is a hard target to click or tap, but when combined with icons, it helps users eliminate doubt and avoid symbolic misinterpretation.</li>
  <li>Don’t sacrifice ease of use for eye candy design.</li>
  <li>Consider how icons fit within an interface’s design hierarchy, and don’t forget that different screen sizes may affect icon visibility due to scaling.</li>
</ol>

<p><img src="https://uploads.toptal.io/blog/image/126549/toptal-blog-image-1530484305717-931766a31e1d0417e24543a4864a44f5.jpg" alt="When dealing with app icon design, look at relative icon design size between mobile and desktop interfaces." /></p>

<div class="pop_out_box is-full_width" style="font-size:1em; text-align: center">Notice the visual prominence of the "Search" icon in the mobile interface as opposed to the desktop version. The actual size between versions changes very little, but the mobile interface has less space so the icon stands out.</div>

<ol>
  <li>Remember the 5-second rule. When creating icon concepts, try to think of symbolic associations within 5 seconds. Otherwise, the connection between word, action, and symbol may be weak.</li>
  <li><a href="https://www.toptal.com/designers/web/usability-conversion-data">Test icons</a> with real people. Are they recognizable? Are they memorable? If not, keep working.</li>
</ol>

<h2 id="conclusion">Conclusion</h2>

<p>We live in a world that’s saturated with visual information. We often make multiple choices in a matter of moments. “Where are we headed? How will we get there? What will we do when we arrive?” Icons help us cut through the clutter and quickly decide what’s important. They keep us happily engaged with the products we use every, and when they work well, they promote brand satisfaction.</p>

<p><img src="https://uploads.toptal.io/blog/image/126550/toptal-blog-image-1530484318276-d343f8e6498a17f1da43d593a893455d.jpg" alt="Cohesive design of Google docs icon set" /></p>

<div class="pop_out_box is-full_width" style="font-size:1em; text-align: center">The Google Docs UI has a balanced mix of easy-to-understand icons and text labels that enhance usability and improve the product's overall experience.</div>

<p>Sadly, icons fall short of their potential far too often. Poorly designed icons impede <a href="https://www.toptal.com/designers/ux-consultants/how-to-conduct-usability-testing-in-6-steps">product usability</a>, annoy users, and harm brand loyalty. For product designers and design teams, this is a major opportunity lost.</p>

<p>When icons enhance the user experience rather than confuse it, they achieve the main goal of any design endeavor; they improve quality of life. Remember, icons are abstractions, not afterthoughts. They are meant to relate complexity quickly and seamlessly, without pause from the user. This is no small feat for the designer, but it’s possible with careful planning, a methodical process, and human-centered user testing.</p>

<div align="center">•••</div>

<p><strong>Further reading on the Toptal Design Blog:</strong></p>

<ul>
  <li><a href="https://www.toptal.com/designers/web/usability-conversion-data">Usability Testing for Conversion: Stop Following Trends, Start Using Data</a></li>
  <li><a href="https://www.toptal.com/designers/usability/turning-usability-testing-data-into-action">Turning Usability Testing Data into Action without Going Insane</a></li>
  <li><a href="https://www.toptal.com/designers/ux-consultants/how-to-conduct-usability-testing-in-6-steps">How to Conduct Usability Testing in Six Steps</a></li>
  <li><a href="https://www.toptal.com/designers/ui/importance-web-accessibility">UX and the Importance of Web Accessibility</a></li>
  <li><a href="https://www.toptal.com/designers/mobile-ui/fundamental-guide-mobile-usability">The Fundamental Guide to Mobile Usability</a></li>
</ul>
<div class="blog_author_big_banner is-active" data-ga-action="ClickedOnHireTheAuthor_bottom" data-ga-label="icon-usability-and-design" data-view="content#bottom_banner"><h2>About the author</h2><div class="skill_talent for-blog_post"><div class="skill_talent-extra"><a class="skill_talent-photo_wrapper" href="/designers/resume/micah-bowers"><img alt="Micah Bowers" class="skill_talent-photo" src="https://uploads.toptal.io/user/photo/241853/large_af8544ccbb8119b6abe6938463505ff0.jpg" /><div class="skill_talent-photo_hint">View full profile &raquo;</div></a><div class="blog_author_big_banner-cta"><a class="button is-green_candy is-default is-full_width is-fixed skill_talent-hire" data-role="banner_link" href="https://www.toptal.com/hire?interested_in=designers&amp;skill=ui">Hire the Author</a></div></div><div class="skill_talent-main"><a class="link skill_talent-name" href="/designers/resume/micah-bowers">Micah Bowers, United States</a><div class="clearfix"><div class="skill_talent-member_since">member since January 3, 2016</div></div><div class="skill_talent-skills" data-view="skill_talent#tags"><a class="tag skill_talent-skill" data-role="tag" href="https://www.toptal.com/designers/photoshop">Adobe Photoshop</a><a class="tag skill_talent-skill" data-role="tag" href="https://www.toptal.com/designers/illustrator">Adobe Illustrator</a><a class="tag skill_talent-skill" data-role="tag" href="https://www.toptal.com/designers/brand">Branding</a><a class="tag skill_talent-skill" data-role="tag" href="https://www.toptal.com/designers/logo">Logo Design</a><a class="tag skill_talent-skill" data-role="tag" href="https://www.toptal.com/designers/illustration">Illustration</a><a class="tag skill_talent-skill" data-role="tag" href="https://www.toptal.com/designers/logo">Logotype</a><a class="tag" data-role="more" href="/designers/resume/micah-bowers" style="display: none;">+<span data-role='count'>&nbsp;&nbsp;</span> more</a></div><div class="skill_talent-description">Micah is a brand designer and illustrator who aspires to elevate design to the level of a story. To reach people and forge lasting engagement, Micah believes that design must identify a need, stir a desire for change, and shed light on a path that is uniquely helpful, hopeful, and human. <a class="link" href="/designers/resume/micah-bowers">[click to continue...]</a></div></div></div></div><div class="post-join"><a class="button is-white_and_green is-default is-full_width" href="https://www.toptal.com/designers/ui">Hiring? Meet the Top 10 Freelance UI Designers for Hire in July 2018</a></div><div class="template" data-role="middle_content_template" data-template="{&quot;html&quot;:&quot;&lt;div class=\&quot;embeddable_form-wrapper for-post\&quot; data-role=\&quot;blog_subscribe\&quot; data-view=\&quot;blog_subscribe#form\&quot;&gt;&lt;form action=\&quot;/blog/subscription\&quot; class=\&quot;embeddable_form\&quot; data-entity=\&quot;blog_subscription\&quot; data-remote=\&quot;\&quot; data-view=\&quot;form#form\&quot; method=\&quot;post\&quot;&gt;&lt;div class=\&quot;embeddable_form-step is-email_form is-current\&quot;&gt;&lt;div class=\&quot;embeddable_form-row is-label\&quot;&gt;&lt;div class=\&quot;embeddable_form-label_title\&quot;&gt;Like what you&amp;#39;re reading?&lt;/div&gt;&lt;div class=\&quot;embeddable_form-label\&quot;&gt;Get the latest updates first.&lt;/div&gt;&lt;/div&gt;&lt;div class=\&quot;embeddable_form-row form-field is-email_field\&quot;&gt;&lt;input autocomplete=\&quot;off\&quot; class=\&quot;input is-medium\&quot; data-role=\&quot;email\&quot; name=\&quot;blog_subscription[email]\&quot; placeholder=\&quot;Enter your email address...\&quot; type=\&quot;text\&quot; /&gt;&lt;input name=\&quot;blog_subscription[vertical]\&quot; type=\&quot;hidden\&quot; value=\&quot;designers\&quot; /&gt;&lt;input name=\&quot;from_widget\&quot; type=\&quot;hidden\&quot; value=\&quot;true\&quot; /&gt;&lt;/div&gt;&lt;div class=\&quot;embeddable_form-row is-submit\&quot;&gt;&lt;input class=\&quot;button is-green_candy is-default is-full_width\&quot; data-loader-text=\&quot;Subscribing...\&quot; data-role=\&quot;submit\&quot; type=\&quot;submit\&quot; value=\&quot;Get Exclusive Updates\&quot; /&gt;&lt;/div&gt;&lt;div class=\&quot;embeddable_form-row is-privacy\&quot;&gt;&lt;div class=\&quot;embeddable_form-privacy\&quot;&gt;&lt;div class=\&quot;embeddable_form-privacy_icon\&quot;&gt;&lt;/div&gt;&lt;div class=\&quot;embeddable_form-privacy_text\&quot;&gt;No spam. Just great design posts.&lt;/div&gt;&lt;/div&gt;&lt;/div&gt;&lt;/div&gt;&lt;div class=\&quot;embeddable_form-step is-confirmation\&quot; data-place=\&quot;@blog_subscribe\&quot; data-role=\&quot;confirmation\&quot;&gt;&lt;div class=\&quot;embeddable_form-row is-label is-success\&quot;&gt;&lt;div class=\&quot;embeddable_form-label_title\&quot;&gt;Like what you&amp;#39;re reading?&lt;/div&gt;&lt;div class=\&quot;embeddable_form-label\&quot;&gt;Get the latest updates first.&lt;/div&gt;&lt;/div&gt;&lt;div class=\&quot;embeddable_form-row is-success\&quot;&gt;&lt;div class=\&quot;embeddable_form-label is-header\&quot;&gt;Thank you for subscribing!&lt;/div&gt;&lt;div class=\&quot;embeddable_form-label\&quot;&gt;Check your inbox to confirm subscription. You&#39;ll start receiving posts after you confirm.&lt;/div&gt;&lt;/div&gt;&lt;div class=\&quot;embeddable_form-row is-success\&quot;&gt;&lt;ul class=\&quot;social_share is-horizontal\&quot; data-rss-url=\&quot;https://www.toptal.com/designers/blog.rss\&quot; data-url=\&quot;https://www.toptal.com/designers/blog\&quot; data-view=\&quot;layout#social_share\&quot; data-youtube-channel-url=\&quot;https://www.youtube.com/channel/UCNqm_euTHZz3o5OnKhUS-oA\&quot;&gt;&lt;li class=\&quot;social_share-item is-counter\&quot; title=\&quot;Total number of shares\&quot;&gt;&lt;span class=\&quot;social_share-item_num\&quot; data-role=\&quot;counter_num\&quot;&gt;0&lt;/span&gt;&lt;span class=\&quot;social_share-item_text\&quot; data-role=\&quot;counter_text\&quot;&gt;shares&lt;/span&gt;&lt;/li&gt;&lt;li class=\&quot;social_share-item\&quot;&gt;&lt;a class=\&quot;social_share-item_link\&quot; data-role=\&quot;link\&quot; data-track-click=\&quot;SocialShareButtonClicked\&quot; data-track-default-data=\&quot;{&amp;quot;network&amp;quot;:&amp;quot;twitter&amp;quot;}\&quot; data-type=\&quot;twitter\&quot; title=\&quot;Share on Twitter\&quot;&gt;&lt;img class=\&quot;social_share-item_image\&quot; height=\&quot;50\&quot; src=\&quot;https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/twitter_83c6d4.png\&quot; width=\&quot;50\&quot; /&gt;&lt;/a&gt;&lt;/li&gt;&lt;li class=\&quot;social_share-item\&quot;&gt;&lt;a class=\&quot;social_share-item_link\&quot; data-role=\&quot;link\&quot; data-track-click=\&quot;SocialShareButtonClicked\&quot; data-track-default-data=\&quot;{&amp;quot;network&amp;quot;:&amp;quot;facebook&amp;quot;}\&quot; data-type=\&quot;facebook\&quot; title=\&quot;Share on Facebook\&quot;&gt;&lt;img class=\&quot;social_share-item_image\&quot; height=\&quot;50\&quot; src=\&quot;https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/facebook_dc66c9.png\&quot; width=\&quot;50\&quot; /&gt;&lt;/a&gt;&lt;/li&gt;&lt;li class=\&quot;social_share-item\&quot;&gt;&lt;a class=\&quot;social_share-item_link\&quot; data-role=\&quot;link\&quot; data-track-click=\&quot;SocialShareButtonClicked\&quot; data-track-default-data=\&quot;{&amp;quot;network&amp;quot;:&amp;quot;google_plus&amp;quot;}\&quot; data-type=\&quot;google_plus\&quot; title=\&quot;Share on Google Plus\&quot;&gt;&lt;img class=\&quot;social_share-item_image\&quot; height=\&quot;50\&quot; src=\&quot;https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/google_plus_355fb0.png\&quot; width=\&quot;50\&quot; /&gt;&lt;/a&gt;&lt;/li&gt;&lt;/ul&gt;&lt;/div&gt;&lt;/div&gt;&lt;/form&gt;&lt;/div&gt;&quot;}"></div></div><div class="blog-comments"><div id="disqus_thread_container"><div id="disqus_thread"><div class="d-noscript-comments"><h3>Comments</h3></div></div></div><script>function isIos() {
  return /(iPad|iPhone|iPod)/g.test(navigator.userAgent);
}

function adjustHeightInIos() {
  if (isIos()) {
    var height = $('#disqus_thread').outerHeight();
    $('#disqus_thread_container').height(height);
  }
}

if (isIos()) {
  var el = document.getElementById('disqus_thread_container');
  el.style.height = '1px';
  el.style.overflow = 'hidden';
  el.style.width = '100%';
}

function disqus_config() {
  this.callbacks.onNewComment = [function() {
    $.post('/blog/comments/on_create');
    adjustHeightInIos();
  }];

  this.callbacks.onReady = [adjustHeightInIos];
}

var disqus_shortname = 'toptal';
var disqus_identifier = 'ui/icon-usability-and-design';

(function() {
  var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
  dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
  (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
})();</script><noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript><a class="dsq-brlink" href="https://disqus.com">comments powered by <span class="logo-disqus">Disqus</span></a></div></div></div><div class="two_columns_layout-extra"><div class="blog-block-wrapper"><div class="blog-block-header">Subscribe</div><div class="blog-block"><div class="blog-block-row"><div class="embeddable_form-wrapper is-horizontal" data-role="blog_subscribe" data-view="blog_subscribe#form"><form action="/blog/subscription" class="embeddable_form" data-entity="blog_subscription" data-remote="" data-view="form#form" method="post"><div class="embeddable_form-step is-email_form is-current"><div class="embeddable_form-row is-label"><div class="embeddable_form-label_title">Free email updates</div><div class="embeddable_form-label">Get the latest content first.</div></div><div class="embeddable_form-row form-field is-email_field"><input autocomplete="off" class="input is-medium" data-role="email" name="blog_subscription[email]" placeholder="Enter your email address..." type="text" /><input name="blog_subscription[vertical]" type="hidden" value="designers" /><input name="from_widget" type="hidden" value="true" /></div><div class="embeddable_form-row is-submit"><input class="button is-green_candy is-default is-full_width" data-loader-text="Subscribing..." data-role="submit" type="submit" value="Get Exclusive Updates" /></div><div class="embeddable_form-row is-privacy"><div class="embeddable_form-privacy"><div class="embeddable_form-privacy_icon"></div><div class="embeddable_form-privacy_text">No spam. Just great design posts.</div></div></div></div><div class="embeddable_form-step is-confirmation" data-place="@blog_subscribe" data-role="confirmation"><div class="embeddable_form-row is-label is-success"><div class="embeddable_form-label_title">Free email updates</div><div class="embeddable_form-label">Get the latest content first.</div></div><div class="embeddable_form-row is-success"><div class="embeddable_form-label is-header">Thank you for subscribing!</div><div class="embeddable_form-label">Check your inbox to confirm subscription. You'll start receiving posts after you confirm.</div></div><div class="embeddable_form-row is-success"><ul class="social_share is-horizontal" data-rss-url="https://www.toptal.com/designers/blog.rss" data-url="https://www.toptal.com/designers/blog" data-view="layout#social_share" data-youtube-channel-url="https://www.youtube.com/channel/UCNqm_euTHZz3o5OnKhUS-oA"><li class="social_share-item is-counter" title="Total number of shares"><span class="social_share-item_num" data-role="counter_num">0</span><span class="social_share-item_text" data-role="counter_text">shares</span></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;twitter&quot;}" data-type="twitter" title="Share on Twitter"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/twitter_83c6d4.png" width="50" /></a></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;facebook&quot;}" data-type="facebook" title="Share on Facebook"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/facebook_dc66c9.png" width="50" /></a></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;google_plus&quot;}" data-type="google_plus" title="Share on Google Plus"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/google_plus_355fb0.png" width="50" /></a></li></ul></div></div></form></div></div></div><div class="blog-block-header">Trending articles</div><div class="blog-block"><nav class="blog-trending"><a class="post is-preview blog-trending-item" href="/designers/ui/icon-usability-and-design"><span class="post_cover is-preview"><noscript><img class="post_cover-image" src="https://uploads.toptal.io/blog/cover_image/120637/side_list_cover-image_0-c09f67027b6ac5e4064d9b9c02a8549a.png" /></noscript><span class="post_cover-image" data-role="deferred" data-src="https://uploads.toptal.io/blog/cover_image/120637/side_list_cover-image_0-c09f67027b6ac5e4064d9b9c02a8549a.png"></span></span><span class="post-preview"><span class="post-title">Icon Usability and Design Best Practices</span><span class="post_meta"><span class="post_meta-date">about 9 hours ago</span></span></span></a><a class="post is-preview blog-trending-item" href="/designers/visual-identity/guide-to-mood-boards"><span class="post_cover is-preview"><noscript><img class="post_cover-image" src="https://uploads.toptal.io/blog/cover_image/120635/side_list_cover-image_0-5f9bf559869168def0977f1bc97a7111.png" /></noscript><span class="post_cover-image" data-role="deferred" data-src="https://uploads.toptal.io/blog/cover_image/120635/side_list_cover-image_0-5f9bf559869168def0977f1bc97a7111.png"></span></span><span class="post-preview"><span class="post-title">Use Your Inspiration – A Guide to Mood Boards</span><span class="post_meta"><span class="post_meta-date">5 days ago</span></span></span></a><a class="post is-preview blog-trending-item" href="/designers/ux/signs-you-need-to-hire-ux-expert"><span class="post_cover is-preview"><noscript><img class="post_cover-image" src="https://uploads.toptal.io/blog/cover_image/120634/side_list_cover-image_0-628dd46c4da7d75c63755f6fef748005.png" /></noscript><span class="post_cover-image" data-role="deferred" data-src="https://uploads.toptal.io/blog/cover_image/120634/side_list_cover-image_0-628dd46c4da7d75c63755f6fef748005.png"></span></span><span class="post-preview"><span class="post-title">Danger Ahead: Telltale Signs It&#39;s Time to Bring in a UX Expert</span><span class="post_meta"><span class="post_meta-date">7 days ago</span></span></span></a><a class="post is-preview blog-trending-item" href="/designers/ux/roi-of-ux-redesign-case-studies"><span class="post_cover is-preview"><noscript><img class="post_cover-image" src="https://uploads.toptal.io/blog/cover_image/120628/side_list_cover-image_0-b85f4680490891ef452b26ea191715ff.png" /></noscript><span class="post_cover-image" data-role="deferred" data-src="https://uploads.toptal.io/blog/cover_image/120628/side_list_cover-image_0-b85f4680490891ef452b26ea191715ff.png"></span></span><span class="post-preview"><span class="post-title">The True ROI of UX: B2B Redesign Case Studies</span><span class="post_meta"><span class="post_meta-date">12 days ago</span></span></span></a><a class="post is-preview blog-trending-item" href="/designers/e-commerce/ultimate-ecommerce-design-guide"><span class="post_cover is-preview"><noscript><img class="post_cover-image" src="https://uploads.toptal.io/blog/cover_image/120626/side_list_cover-image_0-b59f10cf77d2ed5bd2f6ef5e5dc2aa04.png" /></noscript><span class="post_cover-image" data-role="deferred" data-src="https://uploads.toptal.io/blog/cover_image/120626/side_list_cover-image_0-b59f10cf77d2ed5bd2f6ef5e5dc2aa04.png"></span></span><span class="post-preview"><span class="post-title">The Ultimate eCommerce Website Design Guide</span><span class="post_meta"><span class="post_meta-date">14 days ago</span></span></span></a><a class="post is-preview blog-trending-item" href="/designers/data-visualization/data-visualization-best-practices"><span class="post_cover is-preview"><noscript><img class="post_cover-image" src="https://uploads.toptal.io/blog/cover_image/120624/side_list_cover-image_0-344a423354035d2d847f78c8624a513c.png" /></noscript><span class="post_cover-image" data-role="deferred" data-src="https://uploads.toptal.io/blog/cover_image/120624/side_list_cover-image_0-344a423354035d2d847f78c8624a513c.png"></span></span><span class="post-preview"><span class="post-title">Data Visualization - Best Practices and Foundations</span><span class="post_meta"><span class="post_meta-date">19 days ago</span></span></span></a><a class="post is-preview blog-trending-item" href="/designers/shopify-website-design/shopify-design-tips"><span class="post_cover is-preview"><noscript><img class="post_cover-image" src="https://uploads.toptal.io/blog/cover_image/120622/side_list_cover-image_0-facc84c525425b7e609dc454eda3b919.png" /></noscript><span class="post_cover-image" data-role="deferred" data-src="https://uploads.toptal.io/blog/cover_image/120622/side_list_cover-image_0-facc84c525425b7e609dc454eda3b919.png"></span></span><span class="post-preview"><span class="post-title">Shopify Design Tips and UX Best Practices</span><span class="post_meta"><span class="post_meta-date">21 days ago</span></span></span></a><a class="post is-preview blog-trending-item" href="/designers/ux/roi-of-ux-convince-executives"><span class="post_cover is-preview"><noscript><img class="post_cover-image" src="https://uploads.toptal.io/blog/cover_image/120617/side_list_cover-image_0-37bb513950690d17e57173f39c70f165.png" /></noscript><span class="post_cover-image" data-role="deferred" data-src="https://uploads.toptal.io/blog/cover_image/120617/side_list_cover-image_0-37bb513950690d17e57173f39c70f165.png"></span></span><span class="post-preview"><span class="post-title">The True ROI of UX: Convincing the Executive Suite</span><span class="post_meta"><span class="post_meta-date">26 days ago</span></span></span></a></nav></div><div class="blog-block-header">Relevant Technologies</div><div class="blog-block"><div class="blog-block-row"><ul class="blog-relevant"><li class="blog-relevant-item"><a class="link is-blue" href="https://www.toptal.com/designers/ux">UX</a></li><li class="blog-relevant-item"><a class="link is-blue" href="https://www.toptal.com/designers/icon">Icon</a></li><li class="blog-relevant-item"><a class="link is-blue" href="https://www.toptal.com/designers/ui">UI</a></li></ul></div></div><div class="blog-block has-no_background blog_banner for-author blog_author_banner" data-ga-action="ClickedOnHireTheAuthor_lateral" data-ga-label="icon-usability-and-design" data-view="content#sidebar_banner"><div class="blog-block-header">About the author</div><div class="blog_author_banner-photo_wrapper"><img alt="Micah Bowers" class="blog_author_banner-photo" src="https://uploads.toptal.io/user/photo/241853/large_af8544ccbb8119b6abe6938463505ff0.jpg" /></div><div class="blog_author_banner-content" data-role="author_content"><div class="blog_author_banner-name"><a href="/designers/resume/micah-bowers">Micah Bowers</a></div><div class="blog_author_banner-role">Designer</div><div class="blog_author_banner-about" data-role="author_about">Micah is a brand designer and illustrator who aspires to elevate design to the level of a story. To reach people and forge lasting engagement, Micah believes that design must identify a need, stir a desire for change, and shed light on a path that is uniquely helpful, hopeful, and human.</div><div class="blog_author_banner-content_footer"></div></div><div class="blog_author_banner-cta"><a class="button is-green_candy is-default is-full_width" data-role="banner_link" href="https://www.toptal.com/hire?interested_in=designers&amp;skill=ui">Hire the Author</a></div></div></div></div></div></section></main><footer class="hide_in_webview"><section class="grid-row has-solid_blue_bg page_footer_map-wrapper"><div class="grid-row-inner has-huge_padding page_footer_map"><div class="page_footer_map-content">Toptal connects the&nbsp;<a href="https://www.toptal.com/top-3-percent">top&nbsp;3%</a> of&nbsp;freelance talent all over&nbsp;the&nbsp;world.</div></div></section><section class="grid-row page_footer_sample_profile-wrapper"><div class="grid-row-inner has-big_padding"><h2 class="header is-row">Toptal Designers</h2><div class="skills_list"><ul class="multi_column_list qa-skills_list"><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/creative-direction">Creative Directors</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/freelance">Freelance Designers</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/graphic">Graphic Designers</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/illustration">Illustrators</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/logo">Logo Designers</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/mobile">Mobile App Designers</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/product-design">Product Designers</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/ui">UI Designers</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/ux">UX Designers</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/visual">Visual Designers</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/web">Web Designers</a></li></ul><div class="skills_list-see_all_wrapper"><a class="button is-tiny is-white is-uppercased" href="https://www.toptal.com/designers"><div class="skills_list-see_all_icon for-designers"></div>See more freelance designers</a></div></div></div></section><div class="skills_enterprise_link"><a class="skills_enterprise_link-url" href="/enterprise">Learn how enterprises benefit from Toptal experts.</a></div><section class="grid-row has-top_border page_footer_join-wrapper" id=""><div class="grid-row-inner has-padding page_footer_join"><h2 class="page_footer_join-header">Join the Toptal community.</h2><div class="page_footer_join-spacer"></div><nav class="page_footer_join-actions"><div class="page_footer_join-item"><a class="button is-green_candy is-big is-fixed page_footer_join-button" href="https://www.toptal.com/hire?interested_in=designers&amp;skill=ui">Hire a designer</a></div><div class="page_footer_join-item is-or">or</div><div class="page_footer_join-item"><a class="button is-green_candy is-big is-fixed page_footer_join-button" href="https://www.toptal.com/designers/join">Apply as a Designer</a></div></nav></div></section><section class="grid-row page_footer_links-wrapper"><div class="grid-row-inner is-wide has-big_padding"><nav class="page_footer_links"><section class="page_footer_links-column is-1"><h3 class="page_footer_links-column_header">Highest In-Demand Talent</h3><ul class="page_footer_links-list"><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/ios">iOS Developers</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/front-end">Front-End Developers</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/designers/ux">UX Designers</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/designers/ui">UI Designers</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/finance/financial-modeling">Financial Modeling Consultants</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/finance/interim-cfos">Interim CFOs</a></li></ul></section><section class="page_footer_links-column is-2"><h3 class="page_footer_links-column_header">About</h3><ul class="page_footer_links-list"><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/top-3-percent">Top 3%</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/clients">Clients</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/developers">Freelance Developers</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/designers">Freelance Designers</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/finance">Freelance Finance Experts</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/about">About Us</a></li></ul></section><section class="page_footer_links-column is-3"><h3 class="page_footer_links-column_header">Contact</h3><ul class="page_footer_links-list"><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/contact">Contact Us</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/press-center">Press Center</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/careers">Careers</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/faq">FAQ</a></li></ul></section><section class="page_footer_links-column is-4"><h3 class="page_footer_links-column_header">Social</h3><ul class="page_footer_links-list"><li class="page_footer_links-item for-social_link"><a class="page_footer_links-social_link is-facebook" href="https://www.facebook.com/toptal">Facebook</a></li><li class="page_footer_links-item for-social_link"><a class="page_footer_links-social_link is-twitter" href="https://twitter.com/toptal">Twitter</a></li><li class="page_footer_links-item for-social_link"><a class="page_footer_links-social_link is-google" href="https://plus.google.com/+Toptalllc/">Google+</a></li><li class="page_footer_links-item for-social_link"><a class="page_footer_links-social_link is-linkedin" href="https://www.linkedin.com/company/toptal">LinkedIn</a></li></ul></section></nav></div></section><section class="grid-row page_footer_legal-wrapper"><div class="grid-row-inner has-medium_padding page_footer_legal is-wide"><div class="logo-wrapper page_footer_legal-logotype"><a class="logo is-mini is-link" href="https://www.toptal.com/">Toptal</a><p class="logo-motto is-mini">Hire the top 3% of freelance talent</p></div><ul class="page_footer_legal-links"><li class="page_footer_legal-links_item is-copyright"><p class="page_footer_legal-copyright">© Copyright 2010 - 2018 Toptal, LLC</p></li><li class="page_footer_legal-links_item has-right_margin"><a class="page_footer_legal-link" href="https://www.toptal.com/privacy">Privacy Policy</a></li><li class="page_footer_legal-links_item"><a class="page_footer_legal-link" href="https://www.toptal.com/tos">Website Terms</a></li></ul></div></section></footer></div><div class="layout-overlay" data-view="layout#overlay"></div><div data-view="bounce_modals#events"><div data-view="bounce_modals#modal"></div></div><div class="notification-container" data-view="notifications#service"></div><script>setTimeout(function () {
  classNameWithFont = document.documentElement.className + ' wf-active'
  document.documentElement.className = classNameWithFont
}, 0);</script><script src="https://assets.toptal.io/assets/public-0d145eb3d4d61ecef414ecf3f7b7a330c5d9e8b1.js"></script><script src="https://assets.toptal.io/assets/blog-0d145eb3d4d61ecef414ecf3f7b7a330c5d9e8b1.js"></script><script src="https://assets.toptal.io/assets/cookie_banner-0d145eb3d4d61ecef414ecf3f7b7a330c5d9e8b1.js"></script><div class="cookie_banner-container" data-allow="Got it" data-cookie-policy-type="privacy_shield" data-message="By continuing to use this site you agree to our &lt;a href=&#39;https://www.toptal.com/cookie-policy&#39;&gt;Cookie Policy&lt;/a&gt;." data-reload="false"></div><script>Widgets && new Widgets.CookieBanner(document.querySelector('.cookie_banner-container'))</script><div class="layout-counters"><script>if (typeof(window.Widgets) !== 'undefined') {
  var appId = 'UA-21104039-1';
  if (appId.length > 0 && !(window.googleAnalytics instanceof Widgets.GoogleAnalytics)) {
    window.googleAnalytics = new Widgets.GoogleAnalytics(
      appId,
      'auto',
      false
    );
    window.googleAnalytics.bucketRole('', '');

    if (typeof(window.gon) !== 'undefined' && gon['ga_settings']){
      window.googleAnalytics.grouping(gon['ga_settings']['group']);
    }

    if (typeof(window.gon) !== 'undefined' && gon['chameleon_current_experiments']) {
      for (var experiment_key in gon['chameleon_current_experiments']) {
        var experiment = gon['chameleon_current_experiments'][experiment_key];
        if (experiment.google_analytics_dimension !== null) {
          window.googleAnalytics.set(experiment.google_analytics_dimension, experiment.variant_key);
        }
      }
    }

    window.googleAnalytics.trackPageview();
    window.googleAnalytics.track15secondsRead();
  }
}</script><script async="" defer="" src="https://cdn.distiltag.com/api/v1/script/A6qhozMiYLpV2VKc8wSHaEmc3saOMhcrxAFcCFAt?GA_TID=UA-21104039-1&amp;GA_CDI=14" type="text/javascript"></script><noscript><img src="https://cdn.distiltag.com/api/v1/noscript/A6qhozMiYLpV2VKc8wSHaEmc3saOMhcrxAFcCFAt?GA_TID=UA-21104039-1&amp;amp;GA_CDI=14" /></noscript><script>// We are checking if window.analytics has the track function in case some dom element has the id equal analytics
if (!window.analytics || typeof window.analytics.track !== 'function') {
  // We do this because if some dom element has id equal analytics we need to override it, otherwise it wouldn't set analytics right
  window.analytics = undefined
  !function(){var analytics=window.analytics=window.analytics||[];if(!analytics.initialize)if(analytics.invoked)window.console&&console.error&&console.error("Segment snippet included twice.");else{analytics.invoked=!0;analytics.methods=["setAnonymousId", "trackSubmit","trackClick","trackLink","trackForm","pageview","identify","group","track","ready","alias","page","once","off","on"];analytics.factory=function(t){return function(){var e=Array.prototype.slice.call(arguments);e.unshift(t);analytics.push(e);return analytics}};for(var t=0;t<analytics.methods.length;t++){var e=analytics.methods[t];analytics[e]=analytics.factory(e)}analytics.load=function(t){var e=document.createElement("script");e.type="text/javascript";e.async=!0;e.src=("https:"===document.location.protocol?"https://":"http://")+"cdn.segment.com/analytics.js/v1/"+t+"/analytics.min.js";var n=document.getElementsByTagName("script")[0];n.parentNode.insertBefore(e,n)};analytics.SNIPPET_VERSION="3.0.1";
  analytics.load('jnS4QsHOCAOeG6XvMDCjD9n9bAcQ53Mb');
  }}();
}
(function() {
  function readVisitorIdCookie() {
    var cookieName = 'visitor_id=';
    var cookies = document.cookie.split(';');
    for (var i = 0; i < cookies.length; i++) {
      var cookie = cookies[i].replace(/^\s+|\s+$/g, '');
      if (cookie.indexOf(cookieName) === 0) {
        return cookie.split('=')[1];
      }
    }
  }
  analytics.setAnonymousId(readVisitorIdCookie());
  
  analytics.page('posts#show');
})();</script><script async="" defer="" id="hs-script-loader" src="//js.hs-scripts.com/2799924.js" type="text/javascript"></script><script>var _hsq = window._hsq = window._hsq || [];
</script><script src="https://tribl.io/footer.js?orgId=EdOAdeaAj8s34gqB05v6"></script><script>!function(f,b,e,v,n,t,s)
{if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};
if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];
s.parentNode.insertBefore(t,s)}(window,document,'script',
'https://connect.facebook.net/en_US/fbevents.js');

fbq('init', '463369723801939');
fbq('track', 'ViewContent');</script><noscript><img height="1" src="https://www.facebook.com/tr?id=463369723801939&amp;ev=ViewContent&amp;noscript=1" width="1" /></noscript><iframe frameborder="0" height="1" scrolling="no" src="https://www.attributiontracker.com/tracker/account_visit?tt_visit=1" width="1"></iframe><script>(function(A, d, S, t, a, g, e) {
  A['AdstageAnalytics'] = a;
  A[a] = A[a] || function() {
    (A[a].q = A[a].q || []).push(arguments)
  };
  A[a].l = 1 * new Date();
  g = d.createElement(S), e = d.getElementsByTagName(S)[0];
  g.async = 1;
  g.src = t;
  e.parentNode.insertBefore(g, e);
})(window, document, 'script', '//assets.adstage.io/analytics.js', '_as');
_as('create', 'e2dd65eb-07a1-4d93-874a-fe6dac5a8b64');
_as('send', 'pageview');</script><script>setTimeout(function(){var a=document.createElement("script");
var b=document.getElementsByTagName("script")[0];
a.src=document.location.protocol+"//dnn506yrbagrg.cloudfront.net/pages/scripts/0012/5977.js?"+Math.floor(new Date().getTime()/3600000);
a.async=true;a.type="text/javascript";b.parentNode.insertBefore(a,b)}, 1);</script><script>_bizo_data_partner_id = "8663";
(function() {
  var s = document.getElementsByTagName("script")[0];
  var b = document.createElement("script");
  b.type = "text/javascript";
  b.async = true;
  b.src = (window.location.protocol === "https:" ? "https://sjs" : "http://js") + ".bizographics.com/insight.min.js";
  s.parentNode.insertBefore(b, s);
})();</script><noscript><img alt="" height="1" src="//www.bizographics.com/collect/?pid=8663&amp;fmt=gif" style="display:none;" width="1" /></noscript></div><div id="breadcrumbs" class="breadcrumbs"><span itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url" href="https://www.toptal.com/"><span itemprop="title">Home</span></a></span> &rsaquo; <span itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url" href="https://www.toptal.com/developers/blog"><span itemprop="title">Blog</span></a></span> &rsaquo; <span itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb"><a class="current" itemprop="url" href="/designers/ui/icon-usability-and-design"><span itemprop="title">Icon Usability and Design Best Practices</span></a></span></div></body></html>