<!DOCTYPE html><!--[if IE 7]><html class="layout-wrapper ie ie7 lte9 lte8 lte7"><![endif]--><!--[if IE 8]><html class="layout-wrapper ie ie8 lte9 lte8"><![endif]--><!--[if IE 9]><html class="layout-wrapper ie ie9 lte9"><![endif]--><!--[if (gte IE 9)|!(IE)]<!--><html class="layout-wrapper"><head><title>Adobe XD Review | Toptal</title>
<meta name="description" content="Great features and seamless integration with the Adobe ecosystem makes Adobe XD a powerful design tool. In this Adobe XD review we’ll explain the details." />
<link rel="alternate" href="https://www.toptal.com/designers/adobe/adobe-xd-review" hreflang="en" />
<link rel="canonical" href="https://www.toptal.com/designers/adobe/adobe-xd-review" />
<meta property="og:image" content="https://uploads.toptal.io/blog/post_image/120988/image_8-762ed5f9af4dbb7c24a4d2b2181f3756.png" />
<meta property="og:title" content="Design with Precision - an Adobe XD Review" />
<meta property="og:description" content="Great features and seamless integration with the Adobe ecosystem makes Adobe XD a powerful design tool. In this Adobe XD review we’ll explain the details." />
<meta property="og:site_name" content="Toptal Design Blog" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="DC.date.issued" content="2018-12-20" /><meta charset="utf-8" /><meta content="IE=edge,chrome=1" http-equiv="X-UA-Compatible" />
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"e3359cee6b","applicationID":"30100511","transactionName":"JV0NEUYJCQkARxgVEwReCgYbFgoWEUYYFg4JRQ==","queueTime":0,"applicationTime":117,"agent":""}</script>
<script type="text/javascript">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</script><meta content="width=device-width, initial-scale=1.0" name="viewport" /><script>(function(w,d,s,l,i){
  w[l]=w[l]||[];
  w[l].push({
    'gtm.start': new Date().getTime(),
    event:'gtm.js'
  });
  var f=d.getElementsByTagName(s)[0],
      j=d.createElement(s),
      dl=l!='dataLayer'?'&l='+l:'';
  j.async=true;
  j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;
  f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-K4WD79L');</script><script>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</script>
<link href="https://assets.toptal.io/assets/front/static/favicons/favicon_ca7136.png" rel="icon" /><!--[if IE]><link href="https://assets.toptal.io/assets/front/static/favicons/favicon_68b340.ico" rel="shortcut icon" /><![endif]--><link href="https://assets.toptal.io/assets/front/static/favicons/touch_x57_f72647.png" rel="apple-touch-icon-precomposed" sizes="57x57" /><link href="https://assets.toptal.io/assets/front/static/favicons/touch_x72_516451.png" rel="apple-touch-icon-precomposed" sizes="72x72" /><link href="https://assets.toptal.io/assets/front/static/favicons/touch_x114_1798a8.png" rel="apple-touch-icon-precomposed" sizes="114x114" /><link href="https://assets.toptal.io/assets/front/static/favicons/touch_x57_f72647.png" rel="apple-touch-icon-precomposed" /><script src="https://assets.toptal.io/assets/jquery_and_modernizr-73e6ee8a8c1ddc864a7aa3e01cc292ecefeaa0cf.js"></script><script>// TODO: Figure out how to override Modernizr test
(function () {
  var isIE, isIE11, noFlexboxClassName;
  isIE = /MSIE/.test(navigator.userAgent) && !/Opera/.test(navigator.userAgent);
  isIE11 = window.MSInputMethodContext && !/\bEdge\/[0-9.]+$/.test(navigator.userAgent);
  if (window.Modernizr && window.Modernizr.flexbox && (isIE || isIE11)) {
    noFlexboxClassName = document.documentElement.className.replace(/\bflexbox\b/, 'no-flexbox ie-flexbox');
    document.documentElement.className = noFlexboxClassName;
  }
})();</script><script>
//<![CDATA[
window.gon={};gon.flash={};gon.env="production";gon.signedin=false;gon.check_session_url="https:\/\/www.toptal.com\/signed_in";gon.shorten_url="https:\/\/www.toptal.com\/shorten_url";gon.geo_target_url="https:\/\/www.toptal.com\/api\/geo_target";gon.recaptcha_site_key="6LfgR1UUAAAAAJ8-zrjvTk18gKat-4CdBPSrUJoR";gon.recaptcha_url="https:\/\/www.google.com\/recaptcha\/api.js";gon.google_api_browser_key="AIzaSyDED9v55b-c1opDYMEDYBkOgDFGlBMICGY";gon.google_js_maps_key="AIzaSyDspLQumHNqilmD5UHddqqpSjwY1AJpVd0";gon.google_places_api_key="AIzaSyBcP-ExZ1pLLRX2Adlc-faZpjwC3raVQI4";gon.ga_settings={"group":"Blog posts"};gon.current_vertical="designers";gon.url_share_counter=0;gon.chameleon_current_experiments={"bounce_modal_blog":{"google_analytics_dimension":"dimension16","variant_key":"switched_on"},"blog_post_ux_experiments":{"google_analytics_dimension":"dimension9","variant_key":"reading_time_and_progress_bar"}};gon.bounce_modal_settings={"show":true,"type":"fullscreen","current_vertical_role_type":"Designer","template_options":{"blog":{"bundle_name":"blog_designers","submit_path":"https:\/\/www.toptal.com\/blog\/subscription","form_vertical":"designers","blog_image":"designers","blog_type":"Toptal Design Blog","subtitle":"for the latest design tutorials and exploration of current trends.","articles":[{"url":"https:\/\/www.toptal.com\/designers\/adobe\/adobe-xd-review","image":"https:\/\/uploads.toptal.io\/blog\/cover_image\/120771\/list_inside_cover-image_0-eaba2ea424aa81830010743e541067e0.png","title":"Design with Precision - an Adobe XD Review","author":"Lex Valishvili","author_image":"https:\/\/uploads.toptal.io\/user\/photo\/529587\/small_8512abf260370db358965068ab423452.jpg","author_position":"Designer"},{"url":"https:\/\/www.toptal.com\/designers\/typography\/web-typography-infographic","image":"https:\/\/uploads.toptal.io\/blog\/cover_image\/120770\/list_inside_cover-1210-Guide-to-Web-Typography-Luke_Wide-77433e5c33611234abd31bcb75f7723d.png","title":"Designing for Readability - A Guide to Web Typography (with Infographic)","author":"Jordan DeVos","author_image":"https:\/\/uploads.toptal.io\/user\/photo\/537174\/small_6cbebcbfbe77d589031c84870016d135.jpg","author_position":"Designer"},{"url":"https:\/\/www.toptal.com\/designers\/ui\/principles-of-design","image":"https:\/\/uploads.toptal.io\/blog\/cover_image\/120766\/list_inside_cover-image_0-6570827bba5c0b05395bbb4094e0c105.png","title":"The Principles of Design and Their Importance","author":"Cameron Chapman","author_image":"https:\/\/uploads.toptal.io\/avatar\/external_author_photo\/120766\/Cameron-869ebe1c5036a3b2480339378d36fcdf.jpg","author_position":"Design Blog Editor"}]},"fullscreen":{"subtitle":"designers","bounce_modal_header_skill":"Adobe Creative Suite experts","verticals":["developers","designers","finance_experts","project_managers"],"for_projects":false,"email_validation_api_path":"https:\/\/www.toptal.com\/giorgio\/api\/company_email_validations","submit_path":"https:\/\/www.toptal.com\/giorgio\/api\/leads","default_vertical":"designers"}},"skill":"Adobe","role":"designers"};gon.current_skill_name="Adobe";gon.current_skill_name_overriden_singular="Adobe Creative Suite expert";gon.current_skill_name_overriden_plural="Adobe Creative Suite experts";
//]]>
</script><link rel="stylesheet" media="screen" href="https://assets.toptal.io/assets/public_styles-73e6ee8a8c1ddc864a7aa3e01cc292ecefeaa0cf.css" /><link rel="stylesheet" media="screen" href="https://assets.toptal.io/assets/portal_styles-73e6ee8a8c1ddc864a7aa3e01cc292ecefeaa0cf.css" /><link rel="stylesheet" media="screen" href="https://assets.toptal.io/assets/blog_styles-73e6ee8a8c1ddc864a7aa3e01cc292ecefeaa0cf.css" /><script>if(!window.appinfo) {
  var thens = []
  var catches = []
  var LocalPromise = {
    then: function(callback, error) {
      thens.push(callback)
      if (error) {
        catches.push(error)
      }
    },
    catch: function (error) {
      catches.push(error)
    }
  }
  var resolve = function() {
    var args = arguments
    thens.forEach(function(callback) {
      callback.apply(null, args)
    })
  }
  var reject = function() {
    var args = arguments
    catches.forEach(function(callback) {
      callback.apply(null, args)
    })
  }

  window.onAppInfoLoaded = LocalPromise

  window.onAppinfoLoad = function() {
    document.cookie = 'appinfo_id_status=doing_request;'

    window.appinfo.grab('https://appinfo.toptal.com', {
      data: gon['application_info_data'] || {},
      callback: function(response, error) {
        if (!error) {
          document.cookie = 'appinfo_id_status=request_completed;'

          resolve({
            applicationInfo: response.data
          })
        } else {
          document.cookie = 'appinfo_id_status=request_failed;'
        }
      }
    })
  }

  document.cookie = 'appinfo_id_status=loading_script;'

  var script = document.createElement('script')
  script.type = 'text/javascript'
  script.onError = function() {
    document.cookie = 'appinfo_id_status=script_load_failed;'
    reject()
  }
  script.src = 'https://appinfo.toptal.com/script.js'
  document.getElementsByTagName('head')[0].appendChild(script)
}</script></head><body class="layout" data-view="layout#body" id="top"><div class="layout_layer" data-view="layout#layout"><header class="page_header hide_in_webview" data-role="fixed-header"><div class="page_header_line"></div><div class="page_header" data-view="layout#menu"><div class="blog-simple-header grid-row is-light_gray" data-role="main_menu_wrapper"><div class="grid-row-inner is-wide has-padding page_header_top"><div class="page_header_top-logotype_wrapper"><div class="page_header_top-logotype"><a class="logo is-big is-link" href="https://www.toptal.com/designers"></a></div><div class="page_header_top-main_title"><b>Hiring?</b> Toptal handpicks <b><a href="https://www.toptal.com/designers/adobe" onclick='window.googleAnalytics.trackEvent(event, "BlogCTAs", "ClickedOnHeaderHeadline", "ClickedOnHeaderHeadline")'>top Adobe Creative Suite experts</a></b> to suit your needs.</div></div><a class="page_header_top-expand" data-role="expand_menu" href="#"><span class="page_header_top-expand_icon"></span></a><nav class="page_header_top-nav_wrapper"><ul class="page_header_top-nav"><li class="page_header_top-nav_item"><a class="button is-green_candy is-small page_header_top-nav_link is-button" data-role="companies_apply_button" href="https://www.toptal.com/designers/adobe" onclick="window.googleAnalytics.trackEvent(event, &quot;BlogCTAs&quot;, &quot;ClickedOnHeaderCTA&quot;, &quot;ClickedOnHeaderCTA&quot;);">Start hiring</a></li><li class="page_header_top-nav_item"><a class="button is-small is-light page_header_top-nav_link is-button" href="https://www.toptal.com/users/login">Log in</a></li></ul></nav></div></div><nav class="grid-row has-top_border is-light_gray page_header_menu-wrapper" data-role="main_menu_wrapper"><div class="grid-row-inner is-wide has-small_padding page_header_menu"><div class="page_header_menu-items-wrapper"><ul class="page_header_menu-items" data-role="menu"><li class="page_header_menu-item is-home"><a class="page_header_menu-link" href="https://www.toptal.com/designers"></a></li><li class="page_header_menu-item is-top-3-percent"><a class="page_header_menu-link" href="https://www.toptal.com/top-3-percent">Top 3%</a></li><li class="page_header_menu-item is-why"><a class="page_header_menu-link" href="https://www.toptal.com/why">Why</a></li><li class="page_header_menu-item is-clients"><a class="page_header_menu-link" href="https://www.toptal.com/clients">Clients</a></li><li class="page_header_menu-item is-enterprise"><a class="page_header_menu-link" href="https://www.toptal.com/enterprise">Enterprise</a></li><li class="page_header_menu-item is-community"><a class="page_header_menu-link" href="https://www.toptal.com/community">Community</a></li><li class="page_header_menu-item is-blog"><a class="page_header_menu-link" href="https://www.toptal.com/designers/blog">Blog</a></li><li class="page_header_menu-item is-about"><a class="page_header_menu-link" href="https://www.toptal.com/about">About Us</a></li><li class="page_header_menu-item is-join"><a class="button is-green_candy is-small page_hader_menu-button" data-role="companies_apply_button" href="https://www.toptal.com/designers/adobe" onclick="window.googleAnalytics.trackEvent(event, &quot;BlogCTAs&quot;, &quot;ClickedOnHeaderCTA&quot;, &quot;ClickedOnHeaderCTA&quot;);">Start hiring</a></li><li class="page_header_menu-item is-join"><a class="button is-green_candy is-small page_hader_menu-button" href="https://www.toptal.com/designers/join">Apply as a Designer</a></li><li class="page_header_menu-item is-login"><a class="button is-light is-small page_hader_menu-button is-login" href="https://www.toptal.com/users/login">Login</a></li><li class="page_header_menu-item is-contacts"><ul class="page_header_menu-contact-items is-replaceable"><li class="page_header_menu-contact-item is-contact">Questions?</li><li class="page_header_menu-contact-item is-contact"><a class="link is-dotted page_header_menu-contact-link" href="https://www.toptal.com/contact">Contact Us</a></li><li class="page_header_menu-contact-item"><a class="page_header_menu-contact-link is-social is-facebook" href="https://www.facebook.com/toptal" target="_blank"><span class="page_header_menu-contact-link-icon"></span></a></li><li class="page_header_menu-contact-item"><a class="page_header_menu-contact-link is-social is-twitter" href="https://twitter.com/toptal" target="_blank"><span class="page_header_menu-contact-link-icon"></span></a></li><li class="page_header_menu-contact-item"><a class="page_header_menu-contact-link is-social is-linkedin" href="https://www.linkedin.com/company/toptal" target="_blank"><span class="page_header_menu-contact-link-icon"></span></a></li></ul></li></ul></div><div class="blog_search" data-view="quick_search#search_field" data-vertical="Designer"><form class="blog_search-form" data-role="form"><input autocomplete="off" class="blog_search-field" data-role="field" name="text" placeholder="Search Topics" type="text" /><button class="button is-tiny blog_search-submit"><span class="blog_search-submit_icon"></span></button></form><div class="blog_search-suggestions" data-role="suggestions_wrapper"></div><div class="blog_search_results" data-role="results" style="display: none;"></div></div><a class="button is-green_candy is-tiny for-page_header_menu page_header_menu-hire" data-role="companies_apply_button" href="https://www.toptal.com/hire?interested_in=designers&amp;skill=adobe">Hire a designer</a></div></nav><nav class="blog-simple-header grid-row page_header_menu-wrapper is-fixed" data-role="sticky_menu_wrapper"><div class="grid-row-inner is-wide page_header_menu has-padding"><div class="page_header_top-logotype_wrapper"><div class="page_header_top-logotype"><a class="logo is-big is-link" href="https://www.toptal.com/designers"></a></div><div class="page_header_top-main_title"><b>Hiring?</b> Toptal handpicks <b><a href="https://www.toptal.com/designers/adobe" onclick='window.googleAnalytics.trackEvent(event, "BlogCTAs", "ClickedOnHeaderHeadline", "ClickedOnHeaderHeadline")'>top Adobe Creative Suite experts</a></b> to suit your needs.</div></div><nav class="page_header_top-nav_wrapper"><ul class="page_header_top-nav" data-role="menu"><li class="page_header_top-nav_item"><a class="button is-green_candy is-small page_header_top-nav_link is-button" data-role="companies_apply_button" href="https://www.toptal.com/designers/adobe" onclick="window.googleAnalytics.trackEvent(event, &quot;BlogCTAs&quot;, &quot;ClickedOnHeaderCTA&quot;, &quot;ClickedOnHeaderCTA&quot;);">Start hiring</a></li><li class="page_header_top-nav_item"><a class="button is-small is-light page_header_top-nav_link is-button" href="https://www.toptal.com/users/login">Log in</a></li></ul></nav></div></nav></div></header><main class="layout-main"><div class="reading-progress" data-view="content#reading_progress"></div><header class="grid-row has-top_border has-bottom_border post_cover is-post"><div class="grid-row-inner is-wide has-big_padding blog_title for-show"></div></header><article class="grid-row is-transparent"><div class="grid-row-inner is-wide"><div class="post_title"><div class="post_title-header"><p class="post-reading_time" data-view="content#reading_time" data-minutes="7">7 min read</p><h1 class="post_title-text">Design with Precision - an Adobe XD Review</h1></div><a class="post_title-back" href="https://www.toptal.com/designers/blog">View all articles</a></div></div></article><section class="grid-row has-top_border is-transparent has-no_border" data-view="" id="main_content"><div class="grid-row-inner has-medium_padding two_columns_layout is-wide"><div class="two_columns_layout-content"><div class="post is-full"><div class="post_meta-wrapper post_header"><div class="post_header-triangle"></div><div class="post_avatar post_meta-avatar"><img width="50" class="post_avatar-image" src="https://uploads.toptal.io/user/photo/529587/small_8512abf260370db358965068ab423452.jpg" /></div><div class="post_meta is-full"><div class="post_meta-author"><p>by <strong><a class="link is-blue" target="_blank" href="https://www.toptal.com/designers/resume/lex-valishvili">Lex Valishvili</a></strong> - Designer
@ <a class="link is-blue" target="_blank" href="https://www.toptal.com/">Toptal</a>
</p>
</div><div class="post_meta-tags"><a href="https://www.toptal.com/designers/blog/tags/interactiondesign">#InteractionDesign</a> <a href="https://www.toptal.com/designers/blog/tags/prototyping">#Prototyping</a> <a href="https://www.toptal.com/designers/blog/tags/ui">#UI</a> <a href="https://www.toptal.com/designers/blog/tags/ux">#UX</a></div></div><ul class="social_share is-horizontal is-small is-centered_on_mobile for-blog_post_heading" data-hashtags="UX,UI,Prototyping,InteractionDesign" data-url="https://www.toptal.com/designers/adobe/adobe-xd-review" data-view="layout#social_share" data-youtube-channel-url="https://www.youtube.com/channel/UCNqm_euTHZz3o5OnKhUS-oA"><li class="social_share-item is-counter" title="Total number of shares"><span class="social_share-item_num" data-role="counter_num">0</span><span class="social_share-item_text" data-role="counter_text">shares</span></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;twitter&quot;}" data-type="twitter" title="Share on Twitter"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/twitter_83c6d4.png" width="50" /></a></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;facebook&quot;}" data-type="facebook" title="Share on Facebook"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/facebook_dc66c9.png" width="50" /></a></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;linkedin&quot;}" data-type="linkedin" title="Share on LinkedIn"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/linkedin_b923c3.png" width="50" /></a></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;pocket&quot;}" data-type="pocket" title="Save to Pocket"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/pocket_e4260c.png" width="50" /></a></li></ul><div class="post_meta-extra"></div></div><div class="content_body" data-insert-middle-content="true" data-view="content#body"><p>As we wrap up 2018 and step into 2019, let’s review the current state of the design industry, the designer’s role, UX design tools, and workflow.</p>

<p>From building a cohesive design system to designing flows for the next device innovation or <a href="https://www.toptal.com/designers/prototyping">prototyping</a> complex interfaces for user testing, <a href="https://www.toptal.com/designers">designers</a> can choose from an <a href="https://www.toptal.com/designers/ux/best-ux-tools-infographic">abundance of UX design tools</a>. Whether it’s one of the more popular programs like <a href="https://www.toptal.com/designers/ux/adobe-xd-vs-sketch-which-tool">Sketch</a>, web-based <a href="https://www.figma.com/">Figma</a>, the aggressively growing <a href="https://www.adobe.com/products/xd.html">Adobe XD</a>, or newly-introduced <a href="https://www.invisionapp.com/studio">InVision Studio</a>—familiarity with the right <a href="https://www.toptal.com/designers/ux/top-ux-tools">UX design tool</a><a href="https://www.toptal.com/designers/ux/top-ux-tools">s</a> including this Adobe XD review will speed up the product design process.</p>

<p><img src="https://uploads.toptal.io/blog/image/127807/toptal-blog-image-1545164011287-212944e4392096211bdd3e58064bb086.png" alt="There's an overabundance of UX design tools." /></p>

<h2 id="choosing-the-right-ux-design-tool">Choosing the Right UX Design Tool</h2>

<p>While looking at the tools designers use, it’s important to note that designers’ responsibilities shift and expand constantly. Only 6-7 years ago, few people even understood what a <a href="https://www.toptal.com/designers/ux">user experience designer</a> did. These days it’s expected every designer to do at least some sort of <a href="https://www.toptal.com/designers/user-research">user research</a>, prototyping, and competitive analysis.</p>

<p>These shifts affect how designers need to look at their workflow, domain knowledge, techniques, and tools. Clients today expect to see not only a polished final product but everything from wireframing to prototyping to a smoothly animating UI.</p>

<p>Expanding your area of expertise is not just a way to make more money—it’s become a job requirement. New product design processes usually mean new tools, which means <a href="https://www.toptal.com/designers/digital">designers</a> needing to spend time learning how to use them—which is why the emergence of new design tools has accelerated so much in the past few years.</p>

<p><img src="https://uploads.toptal.io/blog/image/127808/toptal-blog-image-1545164019256-9c845803bd6aa62bc24111ca2d2ed3a1.png" alt="An Adobe XD prototype." /></p>

<div class="pop_out_box is-full_width" style="font-size:1em; text-align: center">Linked screens in an Adobe XD prototype project. </div>

<p>The days of designers relying on Photoshop as their main design tool are long gone. Now it’s a race for design software platforms to attract both beginners and professionals. Sketch has been a major player for several years, and Figma, having received<a href="https://blog.figma.com/figma-raises-25mm-series-b-896d701e6b5b"> financial backing</a> of over $46 million, is catching up with its web-based interactive prototyping tool.</p>

<p>Recently, prototyping platform InVision decided to enter the space with its own design tool, <a href="https://www.toptal.com/designers/ui/invision-studio-tutorial">Invision Studio</a>. It didn’t move as fast as everyone had hoped, so while Studio seems pretty solid, it’s still <a href="https://uxdesign.cc/invision-studio-is-out-but-are-designers-migrating-to-a-new-tool-again-102949210aeb">somewhat underwhelming</a> and notoriously buggy in spite of the initial hype.</p>

<p>After dominating the digital design universe for so long, Adobe is behind in this race for the ultimate UX/UI design tool. Not having the luxury of staying in that position for long… enter Adobe XD. Although a little late to the race, Adobe XD has grown in popularity and has become a promising contender since its release in 2016.</p>

<h2 id="adobe-xd-review-features-and-benefits">Adobe XD Review: Features and Benefits</h2>

<p>Some may say that an industry giant like Adobe is a dinosaur and not able to be as agile as its younger competitors. However, a company like Adobe has the resources to evolve rapidly, as well as the financial stability that would make mastering Adobe XD a good investment. This is a huge advantage, making Adobe XD very valuable, and potentially the leading UX design tool for the future.</p>

<p><img src="https://uploads.toptal.io/blog/image/127809/toptal-blog-image-1545164029266-eed24eb8dbc7ae0f574420a187ba1f2c.png" alt="An Adobe XD review." /></p>

<div class="pop_out_box is-full_width" style="font-size:1em; text-align: center">The Adobe Design Library Manager makes the workflow of creating design assets seamless.</div>

<p>Before we dive into reviewing Adobe XD features, let’s stop and ask, “is it even worth the time to learn a new tool that provides similar functionality to the tools we already know?” To answer that, let’s look at four criteria: price, ease of use, ecosystem, and market share.</p>

<h3 id="price">Price</h3>

<p>One of the factors in the early success of industry favorites like Sketch and Figma was their relative affordability. Adobe XD is a part of the <a href="https://www.adobe.com/creativecloud.html">Adobe Creative Cloud</a> subscription, which gives you access to over 20 apps like Photoshop, Illustrator, Premiere Pro, etc. for $50/month, so it’s hard to separate the price specifically for that product. Unless you already have a subscription, it may be difficult to justify spending so much on trying a new tool.</p>

<p>However, back in May 2018 Adobe announced <a href="https://news.adobe.com/press-release/creative-cloud/adobe-accelerates-experience-design-growth-starter-plan-adobe-xd">a starter plan</a> that allows the use of Adobe XD for free! It’s limited to only one active project but it’s a perfect way to test the waters and try all it has to offer.</p>

<h3 id="ease-of-use">Ease of Use</h3>

<p>Most digital designers have used an Adobe application at some point and are familiar with the general interface: tool panel on the left, the main area in the center, layers, etc. on the right. The beauty of Adobe XD is that you will feel at home as soon as you start using it. The learning curve is light and occurs mostly around more complex design systems and symbol overrides.</p>

<p>Like similar tools, Adobe XD handles complex design systems and symbol libraries. It also features intuitive tools for easily connecting screens and creating interactive prototypes that can be utilized in user testing without the need for code. The recent release of <a href="https://www.youtube.com/watch?v=NFV1iwhVClM">auto-animate</a> makes prototyping rich interactions even easier by automatically animating micro-interactions across artboards in Adobe XD.</p>

<p><img src="https://uploads.toptal.io/blog/image/127810/toptal-blog-image-1545164047251-c234fbbc717ac95fdb05be173417dfed.gif" alt="Adobe XD prototype examples." /></p>

<div class="pop_out_box is-full_width" style="font-size:1em; text-align: center">Adobe XD can create auto-animate transitions using a drag gesture.</div>

<h3 id="ecosystem">Ecosystem</h3>

<p>Having Adobe XD in the Adobe ecosystem is one of its strongest selling points because chances are you already have Creative Cloud, or use other Adobe products on a weekly basis. From vectors to photos, the suite of Adobe products has a dedicated tool for most designer needs that will work pretty smoothly with Adobe XD.</p>

<h3 id="market-share">Market Share</h3>

<p>In 2017 Adobe XD had an average rank in the market and couldn’t overshadow Sketch’s dominance. Fast forward two years and Adobe is catching up fast (with over 12 million Creative Cloud subscribers) and has demonstrated a big potential for continuing its rapid growth.</p>

<p>Going back to the question if it’s worth spending the time to learn a new design tool, one can think of it this way: if you have a hammer, you can hammer in a nail but you can’t remove a screw—and you never know when you will need to take out a screw. As Adobe XD gains in popularity, so do the chances of encountering a team or client that relies exclusively on Adobe products. The more tools a <a href="https://www.toptal.com/designers/visual">designer</a> has in their toolbox, the more design projects they will be able to tackle, and the more teams they will be able to work with effectively.</p>

<h2 id="a-growing-list-of-adobe-xd-features-and-plugins">A Growing List of Adobe XD Features and Plugins</h2>

<p>“Through integrations with Creative Cloud we can make our customers happier and more productive by connecting them seamlessly to all the services they use, and an endless supply of tools that extend our applications in powerful and custom ways.”– <a href="https://theblog.adobe.com/author/vijay-vachani/">Vijay Vachani</a>, Director, Head of Partner Platform &amp; Ecosystem, Adobe Creative Cloud.</p>

<p><img src="https://uploads.toptal.io/blog/image/127811/toptal-blog-image-1545164079721-533d48aeef2a76a7a064446d3febdf2d.png" alt="Adobe XD features, plugins, and add-ons." /></p>

<div class="pop_out_box is-full_width" style="font-size:1em; text-align: center">Plugins and integrations enhance the Adobe XD prototyping tool.</div>

<p>As “light and basic” as it might appear, Adobe XD’s interface handles complex design systems and symbol libraries, allowing designers to build and update intricate designs with ease. Just as important to the design and user testing process are the sophisticated XD prototype and animation tools. When a designer is ready to get feedback on designs, plugins by <a href="https://www.usertesting.com/blog/adobe-xd/">UserTesting</a> and Userlytics allows them to do that without leaving the program.</p>

<p>Creating the ultimate UX design tool that will have all the right features is what companies like InVision, Adobe, and others strive for. The task is massive and complicated, so one of the ways to accomplish this goal is for platforms to develop plugins (and encourage others to do the same).</p>

<p>Adobe’s recent announcement of a <a href="https://theblog.adobe.com/investing-future-creativity-announcing-adobe-fund-design/">$10 million Design Fund</a> for this exact purpose proves the importance of supporting plugins and incentivizing developers to create them. During the recent Adobe MAX conference, there were several important announcements around plugins, UI kits, and app integrations to expand Adobe XD’s utility.</p>

<p>While Sketch is a great design tool, what makes it <em>really</em> great is the availability of third-party plugins like <a href="https://sketchrunner.com/help.html">Runner</a>, <a href="https://github.com/getflourish/Sketch-Color-Contrast-Analyser">Color Accessibility Check</a>, <a href="https://magicsketch.io/mirror/">Magic Mirror</a>, <a href="https://animaapp.github.io">Auto Animate</a>, etc. Adobe XD is stepping up their game with plugins like <a href="https://renameit.design/">RenameIt</a>, <a href="https://helpx.adobe.com/xd/help/plugins.html">Pixel Perfect</a>, <a href="https://www.datapopulator.com/">Data Generator</a>, etc. and integrations with <a href="https://trello.com">Trello</a>, <a href="https://dribbble.com/">Dribbble</a>, <a href="https://www.google.com/sheets/about/">Google Sheets</a>, etc.</p>

<p><img src="https://uploads.toptal.io/blog/image/127812/toptal-blog-image-1545164092399-ba15e66b97a049fe8b62e8d9abd9c143.gif" alt="Adobe prototyping tool with a large number of available plugins." /></p>

<div class="pop_out_box is-full_width" style="font-size:1em; text-align: center">Adobe XD benefits include wide-availability of plugins and add-ons.</div>

<p>By pouring money into hosting and supporting emerging talent in <a href="https://www.adobe.com/about-adobe/creative-residency.html">Adobe Creative Residency</a> Adobe maintains the important advantage of its ecosystem. Another key element of future success is something else the Adobe XD team is doing well—listening to the end user and engaging them in the development process by inviting them to suggest and upvote the next features to be developed.</p>

<p>Since the beginning, Adobe XD was positioned as a “product from designers to designers” and they are faithfully staying that course. Every month, new sets of features are rolled out. For example, just in the past few months, Adobe introduced new Adobe XD features like Responsive Resize, Timed Transitions, Spell Check, <a href="https://theblog.adobe.com/adobe-xd-for-jira-cloud-streamline-design-to-development-workflows/">Jira integration</a>, and more.</p>

<p><img src="https://uploads.toptal.io/blog/image/127813/toptal-blog-image-1545164124708-78d39571cd95c16fe9ceee4d504a2d52.png" alt="Animating in Adobe XD, an Adobe prototyping tool." /></p>

<div class="pop_out_box is-full_width" style="font-size:1em; text-align: center">The auto-animation tool used in an Adobe XD prototype.</div>

<p>Adobe also recently announced the addition of <a href="https://theblog.adobe.com/introducing-voice-prototyping-in-adobe-xd/">voice prototyping</a> to the Adobe XD toolset. It’s not the most obvious feature you’d expect from a screen UI design tool, but voice command UIs are becoming more and more common.</p>

<p>From Siri to Alexa and other experiences beyond the screen, <a href="https://www.toptal.com/designers/ui/designing-a-vui">voice-based interaction</a> is gaining ground. Adobe XD’s unique <a href="https://www.youtube.com/watch?time_continue=26&amp;v=R7Pf1_DlT6I">voice prototyping gives designers the edge</a> to keep up with this rapidly growing trend.</p>

<h2 id="expanding-a-designers-toolbox">Expanding A Designer’s Toolbox</h2>

<p>Designers working with a variety of companies and on different projects will most likely need a spectrum of problem-solving skills. A broader design toolbox can be a <a href="https://www.toptal.com/designers/ux/ux-designer-portfolios">big advantage over other potential candidates</a>. This is especially important for freelancers who may be working with different clients every few months—sooner or later a project requiring expert knowledge of a specific design tool will come along. Not being familiar with that tool may mean the loss of potential engagement.</p>

<p>There is some argument about whether a designer should focus on expanding their repertoire vs. honing a particular specialization. Adobe XD is fast, free, and easy to learn—there’s nothing lost in taking the plunge and expanding your versatility.</p>

<div align="center">• • •</div>

<h3 id="further-reading-on-the-toptal-design-blog">Further reading on the Toptal Design Blog:</h3>

<ul>
  <li><a href="https://www.toptal.com/designers/ux/best-ux-tools-infographic">The Best UX Tools (with Infographic) </a></li>
  <li><a href="https://www.toptal.com/designers/ux/figma-vs-sketch">Figma vs. Sketch vs. Axure - a Task-Based Review </a></li>
  <li><a href="https://www.toptal.com/designers/ui/designing-a-vui">Designing a VUI – Voice User Interface </a></li>
  <li><a href="https://www.toptal.com/designers/ux/ux-designer-portfolios">The Best UX Designer Portfolios - Inspiring Case Studies and Examples</a></li>
  <li><a href="https://www.toptal.com/designers/ui/invision-studio-tutorial">Prototype with Ease - An InVision Studio Tutorial </a></li>
</ul>
<div class="post_key_learnings for-post"><h2 class="post_key_learnings-heading" data-disable_middle_content_placement="true">Understanding the Basics</h2><div class="post_key_learnings-item" data-animation-speed="450" data-hide-button="false" data-initial-state="expanded" data-view="ui#expander"><span class="post_key_learnings-item_arrow is-expanded" data-role="button"></span><h3 class="post_key_learnings-title is-expanded" data-disable_middle_content_placement="true" data-role="button">What is Adobe XD used for?</h3><p class="post_key_learnings-body" data-role="content">Adobe XD is the Adobe prototyping tool for user experience and interaction designers. Adobe XD features are used for creating wireframes, prototypes, and screen designs for digital products such as websites and mobile apps. </p></div><div class="post_key_learnings-item" data-animation-speed="450" data-hide-button="false" data-initial-state="collapsed" data-view="ui#expander"><span class="post_key_learnings-item_arrow is-collapsed" data-role="button"></span><h3 class="post_key_learnings-title is-collapsed" data-disable_middle_content_placement="true" data-role="button">Can Adobe XD open Sketch files?</h3><p class="post_key_learnings-body is-hidden" data-role="content">Adobe XD can open Sketch files and maintains partial support for many of the application’s main features such as symbols, pages, and some prototyping capabilities. This means users can switch easily from Sketch to Adobe XD features as needed to create an Adobe XD prototype.</p></div><div class="post_key_learnings-item" data-animation-speed="450" data-hide-button="false" data-initial-state="collapsed" data-view="ui#expander"><span class="post_key_learnings-item_arrow is-collapsed" data-role="button"></span><h3 class="post_key_learnings-title is-collapsed" data-disable_middle_content_placement="true" data-role="button">What is Sketch and InVision?</h3><p class="post_key_learnings-body is-hidden" data-role="content">Sketch is a screen design and prototyping tool. InVision is a platform for creating and sharing clickable prototypes. Adobe XD is the Adobe prototyping tool that has similar features to Sketch App and InVision Studio. </p></div><div class="post_key_learnings-item" data-animation-speed="450" data-hide-button="false" data-initial-state="collapsed" data-view="ui#expander"><span class="post_key_learnings-item_arrow is-collapsed" data-role="button"></span><h3 class="post_key_learnings-title is-collapsed" data-disable_middle_content_placement="true" data-role="button">What is the best prototyping tool?</h3><p class="post_key_learnings-body is-hidden" data-role="content">The best prototyping tool depends on the unique needs of the project, but industry favorites include Sketch App, InVision, Figma, and Adobe XD. Many of the Adobe XD features and tools are similar to its competitors like Sketch App. </p></div><div class="post_key_learnings-item" data-animation-speed="450" data-hide-button="false" data-initial-state="collapsed" data-view="ui#expander"><span class="post_key_learnings-item_arrow is-collapsed" data-role="button"></span><h3 class="post_key_learnings-title is-collapsed" data-disable_middle_content_placement="true" data-role="button">What is prototyping in UX?</h3><p class="post_key_learnings-body is-hidden" data-role="content">Prototyping is part of the UX design process where designers and product teams create models of varying fidelity and interactivity to mimic aspects of a design in progress. Designers can create an interactive Adobe XD prototype in the Adobe prototyping tool.</p></div><div class="post_key_learnings-item" data-animation-speed="450" data-hide-button="false" data-initial-state="collapsed" data-view="ui#expander"><span class="post_key_learnings-item_arrow is-collapsed" data-role="button"></span><h3 class="post_key_learnings-title is-collapsed" data-disable_middle_content_placement="true" data-role="button">What is UI prototyping?</h3><p class="post_key_learnings-body is-hidden" data-role="content">UI prototyping is the process of creating a prototype that models aspects of the user interface to be tried out and tested during the product design process. Designers can use Adobe XD features to design and develop UI prototypes for user testing and demonstration. </p></div></div><div class="blog_author_big_banner is-active" data-ga-action="ClickedOnHireTheAuthor_bottom" data-ga-label="adobe-xd-review" data-view="content#bottom_banner"><h2>About the author</h2><div class="skill_talent for-blog_post"><div class="skill_talent-extra"><a class="skill_talent-photo_wrapper" href="/designers/resume/lex-valishvili"><img alt="Lex Valishvili" class="skill_talent-photo" src="https://uploads.toptal.io/user/photo/529587/large_8512abf260370db358965068ab423452.jpg" /><div class="skill_talent-photo_hint">View full profile &raquo;</div></a><div class="blog_author_big_banner-cta"><a class="button is-green_candy is-default is-full_width is-fixed skill_talent-hire" data-role="banner_link" href="https://www.toptal.com/hire?interested_in=designers&amp;skill=adobe">Hire the Author</a></div></div><div class="skill_talent-main"><a class="link skill_talent-name" href="/designers/resume/lex-valishvili">Lex Valishvili, United States</a><div class="clearfix"><div class="skill_talent-member_since">member since May 3, 2017</div></div><div class="skill_talent-skills" data-view="skill_talent#tags"><a class="tag skill_talent-skill" data-role="tag" href="https://www.toptal.com/designers/sketch">Sketch</a><a class="tag skill_talent-skill" data-role="tag" href="https://www.toptal.com/designers/photoshop">Adobe Photoshop</a><a class="tag skill_talent-skill" data-role="tag" href="https://www.toptal.com/designers/adobe">Adobe CC</a><a class="tag skill_talent-skill" data-role="tag" href="https://www.toptal.com/designers/brand">Branding</a><a class="tag skill_talent-skill" data-role="tag" href="https://www.toptal.com/designers/dashboard-design">Dashboard Design</a><a class="tag skill_talent-skill" data-role="tag" href="https://www.toptal.com/designers/adobe">Adobe Experience Design (XD)</a><a class="tag skill_talent-skill" data-role="tag" href="https://www.toptal.com/designers/art-direction">Art Direction</a><a class="tag skill_talent-skill" data-role="tag" href="https://www.toptal.com/designers/ux">User Experience (UX)</a><a class="tag skill_talent-skill" data-role="tag" href="https://www.toptal.com/designers/ui">User Interface (UI)</a><a class="tag" data-role="more" href="/designers/resume/lex-valishvili" style="display: none;">+<span data-role='count'>&nbsp;&nbsp;</span> more</a></div><div class="skill_talent-description">Lex is a human-centered designer specializing in creating digital experiences that provide clear and interactive user experience, communicate a desirable message, and brings business results. With over six years of UX/UI, product design and branding experience, he strives to incorporate his knowledge and understanding of the design world and UX into every project. Previous clients range from early-stage startups to McKinsey &amp; Company. <a class="link" href="/designers/resume/lex-valishvili">[click to continue...]</a></div></div></div></div><div class="post-join"><a class="button is-white_and_green is-default is-full_width" href="https://www.toptal.com/designers/adobe">Hiring? Meet the Top 10 Freelance Adobe Creative Suite Experts for Hire in December 2018</a></div><div class="template" data-role="middle_content_template" data-template="{&quot;html&quot;:&quot;&lt;div class=\&quot;embeddable_form-wrapper for-post\&quot; data-role=\&quot;blog_subscribe\&quot; data-view=\&quot;blog_subscribe#form\&quot;&gt;&lt;form action=\&quot;/blog/subscription\&quot; class=\&quot;embeddable_form\&quot; data-entity=\&quot;blog_subscription\&quot; data-remote=\&quot;\&quot; data-view=\&quot;form#form\&quot; method=\&quot;post\&quot;&gt;&lt;div class=\&quot;embeddable_form-step is-email_form is-current\&quot;&gt;&lt;div class=\&quot;embeddable_form-row is-label\&quot;&gt;&lt;div class=\&quot;embeddable_form-label_title\&quot;&gt;Like what you&amp;#39;re reading?&lt;/div&gt;&lt;div class=\&quot;embeddable_form-label\&quot;&gt;Get the latest updates first.&lt;/div&gt;&lt;/div&gt;&lt;div class=\&quot;embeddable_form-row form-field is-email_field\&quot;&gt;&lt;input autocomplete=\&quot;off\&quot; class=\&quot;input is-medium\&quot; data-role=\&quot;email\&quot; name=\&quot;blog_subscription[email]\&quot; placeholder=\&quot;Enter your email address...\&quot; type=\&quot;text\&quot; /&gt;&lt;input name=\&quot;blog_subscription[vertical]\&quot; type=\&quot;hidden\&quot; value=\&quot;designers\&quot; /&gt;&lt;input name=\&quot;from_widget\&quot; type=\&quot;hidden\&quot; value=\&quot;true\&quot; /&gt;&lt;/div&gt;&lt;div class=\&quot;embeddable_form-row is-submit\&quot;&gt;&lt;input class=\&quot;button is-green_candy is-default is-full_width\&quot; data-loader-text=\&quot;Subscribing...\&quot; data-role=\&quot;submit\&quot; type=\&quot;submit\&quot; value=\&quot;Get Exclusive Updates\&quot; /&gt;&lt;/div&gt;&lt;div class=\&quot;embeddable_form-row is-privacy\&quot;&gt;&lt;div class=\&quot;embeddable_form-privacy\&quot;&gt;&lt;div class=\&quot;embeddable_form-privacy_icon\&quot;&gt;&lt;/div&gt;&lt;div class=\&quot;embeddable_form-privacy_text\&quot;&gt;No spam. Just great articles &amp;amp; insights.&lt;/div&gt;&lt;/div&gt;&lt;/div&gt;&lt;/div&gt;&lt;div class=\&quot;embeddable_form-step is-confirmation\&quot; data-place=\&quot;@blog_subscribe\&quot; data-role=\&quot;confirmation\&quot;&gt;&lt;div class=\&quot;embeddable_form-row is-label is-success\&quot;&gt;&lt;div class=\&quot;embeddable_form-label_title\&quot;&gt;Like what you&amp;#39;re reading?&lt;/div&gt;&lt;div class=\&quot;embeddable_form-label\&quot;&gt;Get the latest updates first.&lt;/div&gt;&lt;/div&gt;&lt;div class=\&quot;embeddable_form-row is-success\&quot;&gt;&lt;div class=\&quot;embeddable_form-label is-header\&quot;&gt;Thank you for subscribing!&lt;/div&gt;&lt;div class=\&quot;embeddable_form-label\&quot;&gt;Check your inbox to confirm subscription. You&#39;ll start receiving posts after you confirm.&lt;/div&gt;&lt;/div&gt;&lt;div class=\&quot;embeddable_form-row is-success\&quot;&gt;&lt;ul class=\&quot;social_share is-horizontal\&quot; data-url=\&quot;https://www.toptal.com/designers/blog\&quot; data-view=\&quot;layout#social_share\&quot; data-youtube-channel-url=\&quot;https://www.youtube.com/channel/UCNqm_euTHZz3o5OnKhUS-oA\&quot;&gt;&lt;li class=\&quot;social_share-item is-counter\&quot; title=\&quot;Total number of shares\&quot;&gt;&lt;span class=\&quot;social_share-item_num\&quot; data-role=\&quot;counter_num\&quot;&gt;0&lt;/span&gt;&lt;span class=\&quot;social_share-item_text\&quot; data-role=\&quot;counter_text\&quot;&gt;shares&lt;/span&gt;&lt;/li&gt;&lt;li class=\&quot;social_share-item\&quot;&gt;&lt;a class=\&quot;social_share-item_link\&quot; data-role=\&quot;link\&quot; data-track-click=\&quot;SocialShareButtonClicked\&quot; data-track-default-data=\&quot;{&amp;quot;network&amp;quot;:&amp;quot;twitter&amp;quot;}\&quot; data-type=\&quot;twitter\&quot; title=\&quot;Share on Twitter\&quot;&gt;&lt;img class=\&quot;social_share-item_image\&quot; height=\&quot;50\&quot; src=\&quot;https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/twitter_83c6d4.png\&quot; width=\&quot;50\&quot; /&gt;&lt;/a&gt;&lt;/li&gt;&lt;li class=\&quot;social_share-item\&quot;&gt;&lt;a class=\&quot;social_share-item_link\&quot; data-role=\&quot;link\&quot; data-track-click=\&quot;SocialShareButtonClicked\&quot; data-track-default-data=\&quot;{&amp;quot;network&amp;quot;:&amp;quot;facebook&amp;quot;}\&quot; data-type=\&quot;facebook\&quot; title=\&quot;Share on Facebook\&quot;&gt;&lt;img class=\&quot;social_share-item_image\&quot; height=\&quot;50\&quot; src=\&quot;https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/facebook_dc66c9.png\&quot; width=\&quot;50\&quot; /&gt;&lt;/a&gt;&lt;/li&gt;&lt;/ul&gt;&lt;/div&gt;&lt;/div&gt;&lt;/form&gt;&lt;/div&gt;&quot;}"></div></div><div class="blog-comments"><div id="disqus_thread_container"><div id="disqus_thread"><div class="d-noscript-comments"><h3>Comments</h3><div class="comment"><div class="comment-author">Nisarg Pandya</div><div class="comment-body">I love the way Adobe is growing with XD but I still think it cannot compete with Sketch for Symbol overriding option. And for animate, I found that XD doesn&#39;t  have trigger option for mouse hover, which I think is most important trigger needed for prototyping. I would love to worj in XD in future if they come up with some good solution.</div></div></div></div></div><script>function isIos() {
  return /(iPad|iPhone|iPod)/g.test(navigator.userAgent);
}

function adjustHeightInIos() {
  if (isIos()) {
    var height = $('#disqus_thread').outerHeight();
    $('#disqus_thread_container').height(height);
  }
}

if (isIos()) {
  var el = document.getElementById('disqus_thread_container');
  el.style.height = '1px';
  el.style.overflow = 'hidden';
  el.style.width = '100%';
}

function disqus_config() {
  this.callbacks.onNewComment = [function() {
    $.post('/blog/comments/on_create');
    adjustHeightInIos();
  }];

  this.callbacks.onReady = [adjustHeightInIos];
}

var disqus_shortname = 'toptal';
var disqus_identifier = 'adobe/adobe-xd-review';

(function() {
  var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
  dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
  (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
})();</script><noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript><a class="dsq-brlink" href="https://disqus.com">comments powered by <span class="logo-disqus">Disqus</span></a></div></div></div><div class="two_columns_layout-extra"><div class="blog-block-wrapper"><div class="blog-block-header">Subscribe</div><div class="blog-block"><div class="blog-block-row"><div class="embeddable_form-wrapper is-horizontal" data-role="blog_subscribe" data-view="blog_subscribe#form"><form action="/blog/subscription" class="embeddable_form" data-entity="blog_subscription" data-remote="" data-view="form#form" method="post"><div class="embeddable_form-step is-email_form is-current"><div class="embeddable_form-row is-label"><div class="embeddable_form-label_title">Free email updates</div><div class="embeddable_form-label">Get the latest content first.</div></div><div class="embeddable_form-row form-field is-email_field"><input autocomplete="off" class="input is-medium" data-role="email" name="blog_subscription[email]" placeholder="Enter your email address..." type="text" /><input name="blog_subscription[vertical]" type="hidden" value="designers" /><input name="from_widget" type="hidden" value="true" /></div><div class="embeddable_form-row is-submit"><input class="button is-green_candy is-default is-full_width" data-loader-text="Subscribing..." data-role="submit" type="submit" value="Get Exclusive Updates" /></div><div class="embeddable_form-row is-privacy"><div class="embeddable_form-privacy"><div class="embeddable_form-privacy_icon"></div><div class="embeddable_form-privacy_text">No spam. Just great articles &amp; insights.</div></div></div></div><div class="embeddable_form-step is-confirmation" data-place="@blog_subscribe" data-role="confirmation"><div class="embeddable_form-row is-label is-success"><div class="embeddable_form-label_title">Free email updates</div><div class="embeddable_form-label">Get the latest content first.</div></div><div class="embeddable_form-row is-success"><div class="embeddable_form-label is-header">Thank you for subscribing!</div><div class="embeddable_form-label">Check your inbox to confirm subscription. You'll start receiving posts after you confirm.</div></div><div class="embeddable_form-row is-success"><ul class="social_share is-horizontal" data-url="https://www.toptal.com/designers/blog" data-view="layout#social_share" data-youtube-channel-url="https://www.youtube.com/channel/UCNqm_euTHZz3o5OnKhUS-oA"><li class="social_share-item is-counter" title="Total number of shares"><span class="social_share-item_num" data-role="counter_num">0</span><span class="social_share-item_text" data-role="counter_text">shares</span></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;twitter&quot;}" data-type="twitter" title="Share on Twitter"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/twitter_83c6d4.png" width="50" /></a></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;facebook&quot;}" data-type="facebook" title="Share on Facebook"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/facebook_dc66c9.png" width="50" /></a></li></ul></div></div></form></div></div></div><div class="blog-block-header">Trending articles</div><div class="blog-block"><nav class="blog-trending"><a class="post is-preview blog-trending-item" href="/designers/adobe/adobe-xd-review"><span class="post_cover is-preview"><noscript><img class="post_cover-image" src="https://uploads.toptal.io/blog/cover_image/120771/side_list_cover-image_0-eaba2ea424aa81830010743e541067e0.png" /></noscript><span class="post_cover-image" data-role="deferred" data-src="https://uploads.toptal.io/blog/cover_image/120771/side_list_cover-image_0-eaba2ea424aa81830010743e541067e0.png"></span></span><span class="post-preview"><span class="post-title">Design with Precision - an Adobe XD Review</span><span class="post_meta"><span class="post_meta-date">about 4 hours ago</span></span></span></a><a class="post is-preview blog-trending-item" href="/designers/typography/web-typography-infographic"><span class="post_cover is-preview"><noscript><img class="post_cover-image" src="https://uploads.toptal.io/blog/cover_image/120770/side_list_cover-1210-Guide-to-Web-Typography-Luke_Wide-77433e5c33611234abd31bcb75f7723d.png" /></noscript><span class="post_cover-image" data-role="deferred" data-src="https://uploads.toptal.io/blog/cover_image/120770/side_list_cover-1210-Guide-to-Web-Typography-Luke_Wide-77433e5c33611234abd31bcb75f7723d.png"></span></span><span class="post-preview"><span class="post-title">Designing for Readability - A Guide to Web Typography (with Infographic)</span><span class="post_meta"><span class="post_meta-date">2 days ago</span></span></span></a><a class="post is-preview blog-trending-item" href="/designers/ui/principles-of-design"><span class="post_cover is-preview"><noscript><img class="post_cover-image" src="https://uploads.toptal.io/blog/cover_image/120766/side_list_cover-image_0-6570827bba5c0b05395bbb4094e0c105.png" /></noscript><span class="post_cover-image" data-role="deferred" data-src="https://uploads.toptal.io/blog/cover_image/120766/side_list_cover-image_0-6570827bba5c0b05395bbb4094e0c105.png"></span></span><span class="post-preview"><span class="post-title">The Principles of Design and Their Importance</span><span class="post_meta"><span class="post_meta-date">7 days ago</span></span></span></a><a class="post is-preview blog-trending-item" href="/designers/logo/logo-refresh"><span class="post_cover is-preview"><noscript><img class="post_cover-image" src="https://uploads.toptal.io/blog/cover_image/120765/side_list_cover-0822-WorstLogoTrophy-Dan-Banner-299bfa7d1d060b7282e90a2b196de802.png" /></noscript><span class="post_cover-image" data-role="deferred" data-src="https://uploads.toptal.io/blog/cover_image/120765/side_list_cover-0822-WorstLogoTrophy-Dan-Banner-299bfa7d1d060b7282e90a2b196de802.png"></span></span><span class="post-preview"><span class="post-title">Operation Logo Refresh - How We Fixed the World&#39;s Worst Logo</span><span class="post_meta"><span class="post_meta-date">9 days ago</span></span></span></a><a class="post is-preview blog-trending-item" href="/designers/ux/ux-designer-portfolios"><span class="post_cover is-preview"><noscript><img class="post_cover-image" src="https://uploads.toptal.io/blog/cover_image/120760/side_list_cover-image_0-e3c54eaa0c9aa8f5500fff422137270e.png" /></noscript><span class="post_cover-image" data-role="deferred" data-src="https://uploads.toptal.io/blog/cover_image/120760/side_list_cover-image_0-e3c54eaa0c9aa8f5500fff422137270e.png"></span></span><span class="post-preview"><span class="post-title">The Best UX Designer Portfolios - Inspiring Case Studies and Examples</span><span class="post_meta"><span class="post_meta-date">14 days ago</span></span></span></a><a class="post is-preview blog-trending-item" href="/designers/ux/user-research-with-ux-researcher"><span class="post_cover is-preview"><noscript><img class="post_cover-image" src="https://uploads.toptal.io/blog/cover_image/120758/side_list_cover-image_0-7a1ba238afc1d280fd79b4c121acad6c.png" /></noscript><span class="post_cover-image" data-role="deferred" data-src="https://uploads.toptal.io/blog/cover_image/120758/side_list_cover-image_0-7a1ba238afc1d280fd79b4c121acad6c.png"></span></span><span class="post-preview"><span class="post-title">Design Talks: Research in Action with UX Researcher Caitria O&#39;Neill</span><span class="post_meta"><span class="post_meta-date">16 days ago</span></span></span></a><a class="post is-preview blog-trending-item" href="/designers/ux/design-thinking-process"><span class="post_cover is-preview"><noscript><img class="post_cover-image" src="https://uploads.toptal.io/blog/cover_image/120755/side_list_cover-image_0-b51c8f001390aa20a0678d9ab51bbebe.png" /></noscript><span class="post_cover-image" data-role="deferred" data-src="https://uploads.toptal.io/blog/cover_image/120755/side_list_cover-image_0-b51c8f001390aa20a0678d9ab51bbebe.png"></span></span><span class="post-preview"><span class="post-title">Breaking Down the Design Thinking Process</span><span class="post_meta"><span class="post_meta-date">21 days ago</span></span></span></a><a class="post is-preview blog-trending-item" href="/designers/typography/typography-anatomy-infographic"><span class="post_cover is-preview"><noscript><img class="post_cover-image" src="https://uploads.toptal.io/blog/cover_image/120751/side_list_cover-image_0-e3c2b602127a83963a4b74bdb5e746fc.png" /></noscript><span class="post_cover-image" data-role="deferred" data-src="https://uploads.toptal.io/blog/cover_image/120751/side_list_cover-image_0-e3c2b602127a83963a4b74bdb5e746fc.png"></span></span><span class="post-preview"><span class="post-title">Dissecting the Intricacies of Typography Anatomy (with Infographic)</span><span class="post_meta"><span class="post_meta-date">23 days ago</span></span></span></a></nav></div><div class="blog-block-header">Relevant Technologies</div><div class="blog-block"><div class="blog-block-row"><ul class="blog-relevant"><li class="blog-relevant-item"><a class="link is-blue" href="https://www.toptal.com/designers/ui">UI</a></li><li class="blog-relevant-item"><a class="link is-blue" href="https://www.toptal.com/designers/ux">UX</a></li><li class="blog-relevant-item"><a class="link is-blue" href="https://www.toptal.com/designers/adobe">Adobe</a></li></ul></div></div><div class="blog-block has-no_background blog_banner for-author blog_author_banner" data-ga-action="ClickedOnHireTheAuthor_lateral" data-ga-label="adobe-xd-review" data-view="content#sidebar_banner"><div class="blog-block-header">About the author</div><div class="blog_author_banner-photo_wrapper"><img alt="Lex Valishvili" class="blog_author_banner-photo" src="https://uploads.toptal.io/user/photo/529587/large_8512abf260370db358965068ab423452.jpg" /></div><div class="blog_author_banner-content" data-role="author_content"><div class="blog_author_banner-name"><a href="/designers/resume/lex-valishvili">Lex Valishvili</a></div><div class="blog_author_banner-role">Designer</div><div class="blog_author_banner-about" data-role="author_about">Lex is a human-centered designer specializing in creating digital experiences that provide clear and interactive user experience, communicate a desirable message, and brings business results. With over six years of UX/UI, product design and branding experience, he strives to incorporate his knowledge and understanding of the design world and UX into every project. Previous clients range from early-stage startups to McKinsey &amp; Company.</div><div class="blog_author_banner-content_footer"></div></div><div class="blog_author_banner-cta"><a class="button is-green_candy is-default is-full_width" data-role="banner_link" href="https://www.toptal.com/hire?interested_in=designers&amp;skill=adobe">Hire the Author</a></div></div></div></div></div></section></main><footer class="hide_in_webview"><section class="grid-row has-solid_blue_bg page_footer_map-wrapper"><div class="grid-row-inner has-huge_padding page_footer_map"><div class="page_footer_map-content">Toptal connects the&nbsp;<a href="https://www.toptal.com/top-3-percent">top&nbsp;3%</a> of&nbsp;freelance talent all over&nbsp;the&nbsp;world.</div></div></section><section class="grid-row page_footer_sample_profile-wrapper"><div class="grid-row-inner has-big_padding"><h2 class="header is-row">Toptal Designers</h2><div class="skills_list"><ul class="multi_column_list qa-skills_list"><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/creative-direction">Creative Directors</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/freelance">Freelance Designers</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/graphic">Graphic Designers</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/illustration">Illustrators</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/logo">Logo Designers</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/mobile">Mobile App Designers</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/product-design">Product Designers</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/ui">UI Designers</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/ux">UX Designers</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/visual">Visual Designers</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/web">Web Designers</a></li></ul><div class="skills_list-see_all_wrapper"><a class="button is-tiny is-white is-uppercased" href="https://www.toptal.com/designers"><div class="skills_list-see_all_icon for-designers"></div>See more freelance designers</a></div></div></div></section><div class="skills_enterprise_link"><a class="skills_enterprise_link-url" href="/enterprise">Learn how enterprises benefit from Toptal experts.</a></div><section class="grid-row has-top_border page_footer_join-wrapper" id=""><div class="grid-row-inner has-padding page_footer_join"><h2 class="page_footer_join-header">Join the Toptal community.</h2><div class="page_footer_join-spacer"></div><nav class="page_footer_join-actions"><div class="page_footer_join-item"><a class="button is-green_candy is-big is-fixed page_footer_join-button" href="https://www.toptal.com/hire?interested_in=designers&amp;skill=adobe">Hire a designer</a></div><div class="page_footer_join-item is-or">or</div><div class="page_footer_join-item"><a class="button is-green_candy is-big is-fixed page_footer_join-button" href="https://www.toptal.com/designers/join">Apply as a Designer</a></div></nav></div></section><section class="grid-row page_footer_links-wrapper"><div class="grid-row-inner is-wide has-big_padding"><nav class="page_footer_links"><section class="page_footer_links-column is-1"><h3 class="page_footer_links-column_header">Highest In-Demand Talent</h3><ul class="page_footer_links-list"><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/ios">iOS Developers</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/front-end">Front-End Developers</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/designers/ux">UX Designers</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/designers/ui">UI Designers</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/finance/financial-modeling">Financial Modeling Consultants</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/finance/interim-cfos">Interim CFOs</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/project-managers/digital">Digital Project Managers</a></li></ul></section><section class="page_footer_links-column is-2"><h3 class="page_footer_links-column_header">About</h3><ul class="page_footer_links-list"><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/top-3-percent">Top 3%</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/clients">Clients</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/developers">Freelance Developers</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/designers">Freelance Designers</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/finance">Freelance Finance Experts</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/project-managers">Freelance Project Managers</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/about">About Us</a></li></ul></section><section class="page_footer_links-column is-3"><h3 class="page_footer_links-column_header">Contact</h3><ul class="page_footer_links-list"><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/contact">Contact Us</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/press-center">Press Center</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/careers">Careers</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/faq">FAQ</a></li></ul></section><section class="page_footer_links-column is-4"><h3 class="page_footer_links-column_header">Social</h3><ul class="page_footer_links-list"><li class="page_footer_links-item for-social_link"><a class="page_footer_links-social_link is-facebook" href="https://www.facebook.com/toptal">Facebook</a></li><li class="page_footer_links-item for-social_link"><a class="page_footer_links-social_link is-twitter" href="https://twitter.com/toptal">Twitter</a></li><li class="page_footer_links-item for-social_link"><a class="page_footer_links-social_link is-instagram" href="https://www.instagram.com/toptal">Instagram</a></li><li class="page_footer_links-item for-social_link"><a class="page_footer_links-social_link is-linkedin" href="https://www.linkedin.com/company/toptal">LinkedIn</a></li></ul></section></nav></div></section><section class="grid-row page_footer_legal-wrapper"><div class="grid-row-inner has-medium_padding page_footer_legal is-wide"><div class="logo-wrapper page_footer_legal-logotype"><a class="logo is-mini is-link" href="https://www.toptal.com/">Toptal</a><p class="logo-motto is-mini">Hire the top 3% of freelance talent</p></div><ul class="page_footer_legal-links"><li class="page_footer_legal-links_item is-copyright"><p class="page_footer_legal-copyright">© Copyright 2010 - 2018 Toptal, LLC</p></li><li class="page_footer_legal-links_item has-right_margin"><a class="page_footer_legal-link" href="https://www.toptal.com/privacy">Privacy Policy</a></li><li class="page_footer_legal-links_item"><a class="page_footer_legal-link" href="https://www.toptal.com/tos">Website Terms</a></li></ul></div></section></footer></div><div class="layout-overlay" data-view="layout#overlay"></div><div data-view="bounce_modals#events"><div data-view="bounce_modals#modal"></div></div><div class="notification-container" data-view="notifications#service"></div><script>setTimeout(function () {
  classNameWithFont = document.documentElement.className + ' wf-active'
  document.documentElement.className = classNameWithFont
}, 0);</script><script src="https://assets.toptal.io/assets/public-73e6ee8a8c1ddc864a7aa3e01cc292ecefeaa0cf.js"></script><script src="https://assets.toptal.io/assets/blog-73e6ee8a8c1ddc864a7aa3e01cc292ecefeaa0cf.js"></script><script src="https://assets.toptal.io/assets/cookie_banner-73e6ee8a8c1ddc864a7aa3e01cc292ecefeaa0cf.js"></script><div class="cookie_banner-container" data-allow="Got it" data-cookie-policy-type="privacy_shield" data-message="By continuing to use this site you agree to our &lt;a href=&#39;https://www.toptal.com/cookie-policy&#39;&gt;Cookie Policy&lt;/a&gt;." data-reload="false"></div><script>Widgets && new Widgets.CookieBanner(document.querySelector('.cookie_banner-container'))</script><div class="layout-counters"><script async="true" src="https://www.googletagmanager.com/gtag/js?id=UA-21104039-1"></script><script>if (typeof(window.Widgets) !== 'undefined') {
  var trackingId = 'UA-21104039-1'

  if (trackingId.length && !(window.googleAnalytics instanceof Widgets.GoogleAnalytics)) {
    window.googleAnalytics = new Widgets.GoogleAnalytics(
      trackingId,
      '',
      '',
      false
    )
  }
}</script><script async="" defer="" src="https://cdn.distiltag.com/api/v1/script/A6qhozMiYLpV2VKc8wSHaEmc3saOMhcrxAFcCFAt?GA_TID=UA-21104039-1&amp;GA_CDI=14" type="text/javascript"></script><noscript><img src="https://cdn.distiltag.com/api/v1/noscript/A6qhozMiYLpV2VKc8wSHaEmc3saOMhcrxAFcCFAt?GA_TID=UA-21104039-1&amp;amp;GA_CDI=14" /></noscript><script>// We are checking if window.analytics has the track function in case some dom element has the id equal analytics
if (!window.analytics || typeof window.analytics.track !== 'function') {
  // We do this because if some dom element has id equal analytics we need to override it, otherwise it wouldn't set analytics right
  window.analytics = undefined
  !function(){var analytics=window.analytics=window.analytics||[];if(!analytics.initialize)if(analytics.invoked)window.console&&console.error&&console.error("Segment snippet included twice.");else{analytics.invoked=!0;analytics.methods=["setAnonymousId", "trackSubmit","trackClick","trackLink","trackForm","pageview","identify","group","track","ready","alias","page","once","off","on"];analytics.factory=function(t){return function(){var e=Array.prototype.slice.call(arguments);e.unshift(t);analytics.push(e);return analytics}};for(var t=0;t<analytics.methods.length;t++){var e=analytics.methods[t];analytics[e]=analytics.factory(e)}analytics.load=function(t){var e=document.createElement("script");e.type="text/javascript";e.async=!0;e.src=("https:"===document.location.protocol?"https://":"http://")+"cdn.segment.com/analytics.js/v1/"+t+"/analytics.min.js";var n=document.getElementsByTagName("script")[0];n.parentNode.insertBefore(e,n)};analytics.SNIPPET_VERSION="3.0.1";
  analytics.load('jnS4QsHOCAOeG6XvMDCjD9n9bAcQ53Mb');
  }}();
}
(function() {
  function readVisitorIdCookie() {
    var cookieName = 'visitor_id=';
    var cookies = document.cookie.split(';');
    for (var i = 0; i < cookies.length; i++) {
      var cookie = cookies[i].replace(/^\s+|\s+$/g, '');
      if (cookie.indexOf(cookieName) === 0) {
        return cookie.split('=')[1];
      }
    }
  }
  analytics.setAnonymousId(readVisitorIdCookie());
  
  analytics.page('posts#show');
})();</script><script async="" defer="" id="hs-script-loader" src="//js.hs-scripts.com/2799924.js" type="text/javascript"></script><script>var _hsq = window._hsq = window._hsq || [];
</script><script>!function(f,b,e,v,n,t,s)
{if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};
if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];
s.parentNode.insertBefore(t,s)}(window,document,'script',
'https://connect.facebook.net/en_US/fbevents.js');

fbq('init', '463369723801939');
fbq('track', 'ViewContent');</script><noscript><img height="1" src="https://www.facebook.com/tr?id=463369723801939&amp;ev=ViewContent&amp;noscript=1" width="1" /></noscript><iframe frameborder="0" height="1" scrolling="no" src="https://www.attributiontracker.com/tracker/account_visit?tt_visit=1" width="1"></iframe><script>(function(A, d, S, t, a, g, e) {
  A['AdstageAnalytics'] = a;
  A[a] = A[a] || function() {
    (A[a].q = A[a].q || []).push(arguments)
  };
  A[a].l = 1 * new Date();
  g = d.createElement(S), e = d.getElementsByTagName(S)[0];
  g.async = 1;
  g.src = t;
  e.parentNode.insertBefore(g, e);
})(window, document, 'script', '//assets.adstage.io/analytics.js', '_as');
_as('create', 'e2dd65eb-07a1-4d93-874a-fe6dac5a8b64');
_as('send', 'pageview');</script><script>_bizo_data_partner_id = "8663";
(function() {
  var s = document.getElementsByTagName("script")[0];
  var b = document.createElement("script");
  b.type = "text/javascript";
  b.async = true;
  b.src = (window.location.protocol === "https:" ? "https://sjs" : "http://js") + ".bizographics.com/insight.min.js";
  s.parentNode.insertBefore(b, s);
})();</script><noscript><img alt="" height="1" src="//www.bizographics.com/collect/?pid=8663&amp;fmt=gif" style="display:none;" width="1" /></noscript></div><div id="breadcrumbs" class="breadcrumbs"><span itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url" href="https://www.toptal.com/"><span itemprop="title">Home</span></a></span> &rsaquo; <span itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url" href="https://www.toptal.com/developers/blog"><span itemprop="title">Blog</span></a></span> &rsaquo; <span itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb"><a class="current" itemprop="url" href="/designers/adobe/adobe-xd-review"><span itemprop="title">Design with Precision - an Adobe XD Review</span></a></span></div></body></html>