<!DOCTYPE html><!--[if IE 7]><html class="layout-wrapper ie ie7 lte9 lte8 lte7"><![endif]--><!--[if IE 8]><html class="layout-wrapper ie ie8 lte9 lte8"><![endif]--><!--[if IE 9]><html class="layout-wrapper ie ie9 lte9"><![endif]--><!--[if (gte IE 9)|!(IE)]<!--><html class="layout-wrapper"><head><title>A Practical Approach to Gamification Design | Toptal</title>
<meta name="description" content="Successful products and experiences offer more than pure functionality. Through a process called gamification, they are designed to engage human emotions and motivate users to forge ongoing interactions that are both meaningful and memorable." />
<link rel="alternate" href="https://www.toptal.com/designers/ui/gamification-design" hreflang="en" />
<link rel="canonical" href="https://www.toptal.com/designers/ui/gamification-design" />
<meta property="og:image" content="https://uploads.toptal.io/blog/post_image/120709/image_12-78e72bb717f93520f642f867c3f78bab.png" />
<meta property="og:title" content="A Practical Approach to Gamification Design" />
<meta property="og:description" content="Successful products and experiences offer more than pure functionality. Through a process called gamification, they are designed to engage human emotions and motivate users to forge ongoing interactions that are both meaningful and memorable." />
<meta property="og:site_name" content="Toptal Design Blog" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="author" content="" />
<meta name="DC.date.issued" content="2018-02-13" /><meta charset="utf-8" /><meta content="IE=edge,chrome=1" http-equiv="X-UA-Compatible" />
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"e3359cee6b","applicationID":"30100511","transactionName":"JV0NEUYJCQkARxgVEwReCgYbFgoWEUYYFg4JRQ==","queueTime":0,"applicationTime":106,"agent":""}</script>
<script type="text/javascript">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</script><meta content="width=device-width, initial-scale=1.0" name="viewport" /><script>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</script>
<script data-cfasync="false" src="//tribl.io/h.js?orgId=EdOAdeaAj8s34gqB05v6" type="text/javascript"></script><link href="https://assets.toptal.io/assets/front/static/favicons/favicon_ca7136.png" rel="icon" /><!--[if IE]><link href="https://assets.toptal.io/assets/front/static/favicons/favicon_68b340.ico" rel="shortcut icon" /><![endif]--><link href="https://assets.toptal.io/assets/front/static/favicons/touch_x57_f72647.png" rel="apple-touch-icon-precomposed" sizes="57x57" /><link href="https://assets.toptal.io/assets/front/static/favicons/touch_x72_516451.png" rel="apple-touch-icon-precomposed" sizes="72x72" /><link href="https://assets.toptal.io/assets/front/static/favicons/touch_x114_1798a8.png" rel="apple-touch-icon-precomposed" sizes="114x114" /><link href="https://assets.toptal.io/assets/front/static/favicons/touch_x57_f72647.png" rel="apple-touch-icon-precomposed" /><script src="https://assets.toptal.io/assets/jquery_and_modernizr-21b8650bce6d3894373f9f7962a9cbffc06373cb.js"></script><script>// TODO: Figure out how to override Modernizr test
(function () {
  var isIE, isIE11, noFlexboxClassName;
  isIE = /MSIE/.test(navigator.userAgent) && !/Opera/.test(navigator.userAgent);
  isIE11 = window.MSInputMethodContext && !/\bEdge\/[0-9.]+$/.test(navigator.userAgent);
  if (window.Modernizr && window.Modernizr.flexbox && (isIE || isIE11)) {
    noFlexboxClassName = document.documentElement.className.replace(/\bflexbox\b/, 'no-flexbox ie-flexbox');
    document.documentElement.className = noFlexboxClassName;
  }
})();</script><script>
//<![CDATA[
window.gon={};gon.flash={};gon.env="production";gon.signedin=false;gon.check_session_url="https:\/\/www.toptal.com\/signed_in";gon.shorten_url="https:\/\/www.toptal.com\/shorten_url";gon.geo_target_url="https:\/\/www.toptal.com\/api\/geo_target";gon.recaptcha_site_key="6LeeeDQUAAAAAJVnh-wvGaLmnO-lJ7X8nn0en1gm";gon.recaptcha_url="https:\/\/www.google.com\/recaptcha\/api.js";gon.google_api_browser_key="AIzaSyDED9v55b-c1opDYMEDYBkOgDFGlBMICGY";gon.google_js_maps_key="AIzaSyDspLQumHNqilmD5UHddqqpSjwY1AJpVd0";gon.google_places_api_key="AIzaSyBcP-ExZ1pLLRX2Adlc-faZpjwC3raVQI4";gon.ga_settings={"group":"Blog posts"};gon.current_vertical="designers";gon.url_share_counter=0;gon.bounce_modal_settings={"show":true,"type":"fullscreen","current_vertical_role_type":"Designer","template_options":{"blog":{"submit_path":"https:\/\/www.toptal.com\/blog\/subscription","form_vertical":"designers","blog_image":"designers","blog_type":"Toptal Design Blog","subtitle":"for the latest design tutorials and exploration of current trends.","articles":[{"url":"https:\/\/www.toptal.com\/designers\/illustration\/a-step-by-step-guide-to-designing-custom-illustrations-without-any-drawing-skills","image":"https:\/\/uploads.toptal.io\/blog\/cover_image\/120250\/list_inside_cover-illustration-ddb8de15cc6f3c6edd2d128940ae8b10.png","title":"A Step-by-step Guide to Designing Custom Illustrations Without Any Drawing Skills","author":"Tidjane Tall","author_image":"https:\/\/uploads.toptal.io\/user\/photo\/271544\/small_834a3184ed32914981f20be54b1e24e8.jpg","author_position":"Design Blog Editor"},{"url":"https:\/\/www.toptal.com\/designers\/product-design\/anticipatory-design-how-to-create-magical-user-experiences","image":"https:\/\/uploads.toptal.io\/blog\/cover_image\/120264\/list_inside_cover-0201michael_cover-801e7a036b586141c3f92525ae6883b7.jpg","title":"Anticipatory Design: How to Create Magical User Experiences","author":"Miklos Philips","author_image":"https:\/\/uploads.toptal.io\/user\/photo\/299315\/small_19003928cb1f4c3d84e6008468a33d92.png","author_position":"UI\/UX Designer"},{"url":"https:\/\/www.toptal.com\/designers\/ui\/button-design-dribbble-timeline","image":"https:\/\/uploads.toptal.io\/blog\/cover_image\/120423\/list_inside_cover-buttonhistory_widecover_2x-ea26f7bcdb179906a270d928d5f98188.png","title":"Button Design Over the Years \u2013 The Dribbble Timeline","author":"Wojciech Dobry","author_image":"https:\/\/uploads.toptal.io\/user\/photo\/424794\/small_f10f0f82d36df37ac83d547de1befad8.jpg","author_position":"Designer and Design Blog Editor"}]},"fullscreen":{"subtitle":"designers","bounce_modal_header_skill":"UI designers","verticals":["developers","designers","finance_experts"],"for_projects":false,"email_validation_api_path":"https:\/\/www.toptal.com\/api\/company_email_validations","submit_path":"https:\/\/www.toptal.com\/api\/leads","default_vertical":"designers"}},"skill":"UI","role":"designers"};gon.current_skill_name="UI";gon.current_skill_name_overriden_singular="UI designer";gon.current_skill_name_overriden_plural="UI designers";
//]]>
</script><link rel="stylesheet" media="screen" href="https://assets.toptal.io/assets/public_styles-21b8650bce6d3894373f9f7962a9cbffc06373cb.css" /><link rel="stylesheet" media="screen" href="https://assets.toptal.io/assets/portal_styles-21b8650bce6d3894373f9f7962a9cbffc06373cb.css" /><link rel="stylesheet" media="screen" href="https://assets.toptal.io/assets/blog_styles-21b8650bce6d3894373f9f7962a9cbffc06373cb.css" /><script>if(!window.appinfo) {
  window.onAppInfoLoaded = $.Deferred();
  document.cookie = 'appinfo_id_status=loading_script;'

  window.onAppinfoLoad = function() {
    document.cookie = 'appinfo_id_status=doing_request;'

    window.appinfo.grab('https://appinfo.toptal.com', {
      data: gon['application_info_data'] || {},
      callback: function(response, error) {
        if (!error) {
          document.cookie = 'appinfo_id_status=request_completed;'
          window.onAppInfoLoaded.resolve({
            applicationInfo: response.data
          });
        } else {
          document.cookie = 'appinfo_id_status=request_failed;'
        }
      }
    });
  };

  (function() {
    $.getScript('https://appinfo.toptal.com/script.js').fail(function() {
      document.cookie = 'appinfo_id_status=script_load_failed;'
      window.onAppInfoLoaded.reject();
    });
  })();
}</script></head><body class="layout" data-view="layout#body" id="top"><div class="layout_layer" data-view="layout#layout"><header class="page_header hide_in_webview" data-role="fixed-header"><div class="page_header_line"></div><div class="page_header" data-view="layout#menu"><div class="blog-simple-header grid-row is-light_gray" data-role="main_menu_wrapper"><div class="grid-row-inner is-wide has-padding page_header_top"><div class="page_header_top-logotype_wrapper"><div class="page_header_top-logotype"><a class="logo is-big is-link for-designers has-no_text_indent" href="https://www.toptal.com/designers"></a></div><div class="page_header_top-main_title"><b>Hiring?</b> Toptal handpicks <b><a href="https://www.toptal.com/designers/ui" onclick='window.googleAnalytics.trackEvent(event, "BlogCTAs", "ClickedOnHeaderHeadline", "ClickedOnHeaderHeadline")'>top UI designers</a></b> to suit your needs.</div></div><a class="page_header_top-expand" data-role="expand_menu" href="#"><span class="page_header_top-expand_icon"></span></a><nav class="page_header_top-nav_wrapper"><ul class="page_header_top-nav"><li class="page_header_top-nav_item"><a class="button is-green_candy is-small page_header_top-nav_link is-button" data-role="companies_apply_button" href="https://www.toptal.com/designers/ui" onclick="window.googleAnalytics.trackEvent(event, &quot;BlogCTAs&quot;, &quot;ClickedOnHeaderCTA&quot;, &quot;ClickedOnHeaderCTA&quot;);">Start hiring</a></li><li class="page_header_top-nav_item"><a class="button is-small is-light page_header_top-nav_link is-button" href="https://www.toptal.com/users/login">Log in</a></li></ul></nav></div></div><nav class="grid-row has-top_border is-light_gray page_header_menu-wrapper" data-role="main_menu_wrapper"><div class="grid-row-inner is-wide has-small_padding page_header_menu"><div class="page_header_menu-items-wrapper"><ul class="page_header_menu-items" data-role="menu"><li class="page_header_menu-item is-home"><a class="page_header_menu-link" href="https://www.toptal.com/designers"></a></li><li class="page_header_menu-item is-top-3-percent"><a class="page_header_menu-link" href="https://www.toptal.com/top-3-percent">Top 3%</a></li><li class="page_header_menu-item is-why"><a class="page_header_menu-link" href="https://www.toptal.com/why">Why</a></li><li class="page_header_menu-item is-clients"><a class="page_header_menu-link" href="https://www.toptal.com/clients">Clients</a></li><li class="page_header_menu-item is-enterprise"><a class="page_header_menu-link" href="https://www.toptal.com/enterprise">Enterprise</a></li><li class="page_header_menu-item is-partners"><a class="page_header_menu-link" href="https://www.toptal.com/partners">Partners</a></li><li class="page_header_menu-item is-community"><a class="page_header_menu-link" href="https://www.toptal.com/community">Community</a></li><li class="page_header_menu-item is-blog"><a class="page_header_menu-link" href="https://www.toptal.com/designers/blog">Blog</a></li><li class="page_header_menu-item is-about"><a class="page_header_menu-link" href="https://www.toptal.com/about">About Us</a></li><li class="page_header_menu-item is-join"><a class="button is-green_candy is-small page_hader_menu-button" data-role="companies_apply_button" href="https://www.toptal.com/designers/ui" onclick="window.googleAnalytics.trackEvent(event, &quot;BlogCTAs&quot;, &quot;ClickedOnHeaderCTA&quot;, &quot;ClickedOnHeaderCTA&quot;);">Start hiring</a></li><li class="page_header_menu-item is-join"><a class="button is-green_candy is-small page_hader_menu-button" href="https://www.toptal.com/designers/join">Apply as a Designer</a></li><li class="page_header_menu-item is-login"><a class="button is-light is-small page_hader_menu-button is-login" href="https://www.toptal.com/users/login">Login</a></li><li class="page_header_menu-item is-contacts"><ul class="page_header_menu-contact-items is-replaceable"><li class="page_header_menu-contact-item is-contact">Questions?</li><li class="page_header_menu-contact-item is-contact"><a class="link is-dotted page_header_menu-contact-link" href="https://www.toptal.com/contact">Contact Us</a></li><li class="page_header_menu-contact-item"><a class="page_header_menu-contact-link is-social is-facebook" href="https://www.facebook.com/toptal" target="_blank"><span class="page_header_menu-contact-link-icon"></span></a></li><li class="page_header_menu-contact-item"><a class="page_header_menu-contact-link is-social is-twitter" href="https://twitter.com/toptal" target="_blank"><span class="page_header_menu-contact-link-icon"></span></a></li><li class="page_header_menu-contact-item"><a class="page_header_menu-contact-link is-social is-google_plus" href="https://plus.google.com/+Toptalllc/" target="_blank"><span class="page_header_menu-contact-link-icon"></span></a></li></ul></li></ul></div><div class="blog_search" data-view="quick_search#search_field" data-vertical="Designer"><form class="blog_search-form" data-role="form"><input autocomplete="off" class="blog_search-field" data-role="field" name="text" placeholder="Search Topics" type="text" /><button class="button is-tiny blog_search-submit"><span class="blog_search-submit_icon"></span></button></form><div class="blog_search-suggestions" data-role="suggestions_wrapper"></div><div class="blog_search_results" data-role="results" style="display: none;"></div></div><a class="button is-green_candy is-tiny for-page_header_menu page_header_menu-hire" data-role="companies_apply_button" href="https://www.toptal.com/companies/apply?interested_in=designers&amp;skill=ui">Hire a designer</a></div></nav><nav class="blog-simple-header grid-row page_header_menu-wrapper is-fixed" data-role="sticky_menu_wrapper"><div class="grid-row-inner is-wide page_header_menu has-padding"><div class="page_header_top-logotype_wrapper"><div class="page_header_top-logotype"><a class="logo is-big is-link for-designers has-no_text_indent" href="https://www.toptal.com/designers"></a></div><div class="page_header_top-main_title"><b>Hiring?</b> Toptal handpicks <b><a href="https://www.toptal.com/designers/ui" onclick='window.googleAnalytics.trackEvent(event, "BlogCTAs", "ClickedOnHeaderHeadline", "ClickedOnHeaderHeadline")'>top UI designers</a></b> to suit your needs.</div></div><nav class="page_header_top-nav_wrapper"><ul class="page_header_top-nav" data-role="menu"><li class="page_header_top-nav_item"><a class="button is-green_candy is-small page_header_top-nav_link is-button" data-role="companies_apply_button" href="https://www.toptal.com/designers/ui" onclick="window.googleAnalytics.trackEvent(event, &quot;BlogCTAs&quot;, &quot;ClickedOnHeaderCTA&quot;, &quot;ClickedOnHeaderCTA&quot;);">Start hiring</a></li><li class="page_header_top-nav_item"><a class="button is-small is-light page_header_top-nav_link is-button" href="https://www.toptal.com/users/login">Log in</a></li></ul></nav></div></nav></div></header><main class="layout-main"><header class="grid-row has-top_border has-bottom_border post_cover is-post"><div class="grid-row-inner is-wide has-big_padding blog_title for-show"></div></header><article class="grid-row is-transparent"><div class="grid-row-inner is-wide"><div class="post_title"><h1 class="post_title-text">A Practical Approach to Gamification Design</h1><a class="post_title-back" href="https://www.toptal.com/designers/blog">View all articles</a></div></div></article><section class="grid-row has-top_border is-transparent has-no_border" data-view="" id="main_content"><div class="grid-row-inner has-medium_padding two_columns_layout is-wide"><div class="two_columns_layout-content"><div class="post is-full"><div class="post_meta-wrapper post_header"><div class="post_header-triangle"></div><div class="post_avatar post_meta-avatar"><img width="50" class="post_avatar-image" src="https://uploads.toptal.io/user/photo/618978/small_5e04d291217d5852cb62153a76ef440c.jpg" alt="Small 5e04d291217d5852cb62153a76ef440c" /></div><div class="post_meta is-full"><div class="post_meta-author"><p>by <strong><a class="link is-blue" target="_blank" href="https://www.toptal.com/designers/resume/stian-sandsgaard">Stian Sandsgaard</a></strong> - Designer
@ <a class="link is-blue" target="_blank" href="https://www.toptal.com/">Toptal</a>
</p>
</div><div class="post_meta-tags"><a rel="nofollow" href="https://www.toptal.com/designers/blog/tags/designpsychology">#DesignPsychology</a> <a rel="nofollow" href="https://www.toptal.com/designers/blog/tags/gamificationdesign">#GamificationDesign</a> <a rel="nofollow" href="https://www.toptal.com/designers/blog/tags/gamificationtheory">#GamificationTheory</a></div></div><ul class="social_share is-horizontal is-small is-centered_on_mobile for-blog_post_heading" data-hashtags="GamificationDesign,DesignPsychology,GamificationTheory" data-rss-url="https://www.toptal.com/designers/blog.rss" data-url="https://www.toptal.com/designers/ui/gamification-design" data-view="layout#social_share" data-youtube-channel-url="https://www.youtube.com/channel/UCNqm_euTHZz3o5OnKhUS-oA"><li class="social_share-item is-counter" title="Total number of shares"><span class="social_share-item_num" data-role="counter_num">0</span><span class="social_share-item_text" data-role="counter_text">shares</span></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;twitter&quot;}" data-type="twitter" title="Share on Twitter"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/twitter_83c6d4.png" width="50" /></a></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;facebook&quot;}" data-type="facebook" title="Share on Facebook"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/facebook_dc66c9.png" width="50" /></a></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;linkedin&quot;}" data-type="linkedin" title="Share on LinkedIn"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/linkedin_b923c3.png" width="50" /></a></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;google_plus&quot;}" data-type="google_plus" title="Share on Google Plus"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/google_plus_355fb0.png" width="50" /></a></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;stumbleupon&quot;}" data-type="stumbleupon" title="Share on StumbleUpon"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/stumbleupon_fc7c35.png" width="50" /></a></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;pocket&quot;}" data-type="pocket" title="Save to Pocket"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/pocket_e4260c.png" width="50" /></a></li></ul><div class="post_meta-extra"></div></div><div class="content_body" data-insert-middle-content="true" data-view="content#body"><style type="text/css">
    .align-center {
        text-align: center;
    }
    .zoomable-image {
        position: relative;
        width:100%;
    }
    .zim-image {
        width: 100%;
    }
    .zim-overlay {
        position: absolute;
        top: 0;
        bottom: 0;
        left: 0;
        right: 0;
        height: 100%;
        width: 100%;
        opacity: 0;
        transition: .5s ease;
        background-color: #a9a9a9;
    }
    .zoomable-image:hover .zim-overlay {
        opacity: 0.75;
    }
    .zim-text {
        color: white;
        font-size: 150%;
        position: absolute;
        top: 50%;
        left: 50%;
        transform: translate(-50%, -50%);
        -ms-transform: translate(-50%, -50%);
        text-align: center;
    }
</style>

<h2 id="good-design-motivates-humans">Good Design Motivates Humans</h2>

<p>Imagine you could create the perfect circumstances for a product to be successful before it’s even been designed. It’s safe to say you’d be a more confident and capable designer. This is the power that gamification, based in <a href="https://www.fastcompany.com/3068506/lemonade-is-using-behavioral-science-to-onboard-customers-and-keep-them-honest">behavioral science</a>, allows <a href="https://www.toptal.com/designers/digital" target="_blank">designers</a> to harness.</p>

<p>There are two primary ways of designing a product: function-focused design (FFD) and human-focused design (HFD).</p>

<p>FFD assumes that people are robots, set to complete a task—think repetitive factory jobs.</p>

<p>HFD is designed to optimize and motivate people’s feelings, making tasks a fun and engaging experience—think amusement parks.</p>

<p>Gamification is the step of converting a product from a function-focused design into a human-focused design. It’s honing for human motivation in a system rather than designing for the sole purpose of efficiency.</p>

<p><img src="https://uploads.toptal.io/blog/image/125398/toptal-blog-image-1518496932696-9cf1899b55d74a8c97cbdcc2a3428343.jpg" alt="Benefits of gamification design" /></p>

<div class="pop_out_box is-full_width is-big align-center">Gamification</div>

<h3 id="the-success-of-a-product-isnt-arbitrary">The Success of a Product Isn’t Arbitrary</h3>

<p><a href="https://www.interaction-design.org/literature/topics/gamification">Gamification</a> is more than adding game elements such as badges, points, and leaderboards to a product. It’s a careful study of what specifically motivates a person to use and enjoy an application.</p>

<p>Take a moment to think about these questions:</p>

<ul>
  <li>Why do people commit to spending hours writing articles on Wikipedia for free?</li>
  <li>Why is Facebook so much more successful than Google+ and LinkedIn?</li>
  <li>Given its simple graphics and gameplay, why is Minecraft such a highly played game?</li>
  <li>Why do people still play ancient games such as Chess and Starcraft 1 while other, seemingly better games fade after only a few months?</li>
</ul>

<p>The Octalysis framework is a gamification framework that answers these questions, explaining in detail why a product is enjoyable or tedious. Let’s take a closer look.</p>

<div class="zoomable-image">
    <img class="zim-image" alt="Gamification design: the Octalysis framework" src="https://uploads.toptal.io/blog/image/125399/toptal-blog-image-1518496942406-acfd51cf509d3f2baebfcca8467c3110.png" />
    <a class="zim-overlay" href="https://uploads.toptal.io/blog/image/125399/toptal-blog-image-1518496942406-acfd51cf509d3f2baebfcca8467c3110.png" target="_blank"><span class="zim-text">Click to see full-sized image.</span></a>
</div>

<div class="pop_out_box is-full_width is-big align-center">The Octalysis framework by <a href="http://yukaichou.com/gamification-expert/">Yu-Kai Chou</a></div>

<p><a href="https://www.interaction-design.org/literature/article/understanding-the-person-in-terms-of-gamification-design">People do things for a reason</a>. Understanding why they do what they do is crucial for creating a successful product. <a href="http://yukaichou.com/gamification-expert/">Yu-Kai Chou</a> spent ten years designing the Octalysis framework and identified eight <strong>core drives</strong> that exist within humans and motivate us to engage in activities.</p>

<p>If an application or experience has none of these core drives present, a person has zero motivation to engage. Therefore, it’s important to understand why core drives motivate people and how to apply them.</p>

<h2 id="master-the-8-core-drives-of-gamification">Master the 8 Core Drives of Gamification</h2>

<h3 id="core-drive-1----epic-meaning-and-calling">Core Drive 1 – Epic Meaning and Calling</h3>

<p>Octalysis inventor Yu-Kai Chou explains Core Drive 1 as “the drive where people are motivated because they believe they are engaged in something that is bigger than themselves.”</p>

<p><strong>Wikipedia</strong></p>

<p>The reason why people spend hours contributing to Wikipedia is because of Core Drive 1. Together, they embark on the epic journey of making the world a better place by documenting and spreading knowledge.</p>

<p><strong>Free Rice</strong></p>

<p><a href="http://freerice.com/">Free Rice</a> is a trivia-based website that supports the United Nations World Food Program. For every question answered correctly by site visitors, Free Rice donates 10 grains of rice to people in need, playing off a Core Drive 1 concept called “humanity hero.”</p>

<h3 id="core-drive-2----development-and-accomplishment">Core Drive 2 – Development and Accomplishment</h3>

<p>Core Drive 2 involves the internal drive of making progress, developing skills, overcoming challenges, and feeling a sense of accomplishment. An awareness of struggle is essential to Core Drive 2, as a badge or a trophy without a challenge is not meaningful and can even demotivate the user.</p>

<p><strong>Twitter</strong></p>

<p>Due to the one-way nature of Twitter communication, people view gaining followers as an achievement. Since no one can be forced to follow anyone else, the only way to increase followers is by creating interesting content. This is a challenge that offers a true sense of accomplishment when overcome.</p>

<p><strong>LinkedIn</strong></p>

<p>In the early days of LinkedIn, people rarely completed their user profiles due to poor visual feedback of the progress made (insufficient Core Drive 2). However, after implementing a profile progress bar, LinkedIn increased their completion ratio by a staggering 60%.</p>

<h3 id="core-drive-3----empowerment-of-creativity-and-feedback">Core Drive 3 – Empowerment of Creativity and Feedback</h3>

<p>Empowerment of creativity and feedback relates to when users are engaged in a creative process. This involves giving users the freedom to express their creativity, get feedback, and make adjustments.</p>

<p><strong>Minecraft</strong></p>

<p>Minecraft is a prime example of Core Drive 3 because users are given the ability to express creativity by using simple building blocks to craft complex structures and make adjustments as they go.</p>

<p><strong>Chess</strong></p>

<p>Chess has stood the test of time due to its focus on Core Drive 3. It’s a uniquely creative game that allows players to shape highly personal playing styles. In fact, there are approximately 140,100,033 possible positions to play in a game of chess.</p>

<p><img src="https://uploads.toptal.io/blog/image/125400/toptal-blog-image-1518496958834-56bc420e7b664943cd6c25f70dd80e3d.jpg" alt="Gamification design - chess" /></p>

<div class="pop_out_box is-full_width is-big align-center">Photo by <a href="https://unsplash.com/@crownagency">Crown Agency</a></div>

<h3 id="core-drive-4----ownership-and-possession">Core Drive 4 – Ownership and Possession</h3>

<p>In Core Drive 4, users are motivated because they feel like they own something. When players feel ownership, they want to improve, personalize, protect, and get more. In the real world, this is what drives us to make money, but it can also be tied to elements with sentimental value such as collecting baseball cards or customizing a Dropbox folder.</p>

<p><strong>Pokémon</strong></p>

<p>Pokémon focuses heavily on a Core Drive 4 concept called “collection set.” Each Pokémon captured is added to a collection and gives users a sense of ownership. Once players catch a few Pokémon, they gotta catch ‘em all, and the hunt continues.</p>

<p><img src="https://uploads.toptal.io/blog/image/125401/toptal-blog-image-1518496965340-ca19bb7d94e5f6a2ae08d7c5ec5ae684.jpg" alt="Gamification design of Pokémon Go" /></p>

<div class="pop_out_box is-full_width is-big align-center">Pokémon GO</div>

<p><strong>Farmville</strong></p>

<p>Farmville makes players constantly strive to increase the value of their assets by developing land. This includes seeking higher crop yields and improving the quantity and quality of livestock, both of which are motivated by the sense of ownership players have for their digital farms.</p>

<h3 id="core-drive-5----social-influence-and-relatedness">Core Drive 5 – Social Influence and Relatedness</h3>

<p>Social influence is related to activities inspired by what other people do, think, or say—basically, what every social media platform is built on.</p>

<p>Relatedness centers on <a href="https://www.toptal.com/designers/product-design/design-for-emotion-to-increase-user-engagement" target="_blank">emotional</a> associations and feelings of nostalgia such as meeting an old friend or finding a product that brings back memories of childhood.</p>

<p><strong>Groupon</strong></p>

<p>Groupon was one of the first companies to turn an eCommerce platform into a social event. If enough people sign up to buy a particular item, the reward is a substantial discount. Happy users then invite other people to join and share the benefits (social influence).</p>

<p><img src="https://uploads.toptal.io/blog/image/125402/toptal-blog-image-1518496972262-08a26055b50fd4abc6e8979a8b73eed0.jpg" alt="Gamification Design of Groupon's website" /></p>

<p><strong>Amazon</strong></p>

<p>People trust what they can relate to. In fact, approximately 60% of Amazon’s revenue comes from the recommendations section. A well-known example is, “Customers who bought this item also bought…”</p>

<p>Appealing to an emotional <a href="https://www.toptal.com/designers/user-experience/anticipatory-persuasive-emotional-design-ux" target="_blank">connection</a> (relatedness) with other users builds a sense of trust and lowers the threshold to buy something.</p>

<h3 id="core-drive-6----scarcity-and-impatience">Core Drive 6 – Scarcity and Impatience</h3>

<p>Scarcity and impatience motivate us because we are either unable to obtain something immediately or because there is great difficulty in obtaining it. If you can’t have it, you want it.</p>

<p><strong>Sales</strong></p>

<p>Oftentimes, sales promise bargains that are only available for a limited period of time—“70% OFF. Today ONLY!”</p>

<p>The existence of the sale is scarce, and people are motivated to act with a sense of urgency.</p>

<p><strong>Facebook</strong></p>

<p>In its early days, Facebook was only available to Harvard students. This caused impatience among other university students who wanted to access the platform. Once Facebook was finally made available to other universities, people flooded in due to the exclusivity (scarcity) of it.</p>

<h3 id="core-drive-7----unpredictability-and-curiosity">Core Drive 7 – Unpredictability and Curiosity</h3>

<p>People are curious beings. We have no foolproof way of predicting the future, yet we’re always thinking about what will happen next.</p>

<p>Unpredictability is a powerful force in motivating people to keep pressing on until they have clarified the unknown. We’re driven by the chase.</p>

<p><strong>Gambling</strong></p>

<p>Gambling is fueled by the feeling of unpredictability. Being able to pull a lever and not knowing the result creates a thrilling experience.</p>

<p><strong>TV Series</strong></p>

<p>A good television series will add a cliffhanger at the end of every episode to create a sense of anticipation for the next. This appeals to the audience’s curiosity and desire to clarify the unknown.</p>

<h3 id="core-drive-8----avoidance-and-loss">Core Drive 8 – Avoidance and Loss</h3>

<p>Avoidance and loss motivate through the fear of losing something or having an undesirable event occur.</p>

<p>Marketing campaigns often target Core Drive 8 with tactics like, “If you don’t sign up now, you’ll lose this chance forever.” In fact, psychology studies suggest that we are more likely to act based on avoiding loss rather than making gains.</p>

<p><strong>FIFA 18</strong></p>

<p>FIFA 18 has a concept called “Player of the Month,” where a famous footballer is available for purchase, but only for a limited time. This motivates FIFA players to act and buy in order to avoid losing out on a good opportunity.</p>

<p><img src="https://uploads.toptal.io/blog/image/125403/toptal-blog-image-1518496982053-71704a3b0a6f041e232f609e1ae41b63.jpg" alt="Gamification Design of FIFA 18" /></p>

<div class="pop_out_box is-full_width is-big align-center">FIFA 18</div>

<p><strong>Black Friday</strong></p>

<p>Black Friday is a great example of how limited opportunity can motivate people to act with an extreme sense of urgency. Once a year, on the Friday after Thanksgiving in the United States, products are priced a lot cheaper, and people flock to stores to avoid losing out on sweet deals.</p>

<h2 id="the-octalysis-framework-as-a-case-study----facebook">The Octalysis Framework as a Case Study – Facebook</h2>

<p>One way to apply the Octalysis framework is by using it to analyze a product, identifying which core drives are in place and how they are utilized. In this way, we can clearly see what motivates people to use a product.</p>

<div class="zoomable-image">
    <img class="zim-image" alt="Gamification Design Facebook case study - the Octalysis framework" src="https://uploads.toptal.io/blog/image/125404/toptal-blog-image-1518496989007-a3ff2124895907d42886b381e7bfff87.png" />
    <a class="zim-overlay" href="https://uploads.toptal.io/blog/image/125404/toptal-blog-image-1518496989007-a3ff2124895907d42886b381e7bfff87.png" target="_blank"><span class="zim-text">Click to see full-sized image.</span></a>
</div>

<div class="pop_out_box is-full_width is-big align-center">The Octalysis framework – Facebook case study</div>

<p>As seen in the illustration, Facebook utilizes most core drives, hence its success. However, it lacks CD1—epic meaning and calling. This results in people feeling like Facebook is a waste of time, which is why we hear their relief when users quit the platform. The relief comes not because people don’t enjoy Facebook, but because it’s not worth their time.</p>

<p>As of late, Facebook has been trying to combat this problem by adding a bigger emphasis on Core Drive 1 and allowing users to donate money to good causes and participate in life-changing events.</p>

<p>If you run the same Octalysis analysis on Google+ and LinkedIn, you’ll notice why they did not achieve levels of success that rival Facebook. Google+ is largely inactive, and LinkedIn lacks social interaction between users.</p>

<p><strong>Google+</strong> primarily failed due to poorly executed Core Drive 2 (development and accomplishment). The onboarding phase was difficult, making users feel inadequate and unaccomplished (CD2). This led to users losing motivation and quitting the platform before they could engage in the community and use their creativity to contribute content (CD3 and CD5).</p>

<p><strong>LinkedIn</strong> lacks the core drive that enables people to be creative (CD3). Users are hesitant to share their personal life on LinkedIn and instead look to portray themselves in a manner worthy of landing a new job or client. This severely limits a willingness to create and share content.</p>

<h2 id="digging-deeper----understanding-the-psychology-of-the-octalysis-framework">Digging Deeper – Understanding the Psychology of the Octalysis Framework</h2>

<h3 id="white-hat-vs-black-hat">White Hat vs. Black Hat</h3>

<p>Octalysis is designed as an octagon for a reason. In this framework, we have a concept called <strong>white hat</strong> and <strong>black hat</strong> core drives. These drives divide the top from the bottom, as seen in the illustration below.</p>

<div class="zoomable-image">
    <img class="zim-image" alt="Gamification Design - the Octalysis framework, White Hat vs. Black Hat" src="https://uploads.toptal.io/blog/image/125405/toptal-blog-image-1518497004940-8f4bbf09e48f304c0352402b20580f5a.png" />
    <a class="zim-overlay" href="https://uploads.toptal.io/blog/image/125405/toptal-blog-image-1518497004940-8f4bbf09e48f304c0352402b20580f5a.png" target="_blank"><span class="zim-text">Click to see full-sized image.</span></a>
</div>

<div class="pop_out_box is-full_width is-big align-center">The Octalysis framework – White Hat vs. Black Hat</div>

<p><strong>White hat core drives</strong> make the user feel powerful and in control, but they fail to prompt a sense of urgency.</p>

<p><strong>Black hat core drives</strong> make people feel urgent and called to action, but in the long run, they discourage users by making them feel like they lack control of their behavior.</p>

<p>Neither white hat nor black hat core drives are inherently good or bad. Each serves its own purpose and balances the other. However, for long-term product engagements, it’s important to focus on white hat core drives.</p>

<p>Minecraft has achieved long-term engagement by allowing players to express their creativity (CD3). However, this creative freedom is given against a backdrop of scenarios that demand urgency (black hat).</p>

<p>Consider the scarcity of safe places to make camp in Minecraft’s first night of survival mode, not to mention the constant threat of being attacked by zombies and spiders.</p>

<p><img src="https://uploads.toptal.io/blog/image/125406/toptal-blog-image-1518497016189-15755162c608437dcd5c5bcfb3810c5e.jpg" alt="Gamification Design of Minecraft" /></p>

<div class="pop_out_box is-full_width is-big align-center">Minecraft</div>

<p>In the past, Zynga games applied black hat concepts effectively. For instance, in Farmville, a player’s crops would die if they weren’t tended to daily (Core Drive 8), motivating players to regularly log in.</p>

<p>However, games created by Zynga are a clear example of what happens when white hat and black hat aren’t properly balanced. People get burned out by the ongoing threat, leading them to quit the experience (too much emphasis on black hat).</p>

<p><img src="https://uploads.toptal.io/blog/image/125407/toptal-blog-image-1518497021255-8e5749af1f82d457f5b28abd6680204b.jpg" alt="Gamification Design of custom Farmville farms" /></p>

<div class="pop_out_box is-full_width is-big align-center">Farmville</div>

<p>Farmville could be improved and gain more long-term (endgame) users if its <a href="https://www.toptal.com/designers/ux" target="_blank">designers</a> would find more opportunities for players to express creativity. If you’re familiar with the game, you may have noticed the emergence of user-generated farm designs with an artistic flair, a clear sign that the user base desires more creative freedom.</p>

<p>Understanding the balance between core drives and the potential for user burnout is crucial in developing a sustainable application. For more information, check out <a href="http://yukaichou.com/gamification-study/white-hat-black-hat-gamification-octalysis-framework/">White Hat vs Black Hat</a>.</p>

<h2 id="key-motivational-forces----intrinsic-vs-extrinsic">Key Motivational Forces – Intrinsic vs. Extrinsic</h2>

<p>The Octalysis framework is also divided into left and right sections. On the left side, we find extrinsic motivation, where users are compelled to perform a behavior to earn a reward or avoid punishment. Simply put, it is the reward that motivates, not the act itself.</p>

<div class="zoomable-image">
    <img class="zim-image" alt="Gamification Design - the Octalysis framework - intrinsic vs. extrinsic motivation" src="https://uploads.toptal.io/blog/image/125408/toptal-blog-image-1518497028462-ee1a9c33ec3a847cbb249bba4aa09eab.png" />
    <a class="zim-overlay" href="https://uploads.toptal.io/blog/image/125408/toptal-blog-image-1518497028462-ee1a9c33ec3a847cbb249bba4aa09eab.png" target="_blank"><span class="zim-text">Click to see full-sized image.</span></a>
</div>

<div class="pop_out_box is-full_width is-big align-center">The Octalysis framework – Intrinsic vs. extrinsic motivation</div>

<p>On the right, we have intrinsic motivation, which involves engaging in a behavior because it is personally rewarding. Essentially, this means performing an activity for its own sake rather than the desire to get a reward.</p>

<h3 id="extrinsic-motivation-examples">Extrinsic Motivation Examples</h3>

<ul>
  <li>Studying in order to get a good grade (development and accomplishment – CD2)</li>
  <li>Working to earn money (ownership and possession – CD4)</li>
  <li>Competing in a contest to win a scholarship (scarcity and impatience – CD6)</li>
</ul>

<h3 id="intrinsic-motivation-examples">Intrinsic Motivation Examples</h3>

<ul>
  <li>Drawing, painting, and other artistic endeavors (empowerment of creativity and feedback – CD3)</li>
  <li>Participating in a social event (social influence and relatedness – CD5)</li>
  <li>Watching a movie (unpredictability and curiosity – CD7)</li>
</ul>

<h3 id="why-is-it-important-to-know-the-difference">Why Is It Important to Know the Difference?</h3>

<p>One reason is that <strong>extrinsic motivation</strong> can kill <strong>intrinsic motivation</strong>. Consider a concept artist who draws as a hobby and then gets hired to draw professionally. If the salary they receive is lower than the value they feel their work is worth, it will eventually diminish any motivation to keep drawing.</p>

<p>Interestingly, this particular artist drew for free before getting the offer to be paid!</p>

<p>It’s also important to be wary of using extrinsic motivation in the discovery phase of a product. This phase is the first point of contact a user has with a product. Early on, users typically don’t have a feeling of ownership over an experience, so it’s often better to focus on intrinsic motivation by appealing to curiosity or the desire to participate in something beneficial.</p>

<h2 id="gamification-infuses-products-with-meaning">Gamification Infuses Products with Meaning</h2>

<p>Success is not arbitrary. In product design, it comes down to the question, “What will make people want to use this product?”</p>

<p>Think back to the examples discussed earlier. From leading eCommerce platforms to popular games, there are surefire patterns that run through all successful products and experiences.</p>

<p>Take industry giants Amazon and eBay, both of which drive sales by appealing to black hat core drives. Why do they do this? To instill shoppers with a sense of urgency. Predictably, it works.</p>

<p>Or, consider chess and Minecraft, two well-loved games that appear to have little in common. However, both have proven capable of generating long term engagement due to a focus on white hat core drives and the empowerment of creativity.</p>

<p>Understanding the concept of motivation is paramount in developing consistently good user experiences.</p>

<p>The behavior influencing concepts and human psychology behind gamification are available to us as <a href="https://www.toptal.com/designers/mobile" target="_blank">designers</a>. They help us grasp why something works or why it doesn’t. Correctly applying core drives will add meaning and value to the products we make. In turn, our users—the people we create for—will enjoy a fun, engaging, and meaningful experience.</p>

<hr />

<h2 id="additional-thinking-points">Additional Thinking Points</h2>

<p>These thinking points are a great way of implementing core drives into a product’s experience. Here are some questions to ask yourself:</p>

<h3 id="core-drive-1">Core Drive 1</h3>

<ul>
  <li>Can I appeal to a greater cause of some sort, like narrating an epic quest?</li>
  <li>Can I instill a group mentality? (sports, universities, factions, nations, etc.)</li>
  <li>Can I create an opportunity for the user to help other people?</li>
</ul>

<h3 id="core-drive-2">Core Drive 2</h3>

<ul>
  <li>How do I make my users feel accomplished?</li>
  <li>Can I add a visual progression? (segments, bosses, chapters, milestones, etc.)</li>
  <li>Can I add an element of challenge in order to make it fun and rewarding?</li>
</ul>

<h3 id="core-drive-3">Core Drive 3</h3>

<ul>
  <li>Can I give the user a tool to be creative with? (drawing, building, creating, etc.)</li>
  <li>Is there an opportunity to give the user multiple choices to reach the same goal?</li>
  <li>Can I give my users boosters, items, or skills to personalize and use?</li>
</ul>

<h3 id="core-drive-4">Core Drive 4</h3>

<ul>
  <li>Can I give the user objects to collect? (cards, Pokémon, money, items, etc.)</li>
  <li>Is there room to personalize content? (profile, avatar, skins, look, etc.)</li>
  <li>Can we instill a sense of ownership or give users something to protect?</li>
</ul>

<h3 id="core-drive-5">Core Drive 5</h3>

<ul>
  <li>Is there an opportunity to add a form of communication between users?</li>
  <li>Is there a possibility to give the user something to relate to? (memes)</li>
  <li>Is there room for competition and companionship? (rivalry, teamwork, etc.)</li>
</ul>

<h3 id="core-drive-6">Core Drive 6</h3>

<ul>
  <li>Can we remove a sense of abundance to promote scarcity?</li>
  <li>Can we add elements of exclusivity? (VIP, rarity, overcoming tough challenges, etc.)</li>
  <li>Is there room for implementing limited opportunities? (timers, seasons, location access, etc.)</li>
</ul>

<h3 id="core-drive-7">Core Drive 7</h3>

<ul>
  <li>Can we add a bit of randomness or chance to the experience? (unpredictability)</li>
  <li>Is there a way to give the user the freedom to explore? (see the world)</li>
  <li>Can we motivate the user with unknown rewards? (mystery box, Easter eggs), etc.</li>
</ul>

<h3 id="core-drive-8">Core Drive 8</h3>

<ul>
  <li>Is there a way to make the user feel a sense of loss if they quit? (losing stats)</li>
  <li>Can we create limited opportunities that disappear if users don’t act soon?</li>
  <li>Is there a way to appeal to future reward if they keep using the product?</li>
</ul>
<div class="post_key_learnings for-post"><h2 class="post_key_learnings-heading" data-disable_middle_content_placement="true">Understanding the Basics</h2><div class="post_key_learnings-item" data-animation-speed="450" data-hide-button="false" data-initial-state="expanded" data-view="ui#expander"><span class="post_key_learnings-item_arrow is-expanded" data-role="button"></span><h3 class="post_key_learnings-title is-expanded" data-disable_middle_content_placement="true" data-role="button">What is Octalysis?</h3><p class="post_key_learnings-body" data-role="content">The Octalysis framework is a gamification framework that explains in detail why a product is enjoyable or tedious. The primary focus of Octalysis is optimizing human motivation.</p></div><div class="post_key_learnings-item" data-animation-speed="450" data-hide-button="false" data-initial-state="collapsed" data-view="ui#expander"><span class="post_key_learnings-item_arrow is-collapsed" data-role="button"></span><h3 class="post_key_learnings-title is-collapsed" data-disable_middle_content_placement="true" data-role="button">What is a gamification strategy?</h3><p class="post_key_learnings-body is-hidden" data-role="content">A gamification strategy is a plan for motivating users throughout their entire journey with a product or experience. </p></div><div class="post_key_learnings-item" data-animation-speed="450" data-hide-button="false" data-initial-state="collapsed" data-view="ui#expander"><span class="post_key_learnings-item_arrow is-collapsed" data-role="button"></span><h3 class="post_key_learnings-title is-collapsed" data-disable_middle_content_placement="true" data-role="button">What is meant by user-centered design?</h3><p class="post_key_learnings-body is-hidden" data-role="content">User-centered design is focused on meeting users’ needs and producing products and experiences that are both functional and accessible. It includes areas of concentration such as ergonomics, human factors, and usability engineering.</p></div></div><div class="blog_author_big_banner is-active" data-ga-action="ClickedOnHireTheAuthor_bottom" data-ga-label="gamification-design" data-view="content#bottom_banner"><h2>About the author</h2><div class="skill_talent for-blog_post"><div class="skill_talent-extra"><a class="skill_talent-photo_wrapper" href="/designers/resume/stian-sandsgaard"><img alt="Stian Sandsgaard" class="skill_talent-photo" src="https://uploads.toptal.io/user/photo/618978/large_5e04d291217d5852cb62153a76ef440c.jpg" /><div class="skill_talent-photo_hint">View full profile &raquo;</div></a><div class="blog_author_big_banner-cta"><a class="button is-green_candy is-default is-full_width is-fixed skill_talent-hire" data-role="banner_link" href="https://www.toptal.com/companies/apply?interested_in=designers&amp;skill=ui">Hire the Author</a></div></div><div class="skill_talent-main"><a class="link skill_talent-name" href="/designers/resume/stian-sandsgaard">Stian Sandsgaard, Norway</a><div class="clearfix"><div class="skill_talent-member_since">member since September 28, 2017</div></div><div class="skill_talent-skills" data-view="skill_talent#tags"><a class="tag skill_talent-skill" data-role="tag" href="https://www.toptal.com/designers/adobe">Adobe Experience Design (XD)</a><a class="tag skill_talent-skill" data-role="tag" href="https://www.toptal.com/designers/photoshop">Adobe Photoshop</a><a class="tag skill_talent-skill" data-role="tag" href="https://www.toptal.com/designers/adobe">Adobe After Effects</a><a class="tag skill_talent-skill" data-role="tag" href="https://www.toptal.com/designers/ux">User Experience (UX)</a><a class="tag skill_talent-skill" data-role="tag" href="https://www.toptal.com/designers/ui">User Interface (UI)</a><a class="tag" data-role="more" href="/designers/resume/stian-sandsgaard" style="display: none;">+<span data-role='count'>&nbsp;&nbsp;</span> more</a></div><div class="skill_talent-description">Stian is an award-winning designer with eight years of experience in the corporate and start-up industry. Working with both large and small-scale projects in SaaS. He specializes in UX and UI design as well as having experience in animation and VFX. Especially oriented around behavioral science also known as gamification. Some of the clients he&#39;s worked with include Statoil, Westcon, Baikingu, and InfoGym.  <a class="link" href="/designers/resume/stian-sandsgaard">[click to continue...]</a></div></div></div></div><div class="post-join"><a class="button is-white_and_green is-default is-full_width" href="https://www.toptal.com/designers/ui">Hiring? Meet the Top 10 Freelance UI Designers for Hire in February 2018</a></div><div class="template" data-role="middle_content_template" data-template="{&quot;html&quot;:&quot;&lt;div class=\&quot;embeddable_form-wrapper for-post\&quot; data-role=\&quot;blog_subscribe\&quot; data-view=\&quot;blog_subscribe#form\&quot;&gt;&lt;form action=\&quot;/blog/subscription\&quot; class=\&quot;embeddable_form\&quot; data-entity=\&quot;blog_subscription\&quot; data-remote=\&quot;\&quot; data-view=\&quot;form#form\&quot; method=\&quot;post\&quot;&gt;&lt;div class=\&quot;embeddable_form-step is-email_form is-current\&quot;&gt;&lt;div class=\&quot;embeddable_form-row is-label\&quot;&gt;&lt;div class=\&quot;embeddable_form-label_title\&quot;&gt;Like what you&amp;#39;re reading?&lt;/div&gt;&lt;div class=\&quot;embeddable_form-label\&quot;&gt;Get the latest updates first.&lt;/div&gt;&lt;/div&gt;&lt;div class=\&quot;embeddable_form-row form-field is-email_field\&quot;&gt;&lt;input autocomplete=\&quot;off\&quot; class=\&quot;input is-medium\&quot; data-role=\&quot;email\&quot; name=\&quot;blog_subscription[email]\&quot; placeholder=\&quot;Enter your email address...\&quot; type=\&quot;text\&quot; /&gt;&lt;input name=\&quot;blog_subscription[vertical]\&quot; type=\&quot;hidden\&quot; value=\&quot;designers\&quot; /&gt;&lt;input name=\&quot;from_widget\&quot; type=\&quot;hidden\&quot; value=\&quot;true\&quot; /&gt;&lt;/div&gt;&lt;div class=\&quot;embeddable_form-row is-submit\&quot;&gt;&lt;input class=\&quot;button is-green_candy is-default is-full_width\&quot; data-loader-text=\&quot;Subscribing...\&quot; data-role=\&quot;submit\&quot; type=\&quot;submit\&quot; value=\&quot;Get Exclusive Updates\&quot; /&gt;&lt;/div&gt;&lt;div class=\&quot;embeddable_form-row is-privacy\&quot;&gt;&lt;div class=\&quot;embeddable_form-privacy\&quot;&gt;&lt;div class=\&quot;embeddable_form-privacy_icon\&quot;&gt;&lt;/div&gt;&lt;div class=\&quot;embeddable_form-privacy_text\&quot;&gt;No spam. Just great design posts.&lt;/div&gt;&lt;/div&gt;&lt;/div&gt;&lt;/div&gt;&lt;div class=\&quot;embeddable_form-step is-confirmation\&quot; data-place=\&quot;@blog_subscribe\&quot; data-role=\&quot;confirmation\&quot;&gt;&lt;div class=\&quot;embeddable_form-row is-label is-success\&quot;&gt;&lt;div class=\&quot;embeddable_form-label_title\&quot;&gt;Like what you&amp;#39;re reading?&lt;/div&gt;&lt;div class=\&quot;embeddable_form-label\&quot;&gt;Get the latest updates first.&lt;/div&gt;&lt;/div&gt;&lt;div class=\&quot;embeddable_form-row is-success\&quot;&gt;&lt;div class=\&quot;embeddable_form-label is-header\&quot;&gt;Thank you for subscribing!&lt;/div&gt;&lt;div class=\&quot;embeddable_form-label\&quot;&gt;Check your inbox to confirm subscription. You&#39;ll start receiving posts after you confirm.&lt;/div&gt;&lt;/div&gt;&lt;div class=\&quot;embeddable_form-row is-success\&quot;&gt;&lt;ul class=\&quot;social_share is-horizontal\&quot; data-rss-url=\&quot;https://www.toptal.com/designers/blog.rss\&quot; data-url=\&quot;https://www.toptal.com/designers/blog\&quot; data-view=\&quot;layout#social_share\&quot; data-youtube-channel-url=\&quot;https://www.youtube.com/channel/UCNqm_euTHZz3o5OnKhUS-oA\&quot;&gt;&lt;li class=\&quot;social_share-item is-counter\&quot; title=\&quot;Total number of shares\&quot;&gt;&lt;span class=\&quot;social_share-item_num\&quot; data-role=\&quot;counter_num\&quot;&gt;0&lt;/span&gt;&lt;span class=\&quot;social_share-item_text\&quot; data-role=\&quot;counter_text\&quot;&gt;shares&lt;/span&gt;&lt;/li&gt;&lt;li class=\&quot;social_share-item\&quot;&gt;&lt;a class=\&quot;social_share-item_link\&quot; data-role=\&quot;link\&quot; data-track-click=\&quot;SocialShareButtonClicked\&quot; data-track-default-data=\&quot;{&amp;quot;network&amp;quot;:&amp;quot;twitter&amp;quot;}\&quot; data-type=\&quot;twitter\&quot; title=\&quot;Share on Twitter\&quot;&gt;&lt;img class=\&quot;social_share-item_image\&quot; height=\&quot;50\&quot; src=\&quot;https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/twitter_83c6d4.png\&quot; width=\&quot;50\&quot; /&gt;&lt;/a&gt;&lt;/li&gt;&lt;li class=\&quot;social_share-item\&quot;&gt;&lt;a class=\&quot;social_share-item_link\&quot; data-role=\&quot;link\&quot; data-track-click=\&quot;SocialShareButtonClicked\&quot; data-track-default-data=\&quot;{&amp;quot;network&amp;quot;:&amp;quot;facebook&amp;quot;}\&quot; data-type=\&quot;facebook\&quot; title=\&quot;Share on Facebook\&quot;&gt;&lt;img class=\&quot;social_share-item_image\&quot; height=\&quot;50\&quot; src=\&quot;https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/facebook_dc66c9.png\&quot; width=\&quot;50\&quot; /&gt;&lt;/a&gt;&lt;/li&gt;&lt;li class=\&quot;social_share-item\&quot;&gt;&lt;a class=\&quot;social_share-item_link\&quot; data-role=\&quot;link\&quot; data-track-click=\&quot;SocialShareButtonClicked\&quot; data-track-default-data=\&quot;{&amp;quot;network&amp;quot;:&amp;quot;google_plus&amp;quot;}\&quot; data-type=\&quot;google_plus\&quot; title=\&quot;Share on Google Plus\&quot;&gt;&lt;img class=\&quot;social_share-item_image\&quot; height=\&quot;50\&quot; src=\&quot;https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/google_plus_355fb0.png\&quot; width=\&quot;50\&quot; /&gt;&lt;/a&gt;&lt;/li&gt;&lt;/ul&gt;&lt;/div&gt;&lt;/div&gt;&lt;/form&gt;&lt;/div&gt;&quot;}"></div></div><div class="blog-comments"><div id="disqus_thread_container"><div id="disqus_thread"><div class="d-noscript-comments"><h3>Comments</h3><div class="comment"><div class="comment-author">Christopher Penkin</div><div class="comment-body">Great article. Thanks Stian.</div></div><div class="comment"><div class="comment-author">Stephan Van Der Merwe</div><div class="comment-body">This is an excellent article about the things that motivate us while using products. I learned a lot. Thanks</div></div><div class="comment"><div class="comment-author">Sudheendra</div><div class="comment-body">Excellent article.</div></div></div></div></div><script>function isIos() {
  return /(iPad|iPhone|iPod)/g.test(navigator.userAgent);
}

function adjustHeightInIos() {
  if (isIos()) {
    var height = $('#disqus_thread').outerHeight();
    $('#disqus_thread_container').height(height);
  }
}

if (isIos()) {
  var el = document.getElementById('disqus_thread_container');
  el.style.height = '1px';
  el.style.overflow = 'hidden';
  el.style.width = '100%';
}

function disqus_config() {
  this.callbacks.onNewComment = [function() {
    $.post('/blog/comments/on_create');
    adjustHeightInIos();
  }];

  this.callbacks.onReady = [adjustHeightInIos];
}

var disqus_shortname = 'toptal';
var disqus_identifier = 'ui/gamification-design';

(function() {
  var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
  dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
  (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
})();</script><noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript><a class="dsq-brlink" href="https://disqus.com">comments powered by <span class="logo-disqus">Disqus</span></a></div></div></div><div class="two_columns_layout-extra"><div class="blog-block-wrapper"><div class="blog-block-header">Subscribe</div><div class="blog-block"><div class="blog-block-row"><div class="embeddable_form-wrapper is-horizontal" data-role="blog_subscribe" data-view="blog_subscribe#form"><form action="/blog/subscription" class="embeddable_form" data-entity="blog_subscription" data-remote="" data-view="form#form" method="post"><div class="embeddable_form-step is-email_form is-current"><div class="embeddable_form-row is-label"><div class="embeddable_form-label_title">Free email updates</div><div class="embeddable_form-label">Get the latest content first.</div></div><div class="embeddable_form-row form-field is-email_field"><input autocomplete="off" class="input is-medium" data-role="email" name="blog_subscription[email]" placeholder="Enter your email address..." type="text" /><input name="blog_subscription[vertical]" type="hidden" value="designers" /><input name="from_widget" type="hidden" value="true" /></div><div class="embeddable_form-row is-submit"><input class="button is-green_candy is-default is-full_width" data-loader-text="Subscribing..." data-role="submit" type="submit" value="Get Exclusive Updates" /></div><div class="embeddable_form-row is-privacy"><div class="embeddable_form-privacy"><div class="embeddable_form-privacy_icon"></div><div class="embeddable_form-privacy_text">No spam. Just great design posts.</div></div></div></div><div class="embeddable_form-step is-confirmation" data-place="@blog_subscribe" data-role="confirmation"><div class="embeddable_form-row is-label is-success"><div class="embeddable_form-label_title">Free email updates</div><div class="embeddable_form-label">Get the latest content first.</div></div><div class="embeddable_form-row is-success"><div class="embeddable_form-label is-header">Thank you for subscribing!</div><div class="embeddable_form-label">Check your inbox to confirm subscription. You'll start receiving posts after you confirm.</div></div><div class="embeddable_form-row is-success"><ul class="social_share is-horizontal" data-rss-url="https://www.toptal.com/designers/blog.rss" data-url="https://www.toptal.com/designers/blog" data-view="layout#social_share" data-youtube-channel-url="https://www.youtube.com/channel/UCNqm_euTHZz3o5OnKhUS-oA"><li class="social_share-item is-counter" title="Total number of shares"><span class="social_share-item_num" data-role="counter_num">0</span><span class="social_share-item_text" data-role="counter_text">shares</span></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;twitter&quot;}" data-type="twitter" title="Share on Twitter"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/twitter_83c6d4.png" width="50" /></a></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;facebook&quot;}" data-type="facebook" title="Share on Facebook"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/facebook_dc66c9.png" width="50" /></a></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;google_plus&quot;}" data-type="google_plus" title="Share on Google Plus"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/google_plus_355fb0.png" width="50" /></a></li></ul></div></div></form></div></div></div><div class="blog-block-header">Trending articles</div><div class="blog-block"><nav class="blog-trending"><a class="post is-preview blog-trending-item" href="/designers/ui/gamification-design"><span class="post_cover is-preview"><noscript><img class="post_cover-image" src="https://uploads.toptal.io/blog/cover_image/120542/side_list_cover-image_0-9f33c9e31d85959bc2eefb9d1c705466.png" /></noscript><span class="post_cover-image" data-role="deferred" data-src="https://uploads.toptal.io/blog/cover_image/120542/side_list_cover-image_0-9f33c9e31d85959bc2eefb9d1c705466.png"></span></span><span class="post-preview"><span class="post-title">A Practical Approach to Gamification Design</span><span class="post_meta"><span class="post_meta-date">1 day ago</span></span></span></a><a class="post is-preview blog-trending-item" href="/designers/ia/guide-to-information-architecture"><span class="post_cover is-preview"><noscript><img class="post_cover-image" src="https://uploads.toptal.io/blog/cover_image/120539/side_list_cover-image_0-da61338eb09fed3b2a0162c8e31a4833.png" /></noscript><span class="post_cover-image" data-role="deferred" data-src="https://uploads.toptal.io/blog/cover_image/120539/side_list_cover-image_0-da61338eb09fed3b2a0162c8e31a4833.png"></span></span><span class="post-preview"><span class="post-title">The Comprehensive Guide to Information Architecture</span><span class="post_meta"><span class="post_meta-date">6 days ago</span></span></span></a><a class="post is-preview blog-trending-item" href="/designers/user-research/net-promoter-score-not-enough-need-user-research"><span class="post_cover is-preview"><noscript><img class="post_cover-image" src="https://uploads.toptal.io/blog/cover_image/120538/side_list_cover-image_0-a53d20dd3e6a8dc95258f7760de4530e.png" /></noscript><span class="post_cover-image" data-role="deferred" data-src="https://uploads.toptal.io/blog/cover_image/120538/side_list_cover-image_0-a53d20dd3e6a8dc95258f7760de4530e.png"></span></span><span class="post-preview"><span class="post-title">Net Promoter Score Isn’t Enough: You Need User Research</span><span class="post_meta"><span class="post_meta-date">8 days ago</span></span></span></a><a class="post is-preview blog-trending-item" href="/designers/ui/designing-a-vui"><span class="post_cover is-preview"><noscript><img class="post_cover-image" src="https://uploads.toptal.io/blog/cover_image/120535/side_list_cover-image_0-357dad81e1561bd0349890ea520f9999.png" /></noscript><span class="post_cover-image" data-role="deferred" data-src="https://uploads.toptal.io/blog/cover_image/120535/side_list_cover-image_0-357dad81e1561bd0349890ea520f9999.png"></span></span><span class="post-preview"><span class="post-title">Designing a VUI – Voice User Interface</span><span class="post_meta"><span class="post_meta-date">13 days ago</span></span></span></a><a class="post is-preview blog-trending-item" href="/designers/product-design/creativity-exercises-to-boost-your-designs"><span class="post_cover is-preview"><noscript><img class="post_cover-image" src="https://uploads.toptal.io/blog/cover_image/120532/side_list_cover-image_0-7c3bf44fda9105104f93f6b0bf5bc7d9.png" /></noscript><span class="post_cover-image" data-role="deferred" data-src="https://uploads.toptal.io/blog/cover_image/120532/side_list_cover-image_0-7c3bf44fda9105104f93f6b0bf5bc7d9.png"></span></span><span class="post-preview"><span class="post-title">Creativity Exercises to Boost Your Designs</span><span class="post_meta"><span class="post_meta-date">15 days ago</span></span></span></a><a class="post is-preview blog-trending-item" href="/designers/user-experience/anticipatory-persuasive-emotional-design-ux"><span class="post_cover is-preview"><noscript><img class="post_cover-image" src="https://uploads.toptal.io/blog/cover_image/120529/side_list_cover-0122_UltimateUXHook_Luke_Banner-c9894d583b40656fd4e3297e6f15eb5e.png" /></noscript><span class="post_cover-image" data-role="deferred" data-src="https://uploads.toptal.io/blog/cover_image/120529/side_list_cover-0122_UltimateUXHook_Luke_Banner-c9894d583b40656fd4e3297e6f15eb5e.png"></span></span><span class="post-preview"><span class="post-title">The Ultimate UX Hook – Anticipatory, Persuasive, and Emotional Design in UX</span><span class="post_meta"><span class="post_meta-date">20 days ago</span></span></span></a><a class="post is-preview blog-trending-item" href="/designers/product-design/design-news-monthly-01-18"><span class="post_cover is-preview"><noscript><img class="post_cover-image" src="https://uploads.toptal.io/blog/cover_image/120528/side_list_cover-MonthlyDesignWorldNews_1of12-a2b8337f85dd6eb6481b850fd0d79f8a.png" /></noscript><span class="post_cover-image" data-role="deferred" data-src="https://uploads.toptal.io/blog/cover_image/120528/side_list_cover-MonthlyDesignWorldNews_1of12-a2b8337f85dd6eb6481b850fd0d79f8a.png"></span></span><span class="post-preview"><span class="post-title">Design News – Innovation from Around the Globe</span><span class="post_meta"><span class="post_meta-date">21 days ago</span></span></span></a><a class="post is-preview blog-trending-item" href="/designers/brand/presentation-design-tips"><span class="post_cover is-preview"><noscript><img class="post_cover-image" src="https://uploads.toptal.io/blog/cover_image/120527/side_list_cover-1701_02_Presentation-Design_Dan_banner-b2a77d721f96e2090cd6eca08640ace4.png" /></noscript><span class="post_cover-image" data-role="deferred" data-src="https://uploads.toptal.io/blog/cover_image/120527/side_list_cover-1701_02_Presentation-Design_Dan_banner-b2a77d721f96e2090cd6eca08640ace4.png"></span></span><span class="post-preview"><span class="post-title">Presentation Design and the Art of Visual Storytelling</span><span class="post_meta"><span class="post_meta-date">22 days ago</span></span></span></a></nav></div><div class="blog-block-header">Relevant Technologies</div><div class="blog-block"><div class="blog-block-row"><ul class="blog-relevant"><li class="blog-relevant-item"><a class="link is-blue" href="https://www.toptal.com/designers/ui">UI</a></li><li class="blog-relevant-item"><a class="link is-blue" href="https://www.toptal.com/designers/ux">UX</a></li><li class="blog-relevant-item"><a class="link is-blue" href="https://www.toptal.com/designers/visual">Visual</a></li></ul></div></div><div class="blog-block has-no_background blog_banner for-author blog_author_banner" data-ga-action="ClickedOnHireTheAuthor_lateral" data-ga-label="gamification-design" data-view="content#sidebar_banner"><div class="blog-block-header">About the author</div><div class="blog_author_banner-photo_wrapper"><img alt="Stian Sandsgaard" class="blog_author_banner-photo" src="https://uploads.toptal.io/user/photo/618978/large_5e04d291217d5852cb62153a76ef440c.jpg" /></div><div class="blog_author_banner-content" data-role="author_content"><div class="blog_author_banner-name"><a href="/designers/resume/stian-sandsgaard">Stian Sandsgaard</a></div><div class="blog_author_banner-role">Designer</div><div class="blog_author_banner-about" data-role="author_about">Stian is an award-winning designer with eight years of experience in the corporate and start-up industry. Working with both large and small-scale projects in SaaS. He specializes in UX and UI design as well as having experience in animation and VFX. Especially oriented around behavioral science also known as gamification. Some of the clients he&#39;s worked with include Statoil, Westcon, Baikingu, and InfoGym. </div><div class="blog_author_banner-content_footer"></div></div><div class="blog_author_banner-cta"><a class="button is-green_candy is-default is-full_width" data-role="banner_link" href="https://www.toptal.com/companies/apply?interested_in=designers&amp;skill=ui">Hire the Author</a></div></div></div></div></div></section></main><footer class="hide_in_webview"><section class="grid-row has-solid_blue_bg page_footer_map-wrapper"><div class="grid-row-inner has-huge_padding page_footer_map"><div class="page_footer_map-content">Toptal connects the&nbsp;<a href="https://www.toptal.com/top-3-percent">top&nbsp;3%</a> of&nbsp;freelance talent all over&nbsp;the&nbsp;world.</div></div></section><section class="grid-row page_footer_sample_profile-wrapper"><div class="grid-row-inner has-big_padding"><h2 class="header is-row">Toptal Designers</h2><div class="skills_list"><ul class="multi_column_list qa-skills_list"><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/creative-direction">Creative Directors</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/freelance">Freelance Designers</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/graphic">Graphic Designers</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/illustration">Illustrators</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/logo">Logo Designers</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/mobile">Mobile App Designers</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/product-design">Product Designers</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/ui">UI Designers</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/ux">UX Designers</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/visual">Visual Designers</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/web">Web Designers</a></li></ul><div class="skills_list-see_all_wrapper"><a class="button is-tiny is-white is-uppercased" href="https://www.toptal.com/designers"><div class="skills_list-see_all_icon for-designers"></div>See more freelance designers</a></div></div></div></section><div class="skills_enterprise_link"><a class="skills_enterprise_link-url" href="/enterprise">Learn how enterprises benefit from Toptal experts.</a></div><section class="grid-row has-top_border page_footer_join-wrapper" id=""><div class="grid-row-inner has-padding page_footer_join"><h2 class="page_footer_join-header">Join the Toptal community.</h2><div class="page_footer_join-spacer"></div><nav class="page_footer_join-actions"><div class="page_footer_join-item"><a class="button is-green_candy is-big is-fixed page_footer_join-button" href="https://www.toptal.com/companies/apply?interested_in=designers&amp;skill=ui">Hire a designer</a></div><div class="page_footer_join-item is-or">or</div><div class="page_footer_join-item"><a class="button is-green_candy is-big is-fixed page_footer_join-button" href="https://www.toptal.com/designers/join">Apply as a Designer</a></div></nav></div></section><section class="grid-row page_footer_links-wrapper"><div class="grid-row-inner is-wide has-big_padding"><nav class="page_footer_links"><section class="page_footer_links-column is-1"><h3 class="page_footer_links-column_header">Highest In-Demand Talent</h3><ul class="page_footer_links-list"><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/ios">iOS Developer</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/front-end">Front-End Developer</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/designers/ux">UX Designer</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/designers/ui">UI Designer</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/finance/financial-modeling">Financial Modeling Consultants</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/finance/interim-cfos">Interim CFOs</a></li></ul></section><section class="page_footer_links-column is-2"><h3 class="page_footer_links-column_header">About</h3><ul class="page_footer_links-list"><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/top-3-percent">Top 3%</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/clients">Clients</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/developers">Freelance Developers</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/designers">Freelance Designers</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/finance">Freelance Finance Experts</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/about">About Us</a></li></ul></section><section class="page_footer_links-column is-3"><h3 class="page_footer_links-column_header">Contact</h3><ul class="page_footer_links-list"><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/contact">Contact Us</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/press-center">Press Center</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/careers">Careers</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/faq">FAQ</a></li></ul></section><section class="page_footer_links-column is-4"><h3 class="page_footer_links-column_header">Social</h3><ul class="page_footer_links-list"><li class="page_footer_links-item for-social_link"><a class="page_footer_links-social_link is-facebook" href="https://www.facebook.com/toptal">Facebook</a></li><li class="page_footer_links-item for-social_link"><a class="page_footer_links-social_link is-twitter" href="https://twitter.com/toptal">Twitter</a></li><li class="page_footer_links-item for-social_link"><a class="page_footer_links-social_link is-google" href="https://plus.google.com/+Toptalllc/">Google+</a></li><li class="page_footer_links-item for-social_link"><a class="page_footer_links-social_link is-linkedin" href="https://www.linkedin.com/company/toptal">LinkedIn</a></li></ul></section></nav></div></section><section class="grid-row page_footer_legal-wrapper"><div class="grid-row-inner has-medium_padding page_footer_legal is-wide"><div class="logo-wrapper page_footer_legal-logotype"><a class="logo is-mini is-link" href="https://www.toptal.com/">Toptal</a><p class="logo-motto is-mini">Hire the top 3% of freelance talent</p></div><ul class="page_footer_legal-links"><li class="page_footer_legal-links_item is-copyright"><p class="page_footer_legal-copyright">© Copyright 2010 - 2018 Toptal, LLC</p></li><li class="page_footer_legal-links_item has-right_margin"><a class="page_footer_legal-link" href="https://www.toptal.com/privacy">Privacy Policy</a></li><li class="page_footer_legal-links_item"><a class="page_footer_legal-link" href="https://www.toptal.com/tos">Website Terms</a></li></ul></div></section></footer></div><div class="layout-overlay" data-view="layout#overlay"></div><div data-view="bounce_modals#events"><div data-view="bounce_modals#modal"></div></div><div class="notification-container" data-view="notifications#service"></div><script>setTimeout(function () {
  classNameWithFont = document.documentElement.className + ' wf-active'
  document.documentElement.className = classNameWithFont
}, 0);</script><script src="https://assets.toptal.io/assets/public-21b8650bce6d3894373f9f7962a9cbffc06373cb.js"></script><script src="https://assets.toptal.io/assets/blog-21b8650bce6d3894373f9f7962a9cbffc06373cb.js"></script><div class="layout-counters"><script>if (typeof(window.Widgets) !== 'undefined') {
  var appId = 'UA-21104039-1';
  if (appId.length > 0 && !(window.googleAnalytics instanceof Widgets.GoogleAnalytics)) {
    window.googleAnalytics = new Widgets.GoogleAnalytics(appId, 'auto');
    window.googleAnalytics.bucketRole('', '');

    if (typeof(window.gon) !== 'undefined' && gon['ga_settings']){
      window.googleAnalytics.grouping(gon['ga_settings']['group']);
    }

    if (typeof(window.gon) !== 'undefined' && gon['chameleon_current_experiments']) {
      for (var experiment_key in gon['chameleon_current_experiments']) {
        var experiment = gon['chameleon_current_experiments'][experiment_key];
        window.googleAnalytics.set(experiment.google_analytics_dimension, experiment.variant_key);
      }
    }

    window.googleAnalytics.trackPageview();
    window.googleAnalytics.track15secondsRead();
  }
}</script><script>// We are checking if window.analytics has the track function in case some dom element has the id equal analytics
if (!window.analytics || typeof window.analytics.track !== 'function') {
  // We do this because if some dom element has id equal analytics we need to override it, otherwise it wouldn't set analytics right
  window.analytics = undefined
  !function(){var analytics=window.analytics=window.analytics||[];if(!analytics.initialize)if(analytics.invoked)window.console&&console.error&&console.error("Segment snippet included twice.");else{analytics.invoked=!0;analytics.methods=["setAnonymousId", "trackSubmit","trackClick","trackLink","trackForm","pageview","identify","group","track","ready","alias","page","once","off","on"];analytics.factory=function(t){return function(){var e=Array.prototype.slice.call(arguments);e.unshift(t);analytics.push(e);return analytics}};for(var t=0;t<analytics.methods.length;t++){var e=analytics.methods[t];analytics[e]=analytics.factory(e)}analytics.load=function(t){var e=document.createElement("script");e.type="text/javascript";e.async=!0;e.src=("https:"===document.location.protocol?"https://":"http://")+"cdn.segment.com/analytics.js/v1/"+t+"/analytics.min.js";var n=document.getElementsByTagName("script")[0];n.parentNode.insertBefore(e,n)};analytics.SNIPPET_VERSION="3.0.1";
  analytics.load('jnS4QsHOCAOeG6XvMDCjD9n9bAcQ53Mb');
  }}();
}
(function() {
  function readVisitorIdCookie() {
    var cookieName = 'visitor_id=';
    var cookies = document.cookie.split(';');
    for (var i = 0; i < cookies.length; i++) {
      var cookie = cookies[i].replace(/^\s+|\s+$/g, '');
      if (cookie.indexOf(cookieName) === 0) {
        return cookie.split('=')[1];
      }
    }
  }
  analytics.setAnonymousId(readVisitorIdCookie());
  
  analytics.page('posts#show');
})();</script><script async="" defer="" id="hs-script-loader" src="//js.hs-scripts.com/2799924.js" type="text/javascript"></script><script>var _hsq = window._hsq = window._hsq || [];
</script><script>(function() {
  var accountId = 41085
  if (accountId && window.Widgets && window.Widgets.Criteo && !window.criteo) {
    window.criteo = new Widgets.Criteo(accountId)
  }
})()</script><script src="https://tribl.io/footer.js?orgId=EdOAdeaAj8s34gqB05v6"></script><iframe frameborder="0" height="1" scrolling="no" src="https://www.attributiontracker.com/tracker/account_visit?tt_visit=1" width="1"></iframe><script type='text/javascript'>
  (function(A, d, S, t, a, g, e) {
    A['AdstageAnalytics'] = a;
    A[a] = A[a] || function() {
      (A[a].q = A[a].q || []).push(arguments)
    };
    A[a].l = 1 * new Date();
    g = d.createElement(S), e = d.getElementsByTagName(S)[0];
    g.async = 1;
    g.src = t;
    e.parentNode.insertBefore(g, e);
  })(window, document, 'script', '//assets.adstage.io/analytics.js', '_as');
  _as('create', 'e2dd65eb-07a1-4d93-874a-fe6dac5a8b64');
  _as('send', 'pageview');
</script>
<script>setTimeout(function(){var a=document.createElement("script");
var b=document.getElementsByTagName("script")[0];
a.src=document.location.protocol+"//dnn506yrbagrg.cloudfront.net/pages/scripts/0012/5977.js?"+Math.floor(new Date().getTime()/3600000);
a.async=true;a.type="text/javascript";b.parentNode.insertBefore(a,b)}, 1);</script><script type="text/javascript">
_bizo_data_partner_id = "8663";
</script>
<script type="text/javascript">
(function() {
  var s = document.getElementsByTagName("script")[0];
  var b = document.createElement("script");
  b.type = "text/javascript";
  b.async = true;
  b.src = (window.location.protocol === "https:" ? "https://sjs" : "http://js") + ".bizographics.com/insight.min.js";
  s.parentNode.insertBefore(b, s);
})();
</script>
<noscript>
  <img height="1" width="1" alt="" style="display:none;" src="//www.bizographics.com/collect/?pid=8663&fmt=gif" />
</noscript>
<script>
  !function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window,document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');

  fbq('init', '463369723801939'); 
  fbq('track', 'PageView');
</script>
<noscript>
 <img height="1" width="1" src="https://www.facebook.com/tr?id=463369723801939&ev=PageView&noscript=1"/>
</noscript>
</div><script>window.criteo && window.criteo.sendEvent('setData', {ui_detag: 1})</script><div id="breadcrumbs" class="breadcrumbs"><span itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url" href="https://www.toptal.com/"><span itemprop="title">Home</span></a></span> &rsaquo; <span itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url" href="https://www.toptal.com/developers/blog"><span itemprop="title">Blog</span></a></span> &rsaquo; <span itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb"><a class="current" itemprop="url" href="/designers/ui/gamification-design"><span itemprop="title">A Practical Approach to Gamification Design</span></a></span></div></body></html>