<!DOCTYPE html><!--[if IE 7]><html class="layout-wrapper ie ie7 lte9 lte8 lte7"><![endif]--><!--[if IE 8]><html class="layout-wrapper ie ie8 lte9 lte8"><![endif]--><!--[if IE 9]><html class="layout-wrapper ie ie9 lte9"><![endif]--><!--[if (gte IE 9)|!(IE)]<!--><html class="layout-wrapper"><head><title>Take It to the Limit - an Overview of Long Scroll Sites | Toptal</title>
<meta name="description" content="While infinite scroll has become a popular and common design pattern, there are some potential pitfalls UI designers should watch out for when designing a site that uses long scrolling. There are also some types of sites where long scrolling isn’t an appropriate design pattern to employ." />
<link rel="alternate" href="https://www.toptal.com/designers/ui/long-scroll-websites" hreflang="en" />
<link rel="canonical" href="https://www.toptal.com/designers/ui/long-scroll-websites" />
<meta property="og:image" content="https://uploads.toptal.io/blog/post_image/122030/image_14-25e3700ce18789b8229c0d06795f0983.png" />
<meta property="og:title" content="Take It to the Limit - an Overview of Long Scroll Websites" />
<meta property="og:description" content="While infinite scroll has become a popular and common design pattern, there are some potential pitfalls UI designers should watch out for when designing a site that uses long scrolling. There are also some types of sites where long scrolling isn’t an appropriate design pattern to employ." />
<meta property="og:site_name" content="Toptal Design Blog" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="DC.date.issued" content="2019-02-14" /><meta charset="utf-8" /><meta content="IE=edge,chrome=1" http-equiv="X-UA-Compatible" />
<script>window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"e3359cee6b","applicationID":"30100511","transactionName":"JV0NEUYJCQkARxgVEwReCgYbFgoWEUYYFg4JRQ==","queueTime":0,"applicationTime":130,"agent":""}</script>
<script>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</script><meta content="width=device-width, initial-scale=1.0" name="viewport" /><script>(function(w,d,s,l,i){
  w[l]=w[l]||[];
  w[l].push({
    'gtm.start': new Date().getTime(),
    event:'gtm.js'
  });
  var f=d.getElementsByTagName(s)[0],
      j=d.createElement(s),
      dl=l!='dataLayer'?'&l='+l:'';
  j.async=true;
  j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;
  f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-K4WD79L');</script><script>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</script>
<link href="https://assets.toptal.io/assets/front/static/favicons/favicon_ca7136.png" rel="icon" /><!--[if IE]><link href="https://assets.toptal.io/assets/front/static/favicons/favicon_68b340.ico" rel="shortcut icon" /><![endif]--><link href="https://assets.toptal.io/assets/front/static/favicons/touch_x57_f72647.png" rel="apple-touch-icon-precomposed" sizes="57x57" /><link href="https://assets.toptal.io/assets/front/static/favicons/touch_x72_516451.png" rel="apple-touch-icon-precomposed" sizes="72x72" /><link href="https://assets.toptal.io/assets/front/static/favicons/touch_x114_1798a8.png" rel="apple-touch-icon-precomposed" sizes="114x114" /><link href="https://assets.toptal.io/assets/front/static/favicons/touch_x57_f72647.png" rel="apple-touch-icon-precomposed" /><script src="https://assets.toptal.io/assets/jquery_and_modernizr-8047c0ad2baab9a986b8f0996a34edd086582a2e.js"></script><script>// TODO: Figure out how to override Modernizr test
(function () {
  var isIE, isIE11, noFlexboxClassName;
  isIE = /MSIE/.test(navigator.userAgent) && !/Opera/.test(navigator.userAgent);
  isIE11 = window.MSInputMethodContext && !/\bEdge\/[0-9.]+$/.test(navigator.userAgent);
  if (window.Modernizr && window.Modernizr.flexbox && (isIE || isIE11)) {
    noFlexboxClassName = document.documentElement.className.replace(/\bflexbox\b/, 'no-flexbox ie-flexbox');
    document.documentElement.className = noFlexboxClassName;
  }
})();</script><script>
//<![CDATA[
window.gon={};gon.ga_settings={"group":"Blog posts"};gon.current_vertical="designers";gon.url_share_counter=0;gon.chameleon_current_experiments={"bounce_modal_blog":{"google_analytics_dimension":"dimension16","variant_key":"switched_off"},"blog_post_ux_experiments":{"google_analytics_dimension":"dimension9","variant_key":"reading_time_and_progress_bar"}};gon.current_skill_name="UI";gon.current_skill_name_overriden_singular="UI designer";gon.current_skill_name_overriden_plural="UI designers";
//]]>
</script><link rel="stylesheet" media="screen" href="https://assets.toptal.io/assets/public_styles-8047c0ad2baab9a986b8f0996a34edd086582a2e.css" /><link rel="stylesheet" media="screen" href="https://assets.toptal.io/assets/portal_styles-8047c0ad2baab9a986b8f0996a34edd086582a2e.css" /><link rel="stylesheet" media="screen" href="https://assets.toptal.io/assets/blog_styles-8047c0ad2baab9a986b8f0996a34edd086582a2e.css" /><script>if(!window.appinfo) {
  var thens = []
  var catches = []
  var LocalPromise = {
    then: function(callback, error) {
      thens.push(callback)
      if (error) {
        catches.push(error)
      }
    },
    catch: function (error) {
      catches.push(error)
    }
  }
  var resolve = function() {
    var args = arguments
    thens.forEach(function(callback) {
      callback.apply(null, args)
    })
  }
  var reject = function() {
    var args = arguments
    catches.forEach(function(callback) {
      callback.apply(null, args)
    })
  }

  window.onAppInfoLoaded = LocalPromise

  window.onAppinfoLoad = function() {
    document.cookie = 'appinfo_id_status=doing_request;'

    window.appinfo.grab('https://appinfo.toptal.com', {
      data: gon['application_info_data'] || {},
      callback: function(response, error) {
        if (!error) {
          document.cookie = 'appinfo_id_status=request_completed;'

          resolve({
            applicationInfo: response.data
          })
        } else {
          document.cookie = 'appinfo_id_status=request_failed;'
        }
      }
    })
  }

  document.cookie = 'appinfo_id_status=loading_script;'

  var script = document.createElement('script')
  script.type = 'text/javascript'
  script.onError = function() {
    document.cookie = 'appinfo_id_status=script_load_failed;'
    reject()
  }
  script.src = 'https://appinfo.toptal.com/script.js'
  document.getElementsByTagName('head')[0].appendChild(script)
}</script></head><body class="layout" data-view="layout#body" id="top"><div class="layout_layer" data-view="layout#layout"><header class="page_header hide_in_webview" data-role="fixed-header"><div class="page_header_line"></div><div class="page_header" data-view="layout#menu"><div class="blog-simple-header grid-row is-light_gray" data-role="main_menu_wrapper"><div class="grid-row-inner is-wide has-padding page_header_top"><div class="page_header_top-logotype_wrapper"><div class="page_header_top-logotype"><a class="logo is-big is-link" href="https://www.toptal.com/designers"></a></div><div class="page_header_top-main_title"><b>Hiring?</b> Toptal handpicks <b><a href="https://www.toptal.com/designers/ui" onclick='window.googleAnalytics.trackEvent(event, "BlogCTAs", "ClickedOnHeaderHeadline", "ClickedOnHeaderHeadline")'>top UI designers</a></b> to suit your needs.</div></div><a class="page_header_top-expand" data-role="expand_menu" href="#"><span class="page_header_top-expand_icon"></span></a><nav class="page_header_top-nav_wrapper"><ul class="page_header_top-nav"><li class="page_header_top-nav_item"><a class="button is-green_candy is-small page_header_top-nav_link is-button" data-role="companies_apply_button" href="https://www.toptal.com/designers/ui" onclick="window.googleAnalytics.trackEvent(event, &quot;BlogCTAs&quot;, &quot;ClickedOnHeaderCTA&quot;, &quot;ClickedOnHeaderCTA&quot;);">Start hiring</a></li><li class="page_header_top-nav_item"><a class="button is-small is-light page_header_top-nav_link is-button" href="https://www.toptal.com/users/login">Log in</a></li></ul></nav></div></div><nav class="grid-row has-top_border is-light_gray page_header_menu-wrapper" data-role="main_menu_wrapper"><div class="grid-row-inner is-wide has-small_padding page_header_menu"><div class="page_header_menu-items-wrapper"><ul class="page_header_menu-items" data-role="menu"><li class="page_header_menu-item is-home"><a class="page_header_menu-link" href="https://www.toptal.com/designers"></a></li><li class="page_header_menu-item is-top-3-percent"><a class="page_header_menu-link" href="https://www.toptal.com/top-3-percent">Top 3%</a></li><li class="page_header_menu-item is-why"><a class="page_header_menu-link" href="https://www.toptal.com/why">Why</a></li><li class="page_header_menu-item is-clients"><a class="page_header_menu-link" href="https://www.toptal.com/clients">Clients</a></li><li class="page_header_menu-item is-enterprise"><a class="page_header_menu-link" href="https://www.toptal.com/enterprise">Enterprise</a></li><li class="page_header_menu-item is-community"><a class="page_header_menu-link" href="https://www.toptal.com/community">Community</a></li><li class="page_header_menu-item is-blog"><a class="page_header_menu-link" href="https://www.toptal.com/designers/blog">Blog</a></li><li class="page_header_menu-item is-about"><a class="page_header_menu-link" href="https://www.toptal.com/about">About Us</a></li><li class="page_header_menu-item is-join"><a class="button is-green_candy is-small page_hader_menu-button" data-role="companies_apply_button" href="https://www.toptal.com/designers/ui" onclick="window.googleAnalytics.trackEvent(event, &quot;BlogCTAs&quot;, &quot;ClickedOnHeaderCTA&quot;, &quot;ClickedOnHeaderCTA&quot;);">Start hiring</a></li><li class="page_header_menu-item is-join"><a class="button is-green_candy is-small page_hader_menu-button" href="https://www.toptal.com/designers/join">Apply as a Designer</a></li><li class="page_header_menu-item is-login"><a class="button is-light is-small page_hader_menu-button is-login" href="https://www.toptal.com/users/login">Login</a></li><li class="page_header_menu-item is-contacts"><ul class="page_header_menu-contact-items is-replaceable"><li class="page_header_menu-contact-item is-contact">Questions?</li><li class="page_header_menu-contact-item is-contact"><a class="link is-dotted page_header_menu-contact-link" href="https://www.toptal.com/contact">Contact Us</a></li><li class="page_header_menu-contact-item"><a class="page_header_menu-contact-link is-social is-facebook" href="https://www.facebook.com/toptal" target="_blank"><span class="page_header_menu-contact-link-icon"></span></a></li><li class="page_header_menu-contact-item"><a class="page_header_menu-contact-link is-social is-twitter" href="https://twitter.com/toptal" target="_blank"><span class="page_header_menu-contact-link-icon"></span></a></li><li class="page_header_menu-contact-item"><a class="page_header_menu-contact-link is-social is-linkedin" href="https://www.linkedin.com/company/toptal" target="_blank"><span class="page_header_menu-contact-link-icon"></span></a></li></ul></li></ul></div><div class="blog_search" data-view="quick_search#search_field" data-vertical="Designer"><form class="blog_search-form" data-role="form"><input autocomplete="off" class="blog_search-field" data-role="field" name="text" placeholder="Search Topics" type="text" /><button class="button is-tiny blog_search-submit"><span class="blog_search-submit_icon"></span></button></form><div class="blog_search-suggestions" data-role="suggestions_wrapper"></div><div class="blog_search_results" data-role="results" style="display: none;"></div></div><a class="button is-green_candy is-tiny for-page_header_menu page_header_menu-hire" data-role="companies_apply_button" href="https://www.toptal.com/hire?interested_in=designers&amp;skill=ui">Hire a designer</a></div></nav><nav class="blog-simple-header grid-row page_header_menu-wrapper is-fixed" data-role="sticky_menu_wrapper"><div class="grid-row-inner is-wide page_header_menu has-padding"><div class="page_header_top-logotype_wrapper"><div class="page_header_top-logotype"><a class="logo is-big is-link" href="https://www.toptal.com/designers"></a></div><div class="page_header_top-main_title"><b>Hiring?</b> Toptal handpicks <b><a href="https://www.toptal.com/designers/ui" onclick='window.googleAnalytics.trackEvent(event, "BlogCTAs", "ClickedOnHeaderHeadline", "ClickedOnHeaderHeadline")'>top UI designers</a></b> to suit your needs.</div></div><nav class="page_header_top-nav_wrapper"><ul class="page_header_top-nav" data-role="menu"><li class="page_header_top-nav_item"><a class="button is-green_candy is-small page_header_top-nav_link is-button" data-role="companies_apply_button" href="https://www.toptal.com/designers/ui" onclick="window.googleAnalytics.trackEvent(event, &quot;BlogCTAs&quot;, &quot;ClickedOnHeaderCTA&quot;, &quot;ClickedOnHeaderCTA&quot;);">Start hiring</a></li><li class="page_header_top-nav_item"><a class="button is-small is-light page_header_top-nav_link is-button" href="https://www.toptal.com/users/login">Log in</a></li></ul></nav></div></nav></div></header><main class="layout-main"><div class="reading-progress" data-view="content#reading_progress"></div><header class="grid-row has-top_border has-bottom_border post_cover is-post"><div class="grid-row-inner is-wide has-big_padding blog_title for-show"></div></header><article class="grid-row is-transparent"><div class="grid-row-inner is-wide"><div class="post_title"><div class="post_title-header"><p class="post-reading_time" data-view="content#reading_time" data-minutes="7">7 min read</p><h1 class="post_title-text">Take It to the Limit - an Overview of Long Scroll Websites</h1></div><a class="post_title-back" href="https://www.toptal.com/designers/blog">View all articles</a></div></div></article><section class="grid-row has-top_border is-transparent has-no_border" data-view="" id="main_content"><div class="grid-row-inner has-medium_padding two_columns_layout is-wide"><div class="two_columns_layout-content"><div class="post is-full"><div class="post_meta-wrapper post_header"><div class="post_header-triangle"></div><div class="post_avatar post_meta-avatar"><img width="50" class="post_avatar-image" src="https://uploads.toptal.io/avatar/external_author_photo/121813/Cameron-869ebe1c5036a3b2480339378d36fcdf.jpg" /></div><div class="post_meta is-full"><div class="post_meta-author"><p>by <strong>Cameron Chapman</strong> - Design Blog Editor
@ <a class="link is-blue" target="_blank" href="https://www.toptal.com/">Toptal</a>
</p>
</div><div class="post_meta-tags"><a href="https://www.toptal.com/designers/blog/tags/interactiondesign">#InteractionDesign</a> <a href="https://www.toptal.com/designers/blog/tags/uidesign">#UIDesign</a> <a href="https://www.toptal.com/designers/blog/tags/uxdesign">#UXDesign</a></div></div><ul class="social_share is-horizontal is-small is-centered_on_mobile for-blog_post_heading" data-hashtags="UXDesign,UIDesign,InteractionDesign" data-url="https://www.toptal.com/designers/ui/long-scroll-websites" data-view="layout#social_share" data-youtube-channel-url="https://www.youtube.com/channel/UCNqm_euTHZz3o5OnKhUS-oA"><li class="social_share-item is-counter" title="Total number of shares"><span class="social_share-item_num" data-role="counter_num">0</span><span class="social_share-item_text" data-role="counter_text">shares</span></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;twitter&quot;}" data-type="twitter" title="Share on Twitter"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/twitter_83c6d4.png" width="50" /></a></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;facebook&quot;}" data-type="facebook" title="Share on Facebook"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/facebook_dc66c9.png" width="50" /></a></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;linkedin&quot;}" data-type="linkedin" title="Share on LinkedIn"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/linkedin_b923c3.png" width="50" /></a></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;pocket&quot;}" data-type="pocket" title="Save to Pocket"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/pocket_e4260c.png" width="50" /></a></li></ul><div class="post_meta-extra"></div></div><div class="content_body" data-insert-middle-content="true" data-view="content#body"><p>Long scroll, or infinite scroll, websites are exactly that: the pages are much longer than the “average” website page and therefore scroll “infinitely.” These types of sites have become popular with social media sites and sites like Pinterest that include a lot of user-generated content, as well as some news and blog sites—personal websites and portfolios are also beginning to employ long scroll techniques in order to increase user engagement and the length of time people spend on a site.</p>

<p>Infinite scroll has become a popular and common design pattern, nevertheless, there are some potential pitfalls <a href="https://www.toptal.com/designers/ui">UI designers</a> should be aware of when designing a site that uses long scrolling. There are also some types of sites where it isn’t appropriate to employ a long scrolling design pattern.</p>

<h2 id="the-purpose-and-benefits-of-long-scroll">The Purpose and Benefits of Long Scroll</h2>

<p>One of the biggest benefits of long scroll websites is that they keep visitors on a site longer. When people don’t have to make a conscious decision to consume more content, they’re less likely to click away.</p>

<p>Think of this as being similar to the way Facebook, YouTube, Netflix, and similar sites autoplay videos when the one a user is viewing finishes. They know that if a visitor has to make an effort to click to a new video, they’re just as likely to click to a different site entirely. But if videos keep playing, it’s more likely they will continue watching.</p>

<p>When long scroll sites are properly coded, they load a new URL with each new piece of content. That equals more page views for the site, which can increase advertising revenue and the site’s overall value.</p>

<p><img src="https://uploads.toptal.io/blog/image/129115/toptal-blog-image-1549997512620-72eaff97494e5c220c505505fdfa11fb.jpg" alt="Long scroll is popular on news sites, which load more content as the user scrolls." /></p>

<div class="pop_out_box is-full_width" style="font-size:1em; text-align: center"><a href="https://mashable.com/">Mashable's</a> home page auto-loads more content as the user scrolls, keeping them on the page for longer.</div>

<p>As with any UX decision, it’s important to weigh the advantages and disadvantages to the people who will actually be using the site before deciding on a format. Long scroll can be a great option for certain types of sites, while in other situations all it does is frustrate users. It’s important to learn the difference between the two.</p>

<h2 id="when-to-use-long-scroll-and-when-not-to">When to Use Long Scroll (and When Not To)</h2>

<p>The key thing to remember when considering long scroll is that the content should dictate the format no matter what kind of site is being designed. Long scroll websites are great for certain types of content but can present a huge UX failure with other types.</p>

<p>On the whole, task and goal-oriented sites don’t benefit from infinite scroll designs (eg. e-commerce sites and tutorial or other educational sites where users want to see definite progress). These types of sites need to give users a sense of completion and accomplishment, which is harder to achieve with long scrolling sites.</p>

<p>Etsy, for example, tried an infinite scroll design in 2012 and ended up <a href="https://www.slideshare.net/danmckinley/design-for-continuous-experimentation">switching back to pagination</a>. They found that while customers still purchased at roughly the same rate, user engagement went way down. Even things like the number of searches performed dropped.</p>

<p><img src="https://uploads.toptal.io/blog/image/129116/toptal-blog-image-1549997575061-73f780b54cf93c273366c743750e584d.png" alt="Etsy stepped away from a long scroll website and returned to pagination." /></p>

<div class="pop_out_box is-full_width" style="font-size:1em; text-align: center">Etsy ended up ditching the long scroll in favor of returning to paginated search results after running tests.</div>

<p>One option some e-commerce sites give to visitors is the “View All” option when looking at product pages. This gives the user the option to view the site in an infinite scroll format if they choose to do so while preserving the shorter results pages for users who prefer that format.</p>

<p>Pagination is also helpful when it’s important for people to view information in chronological order. Where a one-page scrolling website might encourage people to skim and skip ahead, pagination slows the visitor down and increases the likelihood of them consuming information in the proper order.</p>

<p>Where a single page scrolling website can really shine is on sites where reading additional content or articles is the natural flow. This applies to things like news sites or topical blogs. Users on these sites often want to take in large amounts of information at once, and infinite scroll makes it way easier.</p>

<p>Another obvious area where infinite scroll is a popular UX choice is social media sites or sites with a lot of user-generated content. Facebook, Pinterest, and Twitter all use infinite scroll. These sites want to keep users on the site for as long as possible, and infinite scroll does that well.</p>

<h3 id="psychological-costs-of-long-scroll">Psychological Costs of Long Scroll</h3>

<p>The <a href="https://www.toptal.com/designers/ux/design-psychology-neuroscience-of-ux">psychological effects</a> of any design decision should always be considered carefully. When it comes to single page scrolling websites, there are psychological effects for, as well as against it.</p>

<p>The first thing to consider is that users don’t mind purposeful clicking. Clicking has been part of computing, graphical user interfaces, and the internet virtually since its inception. People are used to that particular type of interaction and aren’t going to be turned off if they have to click a few links to get to more content.</p>

<p>A lot of users <a href="https://www.nngroup.com/articles/infinite-scrolling/">dislike infinite scroll</a> by default. Being faced with an extremely long page to scroll can feel a bit like drowning in a never-ending sea of information. When users are looking for specific information, scrolling is rarely the most efficient way to find it.</p>

<p>Since it won’t accurately display the page length, infinite scroll breaks the scroll bar on the side of the page. While not every user makes use of the scroll bar, in this respect, those that do may find infinite scroll frustrating.</p>

<p>Infinite scroll also removes the sense of completion users gain from finishing a task or reaching a goal on one page and then clicking to the next page. Losing this sense of completion can discourage users and cause them to seek other sources for the same information or task.</p>

<p>Another negative psychological impact long scrolling websites can have is that users tend to view content that’s further down the page as less important than the content at the top. Using headers can help with this, as it sort of “resets” the visitor’s brain about where the “top” is.</p>

<h2 id="long-scroll-website-best-practices">Long Scroll Website Best Practices</h2>

<p>If it has been determined that a website project is suitable for a long scroll design, there are some best practices to keep in mind in order to make sure it offers an optimal user experience.</p>

<p>First up, ditch the footer! When content continuously loads, the footer will continuously be pushed off the bottom of the page. That means any content or information contained in the footer will remain out of sight. Worse still is when users catch a glimpse of the footer but lose sight of it before they have a chance to click on anything. Using a sticky footer is one way around this, although getting rid of the footer entirely is often a better option.</p>

<p><img src="https://uploads.toptal.io/blog/image/129117/toptal-blog-image-1549997600326-c8698b2e149a4770b61e3ba915af307c.jpg" alt="A great way to break long scroll UX: Put important information in the footer." /></p>

<div class="pop_out_box is-full_width" style="font-size:1em; text-align: center">Barbican never allows you to see all the valuable information in their footer, because as soon as you get to it, more content loads, pushing it off the screen.</div>

<p>Using visual cues is important, especially if it isn’t immediately obvious when the main screen loads that there’s more content on the page. Sites that have a large header image or visual content that fills the screen when the page loads, often include an arrow (sometimes animated) or similar imagery to indicate that there is more content below.</p>

<p><img src="https://uploads.toptal.io/blog/image/129118/toptal-blog-image-1549997622266-941a3d7114c93adf912a7192b05d2d6e.jpg" alt="Visual cues are important for one page scrolling websites" /></p>

<div class="pop_out_box is-full_width" style="font-size:1em; text-align: center">Dynamit includes a small arrow at the bottom of the home screen to indicate to visitors that they should scroll.</div>

<p>Navigation should be consistently visible, either by using a sticky header or a stationary <a href="https://trends.uxdesign.cc/2019">sidebar with navigation links</a>. The exception to this is on mobile devices, where sticky headers can take up valuable screen real estate. Facebook handles this well by having the header disappear when users scroll down, but then reappear when they start scrolling back up.</p>

<p>The Chrome web browser does something similar with their controls at the bottom of the screen; they disappear when the user is scrolling down, and reappear when they start scrolling back up. It’s a very intuitive way to create an interface that maximizes available screen real estate.</p>

<p>One vital UX feature that has thankfully become more common in infinite scrolling websites is changing the URL as each section is scrolled to. Some do this with internal bookmarks within the page. Other sites, particularly news sites and blogs, update the entire URL when the user scrolls. This is important, as it allows users to link to exactly the content they want to link to, regardless of changes to the page itself.</p>

<p>Some <a href="https://www.toptal.com/designers/web">web designers</a> opt to create what could be considered a “hybrid” long scrolling site, with a “load more” button that loads content directly onto the same page. Some <a href="https://www.toptal.com/designers/ui">UI designers</a> use this repeatedly on the page, while others opt to include it only once, and after that turn the site into a more traditional long scrolling format.</p>

<p>Besides these long scroll website-specific design considerations, other UI and UX best practices for creating good designs still apply to sites that employ infinite scroll.</p>

<h2 id="examples-of-long-scroll-done-right">Examples of Long Scroll Done Right</h2>

<p><img src="https://uploads.toptal.io/blog/image/129119/toptal-blog-image-1549997634217-831e103fbf439be0e75ecec054a8cafb.jpg" alt="A website scroll animation enhances user experience." /></p>

<div class="pop_out_box is-full_width" style="font-size:1em; text-align: center">The Story of Zohra site uses visual cues when you start to scroll.</div>

<p><img src="https://uploads.toptal.io/blog/image/129120/toptal-blog-image-1549997644076-fa465b50063f1c1e161e8d1e34cbcb61.jpg" alt="Portfolios are a good opportunity for a one-page scrolling website." /></p>

<div class="pop_out_box is-full_width" style="font-size:1em; text-align: center">The Merbis Photography &amp; Filmmaking site is a great example of a portfolio site that uses infinite scroll.</div>

<p><img src="https://uploads.toptal.io/blog/image/129121/toptal-blog-image-1549997655431-376f9d36aa96a839227fa1eefa164c27.jpg" alt="A single page scrolling website." /></p>

<div class="pop_out_box is-full_width" style="font-size:1em; text-align: center">The Windows of New York site loads all of the content right on the home page.</div>

<p><img src="https://uploads.toptal.io/blog/image/129122/toptal-blog-image-1549997664257-30cff3ef519a9190a5e05a35084a4453.jpg" alt="Parallax scrolling website techniques are often combined with long scroll." /></p>

<div class="pop_out_box is-full_width" style="font-size:1em; text-align: center">The Like There is No Tomorrow site combines long scroll with parallax scrolling techniques.</div>

<p><img src="https://uploads.toptal.io/blog/image/129123/toptal-blog-image-1549997673822-5809f580d1a32f3375a95a96338f5e78.jpg" alt="A subtle website scroll animation increases user delight." /></p>

<div class="pop_out_box is-full_width" style="font-size:1em; text-align: center">The Faces of New York Fashion Week website—a long feed of photos from the event—is a perfect candidate for the long scroll format.</div>

<p><img src="https://uploads.toptal.io/blog/image/129124/toptal-blog-image-1549997685512-52e8634a5da1dbc7b391f92635744c48.jpg" alt="An example of a unique infinite scroll website." /></p>

<div class="pop_out_box is-full_width" style="font-size:1em; text-align: center">John Ball's website takes a slightly different approach: the background images infinitely scroll while the text content stays stationary. </div>

<p><img src="https://uploads.toptal.io/blog/image/129125/toptal-blog-image-1549997694994-acea1c9fcd99eeba3cc042ebae292c98.jpg" alt="Links to each letter on the right enhance UX on this one page scrolling website" /></p>

<div class="pop_out_box is-full_width" style="font-size:1em; text-align: center">The Fake It Digital website uses long scroll to display their humorous alternative definitions of common business, design, and marketing terms.</div>

<p>Then there’s this site, from <a href="http://andrevv.com/">Andrew McCarthy</a>. While the design is unique, it infinitely scrolls with the same information over and over again. Since McCarthy is a designer, it’s likely a deliberate choice in order to stand out from the crowd.</p>

<p><img src="https://uploads.toptal.io/blog/image/129126/toptal-blog-image-1549997705483-cd1594825dea01ec0b025606b824b0ac.jpg" alt="Designers often have fun with long scroll formats." /></p>

<p>And another example from <a href="http://sammyrosen.com">Sam Rosen</a>, who also keeps repeating the same content over and over again, although this site loops back to the top rather than re-loading all the content.</p>

<p><img src="https://uploads.toptal.io/blog/image/129127/toptal-blog-image-1549997714681-7929c18429fdfa07ab89f0617b97435f.jpg" alt="Infinity scroll techniques can vary widely between sites." /></p>

<h2 id="conclusion">Conclusion</h2>

<p>While long scroll websites are nothing new, they’re reaching a new level of maturity. Designers are no longer employing them as just the next “big” thing, and are instead paying attention to how the pattern impacts user experience.</p>

<p>Following best practices when creating infinite scrolling websites allows designers to create a UX that delights users rather than frustrates them. Concurrently, properly implemented long scroll websites can also help brands achieve their website goals.</p>

<h3 id="further-reading-on-the-toptal-design-blog">Further reading on the Toptal Design Blog:</h3>

<ul>
  <li><a href="https://www.toptal.com/designers/ux/persuasive-design-using-psychology">Persuasive Design: Using Advanced Psychology Effectively</a></li>
  <li><a href="https://www.toptal.com/designers/ux/design-psychology-neuroscience-of-ux">Design Psychology and the Neuroscience of Awesome UX</a></li>
  <li><a href="https://www.toptal.com/designers/ux/the-ultimate-ux-guide">Experience Is Everything – The Ultimate UX Guide</a></li>
  <li><a href="https://www.toptal.com/designers/user-experience/anticipatory-persuasive-emotional-design-ux">The Ultimate UX Hook – Anticipatory, Persuasive, and Emotional Design in UX</a></li>
  <li><a href="https://www.toptal.com/designers/ux/laws-of-ux-infographic">The Tried and True Laws of UX (with Infographic)</a></li>
</ul>
<div class="post_key_learnings for-post"><h2 class="post_key_learnings-heading" data-disable_middle_content_placement="true">Understanding the Basics</h2><div class="post_key_learnings-item" data-animation-speed="450" data-hide-button="false" data-initial-state="expanded" data-view="ui#expander"><span class="post_key_learnings-item_arrow is-expanded" data-role="button"></span><h3 class="post_key_learnings-title is-expanded" data-disable_middle_content_placement="true" data-role="button">What is web scrolling?</h3><p class="post_key_learnings-body" data-role="content">Web scrolling is often used to refer to either parallax scroll or infinite scroll techniques being employed on a website. With infinite scroll, content continues to load on a single page as the user scrolls down, keeping them on the page longer and getting rid of the need for users to click to the next page.</p></div><div class="post_key_learnings-item" data-animation-speed="450" data-hide-button="false" data-initial-state="collapsed" data-view="ui#expander"><span class="post_key_learnings-item_arrow is-collapsed" data-role="button"></span><h3 class="post_key_learnings-title is-collapsed" data-disable_middle_content_placement="true" data-role="button">What are scrolling pages?</h3><p class="post_key_learnings-body is-hidden" data-role="content">Scrolling pages, more commonly referred to as long scrolling or infinite scrolling pages, are web pages that continue to load new content as the user scrolls down the page. This eliminates the need for the user to actively click to see more content, potentially keeping them on the site for longer.</p></div><div class="post_key_learnings-item" data-animation-speed="450" data-hide-button="false" data-initial-state="collapsed" data-view="ui#expander"><span class="post_key_learnings-item_arrow is-collapsed" data-role="button"></span><h3 class="post_key_learnings-title is-collapsed" data-disable_middle_content_placement="true" data-role="button">What is a one-page website called?</h3><p class="post_key_learnings-body is-hidden" data-role="content">There are a variety of types of one-page websites, but one of the most commonly seen is the infinite scrolling website. These types of sites continuously load more content as the user scrolls, rather than separating content onto different pages.</p></div><div class="post_key_learnings-item" data-animation-speed="450" data-hide-button="false" data-initial-state="collapsed" data-view="ui#expander"><span class="post_key_learnings-item_arrow is-collapsed" data-role="button"></span><h3 class="post_key_learnings-title is-collapsed" data-disable_middle_content_placement="true" data-role="button">What is a multi-page website?</h3><p class="post_key_learnings-body is-hidden" data-role="content">Unlike long scroll websites, which load new content as the user scrolls, multi-page sites separate content onto different pages. Multi-page websites are better suited for specific types of sites, like those that are task- or goal-oriented.</p></div></div><div class="post-join"><a class="button is-white_and_green is-default is-full_width" href="https://www.toptal.com/designers/ui">Hiring? Meet the Top 10 Freelance UI Designers for Hire in February 2019</a></div><div class="template" data-role="middle_content_template" data-template="{&quot;html&quot;:&quot;\u003cdiv class=\&quot;embeddable_form-wrapper for-post\&quot; data-role=\&quot;blog_subscribe\&quot; data-view=\&quot;blog_subscribe#form\&quot;\u003e\u003cform action=\&quot;/blog/subscription\&quot; class=\&quot;embeddable_form\&quot; data-entity=\&quot;blog_subscription\&quot; data-remote=\&quot;\&quot; data-view=\&quot;form#form\&quot; method=\&quot;post\&quot;\u003e\u003cdiv class=\&quot;embeddable_form-step is-email_form is-current\&quot;\u003e\u003cdiv class=\&quot;embeddable_form-row is-label\&quot;\u003e\u003cdiv class=\&quot;embeddable_form-label_title\&quot;\u003eLike what you\u0026#39;re reading?\u003c/div\u003e\u003cdiv class=\&quot;embeddable_form-label\&quot;\u003eGet the latest updates first.\u003c/div\u003e\u003c/div\u003e\u003cdiv class=\&quot;embeddable_form-row form-field is-email_field\&quot;\u003e\u003cinput autocomplete=\&quot;off\&quot; class=\&quot;input is-medium\&quot; data-role=\&quot;email\&quot; name=\&quot;blog_subscription[email]\&quot; placeholder=\&quot;Enter your email address...\&quot; type=\&quot;text\&quot; /\u003e\u003cinput name=\&quot;blog_subscription[vertical]\&quot; type=\&quot;hidden\&quot; value=\&quot;designers\&quot; /\u003e\u003cinput name=\&quot;from_widget\&quot; type=\&quot;hidden\&quot; value=\&quot;true\&quot; /\u003e\u003c/div\u003e\u003cdiv class=\&quot;embeddable_form-row is-submit\&quot;\u003e\u003cinput class=\&quot;button is-green_candy is-default is-full_width\&quot; data-loader-text=\&quot;Subscribing...\&quot; data-role=\&quot;submit\&quot; type=\&quot;submit\&quot; value=\&quot;Get Exclusive Updates\&quot; /\u003e\u003c/div\u003e\u003cdiv class=\&quot;embeddable_form-row is-privacy\&quot;\u003e\u003cdiv class=\&quot;embeddable_form-privacy\&quot;\u003e\u003cdiv class=\&quot;embeddable_form-privacy_icon\&quot;\u003e\u003c/div\u003e\u003cdiv class=\&quot;embeddable_form-privacy_text\&quot;\u003eNo spam. Just great articles \u0026amp; insights.\u003c/div\u003e\u003c/div\u003e\u003c/div\u003e\u003c/div\u003e\u003cdiv class=\&quot;embeddable_form-step is-confirmation\&quot; data-place=\&quot;@blog_subscribe\&quot; data-role=\&quot;confirmation\&quot;\u003e\u003cdiv class=\&quot;embeddable_form-row is-label is-success\&quot;\u003e\u003cdiv class=\&quot;embeddable_form-label_title\&quot;\u003eLike what you\u0026#39;re reading?\u003c/div\u003e\u003cdiv class=\&quot;embeddable_form-label\&quot;\u003eGet the latest updates first.\u003c/div\u003e\u003c/div\u003e\u003cdiv class=\&quot;embeddable_form-row is-success\&quot;\u003e\u003cdiv class=\&quot;embeddable_form-label is-header\&quot;\u003eThank you for subscribing!\u003c/div\u003e\u003cdiv class=\&quot;embeddable_form-label\&quot;\u003eCheck your inbox to confirm subscription. You&#39;ll start receiving posts after you confirm.\u003c/div\u003e\u003c/div\u003e\u003cdiv class=\&quot;embeddable_form-row is-success\&quot;\u003e\u003cul class=\&quot;social_share is-horizontal\&quot; data-url=\&quot;https://www.toptal.com/designers/blog\&quot; data-view=\&quot;layout#social_share\&quot; data-youtube-channel-url=\&quot;https://www.youtube.com/channel/UCNqm_euTHZz3o5OnKhUS-oA\&quot;\u003e\u003cli class=\&quot;social_share-item is-counter\&quot; title=\&quot;Total number of shares\&quot;\u003e\u003cspan class=\&quot;social_share-item_num\&quot; data-role=\&quot;counter_num\&quot;\u003e0\u003c/span\u003e\u003cspan class=\&quot;social_share-item_text\&quot; data-role=\&quot;counter_text\&quot;\u003eshares\u003c/span\u003e\u003c/li\u003e\u003cli class=\&quot;social_share-item\&quot;\u003e\u003ca class=\&quot;social_share-item_link\&quot; data-role=\&quot;link\&quot; data-track-click=\&quot;SocialShareButtonClicked\&quot; data-track-default-data=\&quot;{\u0026quot;network\u0026quot;:\u0026quot;twitter\u0026quot;}\&quot; data-type=\&quot;twitter\&quot; title=\&quot;Share on Twitter\&quot;\u003e\u003cimg class=\&quot;social_share-item_image\&quot; height=\&quot;50\&quot; src=\&quot;https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/twitter_83c6d4.png\&quot; width=\&quot;50\&quot; /\u003e\u003c/a\u003e\u003c/li\u003e\u003cli class=\&quot;social_share-item\&quot;\u003e\u003ca class=\&quot;social_share-item_link\&quot; data-role=\&quot;link\&quot; data-track-click=\&quot;SocialShareButtonClicked\&quot; data-track-default-data=\&quot;{\u0026quot;network\u0026quot;:\u0026quot;facebook\u0026quot;}\&quot; data-type=\&quot;facebook\&quot; title=\&quot;Share on Facebook\&quot;\u003e\u003cimg class=\&quot;social_share-item_image\&quot; height=\&quot;50\&quot; src=\&quot;https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/facebook_dc66c9.png\&quot; width=\&quot;50\&quot; /\u003e\u003c/a\u003e\u003c/li\u003e\u003c/ul\u003e\u003c/div\u003e\u003c/div\u003e\u003c/form\u003e\u003c/div\u003e&quot;}"></div></div><div class="embeddable_form-wrapper for-post for-external_author" data-role="blog_subscribe" data-view="blog_subscribe#form"><form action="/blog/subscription" class="embeddable_form" data-entity="blog_subscription" data-remote="" data-view="form#form" method="post"><div class="embeddable_form-step is-email_form is-current"><div class="embeddable_form-row is-label"><div class="embeddable_form-label_title">Don&#39;t miss out.</div><div class="embeddable_form-label">Get the latest updates first.</div></div><div class="embeddable_form-row form-field is-email_field"><input autocomplete="off" class="input is-medium" data-role="email" name="blog_subscription[email]" placeholder="Enter your email address..." type="text" /><input name="blog_subscription[vertical]" type="hidden" value="designers" /><input name="from_widget" type="hidden" value="true" /></div><div class="embeddable_form-row is-submit"><input class="button is-green_candy is-default is-full_width" data-loader-text="Subscribing..." data-role="submit" type="submit" value="Get Exclusive Updates" /></div><div class="embeddable_form-row is-privacy"><div class="embeddable_form-privacy"><div class="embeddable_form-privacy_icon"></div><div class="embeddable_form-privacy_text">No spam. Just great articles &amp; insights.</div></div></div></div><div class="embeddable_form-step is-confirmation" data-place="@blog_subscribe" data-role="confirmation"><div class="embeddable_form-row is-label is-success"><div class="embeddable_form-label_title">Don&#39;t miss out.</div><div class="embeddable_form-label">Get the latest updates first.</div></div><div class="embeddable_form-row is-success"><div class="embeddable_form-label is-header">Thank you for subscribing!</div><div class="embeddable_form-label">Check your inbox to confirm subscription. You'll start receiving posts after you confirm.</div></div><div class="embeddable_form-row is-success"><ul class="social_share is-horizontal" data-url="https://www.toptal.com/designers/blog" data-view="layout#social_share" data-youtube-channel-url="https://www.youtube.com/channel/UCNqm_euTHZz3o5OnKhUS-oA"><li class="social_share-item is-counter" title="Total number of shares"><span class="social_share-item_num" data-role="counter_num">0</span><span class="social_share-item_text" data-role="counter_text">shares</span></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;twitter&quot;}" data-type="twitter" title="Share on Twitter"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/twitter_83c6d4.png" width="50" /></a></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;facebook&quot;}" data-type="facebook" title="Share on Facebook"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/facebook_dc66c9.png" width="50" /></a></li></ul></div></div></form></div><div class="blog-comments"><div id="disqus_thread_container"><div id="disqus_thread"><div class="d-noscript-comments"><h3>Comments</h3></div></div></div><script>function isIos() {
  return /(iPad|iPhone|iPod)/g.test(navigator.userAgent);
}

function adjustHeightInIos() {
  if (isIos()) {
    var height = $('#disqus_thread').outerHeight();
    $('#disqus_thread_container').height(height);
  }
}

if (isIos()) {
  var el = document.getElementById('disqus_thread_container');
  el.style.height = '1px';
  el.style.overflow = 'hidden';
  el.style.width = '100%';
}

function disqus_config() {
  this.callbacks.onNewComment = [function() {
    $.post('/blog/comments/on_create');
    adjustHeightInIos();
  }];

  this.callbacks.onReady = [adjustHeightInIos];
}

var disqus_shortname = 'toptal';
var disqus_identifier = 'ui/long-scroll-websites';

(function() {
  var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
  dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
  (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
})();</script><noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript><a class="dsq-brlink" href="https://disqus.com">comments powered by <span class="logo-disqus">Disqus</span></a></div></div></div><div class="two_columns_layout-extra"><div class="blog-block-wrapper"><div class="blog-block-header">Subscribe</div><div class="blog-block"><div class="blog-block-row"><div class="embeddable_form-wrapper is-horizontal" data-role="blog_subscribe" data-view="blog_subscribe#form"><form action="/blog/subscription" class="embeddable_form" data-entity="blog_subscription" data-remote="" data-view="form#form" method="post"><div class="embeddable_form-step is-email_form is-current"><div class="embeddable_form-row is-label"><div class="embeddable_form-label_title">Free email updates</div><div class="embeddable_form-label">Get the latest content first.</div></div><div class="embeddable_form-row form-field is-email_field"><input autocomplete="off" class="input is-medium" data-role="email" name="blog_subscription[email]" placeholder="Enter your email address..." type="text" /><input name="blog_subscription[vertical]" type="hidden" value="designers" /><input name="from_widget" type="hidden" value="true" /></div><div class="embeddable_form-row is-submit"><input class="button is-green_candy is-default is-full_width" data-loader-text="Subscribing..." data-role="submit" type="submit" value="Get Exclusive Updates" /></div><div class="embeddable_form-row is-privacy"><div class="embeddable_form-privacy"><div class="embeddable_form-privacy_icon"></div><div class="embeddable_form-privacy_text">No spam. Just great articles &amp; insights.</div></div></div></div><div class="embeddable_form-step is-confirmation" data-place="@blog_subscribe" data-role="confirmation"><div class="embeddable_form-row is-label is-success"><div class="embeddable_form-label_title">Free email updates</div><div class="embeddable_form-label">Get the latest content first.</div></div><div class="embeddable_form-row is-success"><div class="embeddable_form-label is-header">Thank you for subscribing!</div><div class="embeddable_form-label">Check your inbox to confirm subscription. You'll start receiving posts after you confirm.</div></div><div class="embeddable_form-row is-success"><ul class="social_share is-horizontal" data-url="https://www.toptal.com/designers/blog" data-view="layout#social_share" data-youtube-channel-url="https://www.youtube.com/channel/UCNqm_euTHZz3o5OnKhUS-oA"><li class="social_share-item is-counter" title="Total number of shares"><span class="social_share-item_num" data-role="counter_num">0</span><span class="social_share-item_text" data-role="counter_text">shares</span></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;twitter&quot;}" data-type="twitter" title="Share on Twitter"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/twitter_83c6d4.png" width="50" /></a></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;facebook&quot;}" data-type="facebook" title="Share on Facebook"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/facebook_dc66c9.png" width="50" /></a></li></ul></div></div></form></div></div></div><div class="blog-block-header">Trending articles</div><div class="blog-block"><nav class="blog-trending"><a class="post is-preview blog-trending-item" href="/designers/ui/long-scroll-websites"><span class="post_cover is-preview"><noscript><img class="post_cover-image" src="https://uploads.toptal.io/blog/cover_image/121813/side_list_cover-image_0-882be8425f238ee90ef671ec5149cfd0.png" /></noscript><span class="post_cover-image" data-role="deferred" data-src="https://uploads.toptal.io/blog/cover_image/121813/side_list_cover-image_0-882be8425f238ee90ef671ec5149cfd0.png"></span></span><span class="post-preview"><span class="post-title">Take It to the Limit - an Overview of Long Scroll Websites</span><span class="post_meta"><span class="post_meta-date">about 23 hours ago</span></span></span></a><a class="post is-preview blog-trending-item" href="/designers/ui/atomic-design-sketch"><span class="post_cover is-preview"><noscript><img class="post_cover-image" src="https://uploads.toptal.io/blog/cover_image/121811/side_list_cover-image_0-0044317d081fb4da880e80842ed11105.png" /></noscript><span class="post_cover-image" data-role="deferred" data-src="https://uploads.toptal.io/blog/cover_image/121811/side_list_cover-image_0-0044317d081fb4da880e80842ed11105.png"></span></span><span class="post-preview"><span class="post-title">Atomic Design and Sketch - a Guide to Improving Workflow</span><span class="post_meta"><span class="post_meta-date">3 days ago</span></span></span></a><a class="post is-preview blog-trending-item" href="/designers/ux/importance-of-design-education"><span class="post_cover is-preview"><noscript><img class="post_cover-image" src="https://uploads.toptal.io/blog/cover_image/121806/side_list_cover-image_0-2dfef87f3b2d54798f2fdd6b69066d61.png" /></noscript><span class="post_cover-image" data-role="deferred" data-src="https://uploads.toptal.io/blog/cover_image/121806/side_list_cover-image_0-2dfef87f3b2d54798f2fdd6b69066d61.png"></span></span><span class="post-preview"><span class="post-title">The Importance of Design Education</span><span class="post_meta"><span class="post_meta-date">8 days ago</span></span></span></a><a class="post is-preview blog-trending-item" href="/designers/ux/design-education"><span class="post_cover is-preview"><noscript><img class="post_cover-image" src="https://uploads.toptal.io/blog/cover_image/121805/side_list_cover-image_0-73ccf9d611af1bf6041fbdf808249c72.png" /></noscript><span class="post_cover-image" data-role="deferred" data-src="https://uploads.toptal.io/blog/cover_image/121805/side_list_cover-image_0-73ccf9d611af1bf6041fbdf808249c72.png"></span></span><span class="post-preview"><span class="post-title">Why You Don’t Need Design Education</span><span class="post_meta"><span class="post_meta-date">10 days ago</span></span></span></a><a class="post is-preview blog-trending-item" href="/designers/ux/empty-state-ux-design"><span class="post_cover is-preview"><noscript><img class="post_cover-image" src="https://uploads.toptal.io/blog/cover_image/120799/side_list_cover-image_0-c91589fe913a4fabd238ba1066744810.png" /></noscript><span class="post_cover-image" data-role="deferred" data-src="https://uploads.toptal.io/blog/cover_image/120799/side_list_cover-image_0-c91589fe913a4fabd238ba1066744810.png"></span></span><span class="post-preview"><span class="post-title">Empty States – The Most Overlooked Aspect of UX</span><span class="post_meta"><span class="post_meta-date">15 days ago</span></span></span></a><a class="post is-preview blog-trending-item" href="/designers/ux/ux-trends-2018"><span class="post_cover is-preview"><noscript><img class="post_cover-image" src="https://uploads.toptal.io/blog/cover_image/120798/side_list_cover-img00-f83bb2e51ef2c5725953929b7c4d85fb.png" /></noscript><span class="post_cover-image" data-role="deferred" data-src="https://uploads.toptal.io/blog/cover_image/120798/side_list_cover-img00-f83bb2e51ef2c5725953929b7c4d85fb.png"></span></span><span class="post-preview"><span class="post-title">UX Trends 2018: A Retrospective</span><span class="post_meta"><span class="post_meta-date">17 days ago</span></span></span></a><a class="post is-preview blog-trending-item" href="/designers/ui/minimal-web-design"><span class="post_cover is-preview"><noscript><img class="post_cover-image" src="https://uploads.toptal.io/blog/cover_image/120795/side_list_cover-image_0-21d9e3d75dfd8cc4381a0a767c5b60b5.png" /></noscript><span class="post_cover-image" data-role="deferred" data-src="https://uploads.toptal.io/blog/cover_image/120795/side_list_cover-image_0-21d9e3d75dfd8cc4381a0a767c5b60b5.png"></span></span><span class="post-preview"><span class="post-title">Simplicity is Key - Exploring Minimal Web Design</span><span class="post_meta"><span class="post_meta-date">22 days ago</span></span></span></a><a class="post is-preview blog-trending-item" href="/designers/visual/color-theory-for-designers"><span class="post_cover is-preview"><noscript><img class="post_cover-image" src="https://uploads.toptal.io/blog/cover_image/120794/side_list_cover-image_0-ad1ab0ba7688059b4bf86486382ca386.png" /></noscript><span class="post_cover-image" data-role="deferred" data-src="https://uploads.toptal.io/blog/cover_image/120794/side_list_cover-image_0-ad1ab0ba7688059b4bf86486382ca386.png"></span></span><span class="post-preview"><span class="post-title">Color Theory for Designers – A Crash Course (with Infographic)</span><span class="post_meta"><span class="post_meta-date">24 days ago</span></span></span></a></nav></div><div class="blog-block-header">Relevant Technologies</div><div class="blog-block"><div class="blog-block-row"><ul class="blog-relevant"><li class="blog-relevant-item"><a class="link is-blue" href="https://www.toptal.com/designers/ui">UI</a></li><li class="blog-relevant-item"><a class="link is-blue" href="https://www.toptal.com/designers/ux">UX</a></li><li class="blog-relevant-item"><a class="link is-blue" href="https://www.toptal.com/designers/web">Web</a></li></ul></div></div></div></div></div></section></main><footer class="hide_in_webview"><section class="grid-row has-solid_blue_bg page_footer_map-wrapper"><div class="grid-row-inner has-huge_padding page_footer_map"><div class="page_footer_map-content">Toptal connects the&nbsp;<a href="https://www.toptal.com/top-3-percent">top&nbsp;3%</a> of&nbsp;freelance talent all over&nbsp;the&nbsp;world.</div></div></section><section class="grid-row page_footer_sample_profile-wrapper"><div class="grid-row-inner has-big_padding"><h2 class="header is-row">Toptal Designers</h2><div class="skills_list"><ul class="multi_column_list qa-skills_list"><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/creative-direction">Creative Directors</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/freelance">Freelance Designers</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/graphic">Graphic Designers</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/illustration">Illustrators</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/logo">Logo Designers</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/mobile">Mobile App Designers</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/product-design">Product Designers</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/ui">UI Designers</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/ux">UX Designers</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/visual">Visual Designers</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/web">Web Designers</a></li></ul><div class="skills_list-see_all_wrapper"><a class="button is-tiny is-white is-uppercased" href="https://www.toptal.com/designers"><div class="skills_list-see_all_icon for-designers"></div>See more freelance designers</a></div></div></div></section><div class="skills_enterprise_link"><a class="skills_enterprise_link-url" href="/enterprise">Learn how enterprises benefit from Toptal experts.</a></div><section class="grid-row has-top_border page_footer_join-wrapper" id=""><div class="grid-row-inner has-padding page_footer_join"><h2 class="page_footer_join-header">Join the Toptal community.</h2><div class="page_footer_join-spacer"></div><nav class="page_footer_join-actions"><div class="page_footer_join-item"><a class="button is-green_candy is-big is-fixed page_footer_join-button" href="https://www.toptal.com/hire?interested_in=designers&amp;skill=ui">Hire a designer</a></div><div class="page_footer_join-item is-or">or</div><div class="page_footer_join-item"><a class="button is-green_candy is-big is-fixed page_footer_join-button" href="https://www.toptal.com/designers/join">Apply as a Designer</a></div></nav></div></section><section class="grid-row page_footer_links-wrapper"><div class="grid-row-inner is-wide has-big_padding"><nav class="page_footer_links"><section class="page_footer_links-column is-1"><h3 class="page_footer_links-column_header">Highest In-Demand Talent</h3><ul class="page_footer_links-list"><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/ios">iOS Developers</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/front-end">Front-End Developers</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/designers/ux">UX Designers</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/designers/ui">UI Designers</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/finance/financial-modeling">Financial Modeling Consultants</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/finance/interim-cfos">Interim CFOs</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/project-managers/digital">Digital Project Managers</a></li></ul></section><section class="page_footer_links-column is-2"><h3 class="page_footer_links-column_header">About</h3><ul class="page_footer_links-list"><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/top-3-percent">Top 3%</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/clients">Clients</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/developers">Freelance Developers</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/designers">Freelance Designers</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/finance">Freelance Finance Experts</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/project-managers">Freelance Project Managers</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/product-managers">Freelance Product Managers</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/about">About Us</a></li></ul></section><section class="page_footer_links-column is-3"><h3 class="page_footer_links-column_header">Contact</h3><ul class="page_footer_links-list"><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/contact">Contact Us</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/press-center">Press Center</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/careers">Careers</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/faq">FAQ</a></li></ul></section><section class="page_footer_links-column is-4"><h3 class="page_footer_links-column_header">Social</h3><ul class="page_footer_links-list"><li class="page_footer_links-item for-social_link"><a class="page_footer_links-social_link is-facebook" href="https://www.facebook.com/toptal">Facebook</a></li><li class="page_footer_links-item for-social_link"><a class="page_footer_links-social_link is-twitter" href="https://twitter.com/toptal">Twitter</a></li><li class="page_footer_links-item for-social_link"><a class="page_footer_links-social_link is-instagram" href="https://www.instagram.com/toptal">Instagram</a></li><li class="page_footer_links-item for-social_link"><a class="page_footer_links-social_link is-linkedin" href="https://www.linkedin.com/company/toptal">LinkedIn</a></li></ul></section></nav></div></section><section class="grid-row page_footer_legal-wrapper"><div class="grid-row-inner has-medium_padding page_footer_legal is-wide"><div class="logo-wrapper page_footer_legal-logotype"><a class="logo is-mini is-link" href="https://www.toptal.com/">Toptal</a><p class="logo-motto is-mini">Hire the top 3% of freelance talent</p></div><ul class="page_footer_legal-links"><li class="page_footer_legal-links_item is-copyright"><p class="page_footer_legal-copyright">© Copyright 2010 - 2019 Toptal, LLC</p></li><li class="page_footer_legal-links_item has-right_margin"><a class="page_footer_legal-link" href="https://www.toptal.com/privacy">Privacy Policy</a></li><li class="page_footer_legal-links_item"><a class="page_footer_legal-link" href="https://www.toptal.com/tos">Website Terms</a></li></ul></div></section></footer></div><div class="layout-overlay" data-view="layout#overlay"></div><div class="notification-container" data-view="notifications#service"></div><script>setTimeout(function () {
  classNameWithFont = document.documentElement.className + ' wf-active'
  document.documentElement.className = classNameWithFont
}, 0);</script><script src="https://assets.toptal.io/assets/public-8047c0ad2baab9a986b8f0996a34edd086582a2e.js"></script><script src="https://assets.toptal.io/assets/blog-8047c0ad2baab9a986b8f0996a34edd086582a2e.js"></script><script src="https://assets.toptal.io/assets/cookie_banner-8047c0ad2baab9a986b8f0996a34edd086582a2e.js"></script><div class="cookie_banner-container" data-allow="Got it" data-cookie-policy-type="privacy_shield" data-message="By continuing to use this site you agree to our &lt;a href=&#39;https://www.toptal.com/cookie-policy&#39;&gt;Cookie Policy&lt;/a&gt;." data-reload="false"></div><script>Widgets && new Widgets.CookieBanner(document.querySelector('.cookie_banner-container'))</script><div class="layout-counters"><script async="true" src="https://www.googletagmanager.com/gtag/js?id=UA-21104039-1"></script><script>if (typeof(window.Widgets) !== 'undefined') {
  var trackingId = 'UA-21104039-1'

  if (trackingId.length && !(window.googleAnalytics instanceof Widgets.GoogleAnalytics)) {
    window.googleAnalytics = new Widgets.GoogleAnalytics(
      trackingId,
      '',
      '',
      false
    )
  }
}</script><script async="" defer="" src="https://cdn.distiltag.com/api/v1/script/A6qhozMiYLpV2VKc8wSHaEmc3saOMhcrxAFcCFAt?GA_TID=UA-21104039-1&amp;GA_CDI=14" type="text/javascript"></script><noscript><img src="https://cdn.distiltag.com/api/v1/noscript/A6qhozMiYLpV2VKc8wSHaEmc3saOMhcrxAFcCFAt?GA_TID=UA-21104039-1&amp;amp;GA_CDI=14" /></noscript><script>// We are checking if window.analytics has the track function in case some dom element has the id equal analytics
if (!window.analytics || typeof window.analytics.track !== 'function') {
  // We do this because if some dom element has id equal analytics we need to override it, otherwise it wouldn't set analytics right
  window.analytics = undefined
  !function(){var analytics=window.analytics=window.analytics||[];if(!analytics.initialize)if(analytics.invoked)window.console&&console.error&&console.error("Segment snippet included twice.");else{analytics.invoked=!0;analytics.methods=["setAnonymousId", "trackSubmit","trackClick","trackLink","trackForm","pageview","identify","group","track","ready","alias","page","once","off","on"];analytics.factory=function(t){return function(){var e=Array.prototype.slice.call(arguments);e.unshift(t);analytics.push(e);return analytics}};for(var t=0;t<analytics.methods.length;t++){var e=analytics.methods[t];analytics[e]=analytics.factory(e)}analytics.load=function(t){var e=document.createElement("script");e.type="text/javascript";e.async=!0;e.src=("https:"===document.location.protocol?"https://":"http://")+"cdn.segment.com/analytics.js/v1/"+t+"/analytics.min.js";var n=document.getElementsByTagName("script")[0];n.parentNode.insertBefore(e,n)};analytics.SNIPPET_VERSION="3.0.1";
  analytics.load('jnS4QsHOCAOeG6XvMDCjD9n9bAcQ53Mb');
  }}();
}
(function() {
  function readVisitorIdCookie() {
    var cookieName = 'visitor_id=';
    var cookies = document.cookie.split(';');
    for (var i = 0; i < cookies.length; i++) {
      var cookie = cookies[i].replace(/^\s+|\s+$/g, '');
      if (cookie.indexOf(cookieName) === 0) {
        return cookie.split('=')[1];
      }
    }
  }
  analytics.setAnonymousId(readVisitorIdCookie());
  
  analytics.page('posts#show');
})();</script><script async="" defer="" id="hs-script-loader" src="//js.hs-scripts.com/2799924.js" type="text/javascript"></script><script>var _hsq = window._hsq = window._hsq || [];
</script><script>!function(f,b,e,v,n,t,s)
{if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};
if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];
s.parentNode.insertBefore(t,s)}(window,document,'script',
'https://connect.facebook.net/en_US/fbevents.js');

fbq('init', '463369723801939');
fbq('track', 'ViewContent');</script><noscript><img height="1" src="https://www.facebook.com/tr?id=463369723801939&amp;ev=ViewContent&amp;noscript=1" width="1" /></noscript><iframe frameborder="0" height="1" scrolling="no" src="https://www.attributiontracker.com/tracker/account_visit?tt_visit=1" width="1"></iframe><script>(function(A, d, S, t, a, g, e) {
  A['AdstageAnalytics'] = a;
  A[a] = A[a] || function() {
    (A[a].q = A[a].q || []).push(arguments)
  };
  A[a].l = 1 * new Date();
  g = d.createElement(S), e = d.getElementsByTagName(S)[0];
  g.async = 1;
  g.src = t;
  e.parentNode.insertBefore(g, e);
})(window, document, 'script', '//assets.adstage.io/analytics.js', '_as');
_as('create', 'e2dd65eb-07a1-4d93-874a-fe6dac5a8b64');
_as('send', 'pageview');</script><script>_bizo_data_partner_id = "8663";
(function() {
  var s = document.getElementsByTagName("script")[0];
  var b = document.createElement("script");
  b.type = "text/javascript";
  b.async = true;
  b.src = (window.location.protocol === "https:" ? "https://sjs" : "http://js") + ".bizographics.com/insight.min.js";
  s.parentNode.insertBefore(b, s);
})();</script><noscript><img alt="" height="1" src="//www.bizographics.com/collect/?pid=8663&amp;fmt=gif" style="display:none;" width="1" /></noscript></div><div id="breadcrumbs" class="breadcrumbs"><span itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url" href="https://www.toptal.com/"><span itemprop="title">Home</span></a></span> &rsaquo; <span itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url" href="https://www.toptal.com/developers/blog"><span itemprop="title">Blog</span></a></span> &rsaquo; <span itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb"><a class="current" itemprop="url" href="/designers/ui/long-scroll-websites"><span itemprop="title">Take It to the Limit - an Overview of Long Scroll Websites</span></a></span></div></body></html>