<!DOCTYPE html><!--[if IE 7]><html class="layout-wrapper ie ie7 lte9 lte8 lte7"><![endif]--><!--[if IE 8]><html class="layout-wrapper ie ie8 lte9 lte8"><![endif]--><!--[if IE 9]><html class="layout-wrapper ie ie9 lte9"><![endif]--><!--[if (gte IE 9)|!(IE)]<!--><html class="layout-wrapper"><head><title>Conversational UX in Chatbot Design | Toptal</title>
<meta name="description" content="Conversational User Interfaces are a new frontier that requires thoughtful consideration around visual and experiential design. The design process should include defining the purpose of the chatbot, understanding the platform on which it is built and other design considerations to create a successful user experience." />
<link rel="alternate" href="https://www.toptal.com/designers/ui/chatbot-ux-design" hreflang="en" />
<link rel="canonical" href="https://www.toptal.com/designers/ui/chatbot-ux-design" />
<meta property="og:image" content="https://uploads.toptal.io/blog/post_image/120930/image_11-d23004b147bae5afb254e1d87645bdf8.png" />
<meta property="og:title" content="Chatbot UX - Design Tips and Considerations" />
<meta property="og:description" content="Conversational User Interfaces are a new frontier that requires thoughtful consideration around visual and experiential design. The design process should include defining the purpose of the chatbot, understanding the platform on which it is built and other design considerations to create a successful user experience." />
<meta property="og:site_name" content="Toptal Design Blog" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="author" content="" />
<meta name="DC.date.issued" content="2018-10-09" /><meta charset="utf-8" /><meta content="IE=edge,chrome=1" http-equiv="X-UA-Compatible" />
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"e3359cee6b","applicationID":"30100511","transactionName":"JV0NEUYJCQkARxgVEwReCgYbFgoWEUYYFg4JRQ==","queueTime":0,"applicationTime":107,"agent":""}</script>
<script type="text/javascript">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</script><meta content="width=device-width, initial-scale=1.0" name="viewport" /><script>(function(w,d,s,l,i){
  w[l]=w[l]||[];
  w[l].push({
    'gtm.start': new Date().getTime(),
    event:'gtm.js'
  });
  var f=d.getElementsByTagName(s)[0],
      j=d.createElement(s),
      dl=l!='dataLayer'?'&l='+l:'';
  j.async=true;
  j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;
  f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-K4WD79L');</script><script>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</script>
<link href="https://assets.toptal.io/assets/front/static/favicons/favicon_ca7136.png" rel="icon" /><!--[if IE]><link href="https://assets.toptal.io/assets/front/static/favicons/favicon_68b340.ico" rel="shortcut icon" /><![endif]--><link href="https://assets.toptal.io/assets/front/static/favicons/touch_x57_f72647.png" rel="apple-touch-icon-precomposed" sizes="57x57" /><link href="https://assets.toptal.io/assets/front/static/favicons/touch_x72_516451.png" rel="apple-touch-icon-precomposed" sizes="72x72" /><link href="https://assets.toptal.io/assets/front/static/favicons/touch_x114_1798a8.png" rel="apple-touch-icon-precomposed" sizes="114x114" /><link href="https://assets.toptal.io/assets/front/static/favicons/touch_x57_f72647.png" rel="apple-touch-icon-precomposed" /><script src="https://assets.toptal.io/assets/jquery_and_modernizr-e3b92ae4d80dde446f0fe1c606e52edb68b3417d.js"></script><script>// TODO: Figure out how to override Modernizr test
(function () {
  var isIE, isIE11, noFlexboxClassName;
  isIE = /MSIE/.test(navigator.userAgent) && !/Opera/.test(navigator.userAgent);
  isIE11 = window.MSInputMethodContext && !/\bEdge\/[0-9.]+$/.test(navigator.userAgent);
  if (window.Modernizr && window.Modernizr.flexbox && (isIE || isIE11)) {
    noFlexboxClassName = document.documentElement.className.replace(/\bflexbox\b/, 'no-flexbox ie-flexbox');
    document.documentElement.className = noFlexboxClassName;
  }
})();</script><script>
//<![CDATA[
window.gon={};gon.ga_settings={"group":"Blog posts"};gon.current_vertical="designers";gon.url_share_counter=0;gon.bounce_modal_settings={"show":true,"type":"fullscreen","current_vertical_role_type":"Designer","template_options":{"blog":{"bundle_name":"blog_designers","submit_path":"https:\/\/www.toptal.com\/blog\/subscription","form_vertical":"designers","blog_image":"designers","blog_type":"Toptal Design Blog","subtitle":"for the latest design tutorials and exploration of current trends.","articles":[{"url":"https:\/\/www.toptal.com\/designers\/ui\/chatbot-ux-design","image":"https:\/\/uploads.toptal.io\/blog\/cover_image\/120713\/list_inside_cover-image_0-f9b834e0f3b94515b237bbd6add8d90b.png","title":"Chatbot UX - Design Tips and Considerations","author":"Merve Postalc\u0131o\u011flu","author_image":"https:\/\/uploads.toptal.io\/user\/photo\/649761\/small_ca9465dbd4235716f4e4e02b6cd292c7.jpg","author_position":"Designer"},{"url":"https:\/\/www.toptal.com\/designers\/business-website-design\/b2b-ux-solutions","image":"https:\/\/uploads.toptal.io\/blog\/cover_image\/120711\/list_inside_cover-image_0-022f4e100d6b8f8dc5a39e735a3b97c2.png","title":"B2B UX \u2013 Common Obstacles and Attainable Solutions","author":"Samuel J.","author_image":"https:\/\/uploads.toptal.io\/user\/photo\/712669\/small_51cf5d89138dfcc799d3037d608b69f3.JPG","author_position":"Designer"},{"url":"https:\/\/www.toptal.com\/designers\/ux\/design-system","image":"https:\/\/uploads.toptal.io\/blog\/cover_image\/120708\/list_inside_cover-image_0-ca3c3ddf36ee6bf8f9238272901561fa.png","title":"Understanding Design Systems and Patterns","author":"Darcie G.","author_image":"https:\/\/uploads.toptal.io\/user\/photo\/479804\/small_3ca6943d14eccd4f87d0b819ddaa551b.jpg","author_position":"Designer"}]},"fullscreen":{"subtitle":"designers","bounce_modal_header_skill":"UI designers","verticals":["developers","designers","finance_experts","project_managers"],"for_projects":false,"email_validation_api_path":"https:\/\/www.toptal.com\/giorgio\/api\/company_email_validations","submit_path":"https:\/\/www.toptal.com\/giorgio\/api\/leads","default_vertical":"designers"}},"skill":"UI","role":"designers"};gon.current_skill_name="UI";gon.current_skill_name_overriden_singular="UI designer";gon.current_skill_name_overriden_plural="UI designers";gon.chameleon_current_experiments={"blog_post_ux_experiments":{"google_analytics_dimension":"dimension9","variant_key":"reading_time"}};
//]]>
</script><link rel="stylesheet" media="screen" href="https://assets.toptal.io/assets/public_styles-e3b92ae4d80dde446f0fe1c606e52edb68b3417d.css" /><link rel="stylesheet" media="screen" href="https://assets.toptal.io/assets/portal_styles-e3b92ae4d80dde446f0fe1c606e52edb68b3417d.css" /><link rel="stylesheet" media="screen" href="https://assets.toptal.io/assets/blog_styles-e3b92ae4d80dde446f0fe1c606e52edb68b3417d.css" /><script>if(!window.appinfo) {
  var thens = []
  var catches = []
  var LocalPromise = {
    then: function(callback, error) {
      thens.push(callback)
      if (error) {
        catches.push(error)
      }
    },
    catch: function (error) {
      catches.push(error)
    }
  }
  var resolve = function() {
    var args = arguments
    thens.forEach(function(callback) {
      callback.apply(null, args)
    })
  }
  var reject = function() {
    var args = arguments
    catches.forEach(function(callback) {
      callback.apply(null, args)
    })
  }

  window.onAppInfoLoaded = LocalPromise

  window.onAppinfoLoad = function() {
    document.cookie = 'appinfo_id_status=doing_request;'

    window.appinfo.grab('https://appinfo.toptal.com', {
      data: gon['application_info_data'] || {},
      callback: function(response, error) {
        if (!error) {
          document.cookie = 'appinfo_id_status=request_completed;'

          resolve({
            applicationInfo: response.data
          })
        } else {
          document.cookie = 'appinfo_id_status=request_failed;'
        }
      }
    })
  }

  document.cookie = 'appinfo_id_status=loading_script;'

  var script = document.createElement('script')
  script.type = 'text/javascript'
  script.onError = function() {
    document.cookie = 'appinfo_id_status=script_load_failed;'
    reject()
  }
  script.src = 'https://appinfo.toptal.com/script.js'
  document.getElementsByTagName('head')[0].appendChild(script)
}</script></head><body class="layout" data-view="layout#body" id="top"><div class="layout_layer" data-view="layout#layout"><header class="page_header hide_in_webview" data-role="fixed-header"><div class="page_header_line"></div><div class="page_header" data-view="layout#menu"><div class="blog-simple-header grid-row is-light_gray" data-role="main_menu_wrapper"><div class="grid-row-inner is-wide has-padding page_header_top"><div class="page_header_top-logotype_wrapper"><div class="page_header_top-logotype"><a class="logo is-big is-link" href="https://www.toptal.com/designers"></a></div><div class="page_header_top-main_title"><b>Hiring?</b> Toptal handpicks <b><a href="https://www.toptal.com/designers/ui" onclick='window.googleAnalytics.trackEvent(event, "BlogCTAs", "ClickedOnHeaderHeadline", "ClickedOnHeaderHeadline")'>top UI designers</a></b> to suit your needs.</div></div><a class="page_header_top-expand" data-role="expand_menu" href="#"><span class="page_header_top-expand_icon"></span></a><nav class="page_header_top-nav_wrapper"><ul class="page_header_top-nav"><li class="page_header_top-nav_item"><a class="button is-green_candy is-small page_header_top-nav_link is-button" data-role="companies_apply_button" href="https://www.toptal.com/designers/ui" onclick="window.googleAnalytics.trackEvent(event, &quot;BlogCTAs&quot;, &quot;ClickedOnHeaderCTA&quot;, &quot;ClickedOnHeaderCTA&quot;);">Start hiring</a></li><li class="page_header_top-nav_item"><a class="button is-small is-light page_header_top-nav_link is-button" href="https://www.toptal.com/users/login">Log in</a></li></ul></nav></div></div><nav class="grid-row has-top_border is-light_gray page_header_menu-wrapper" data-role="main_menu_wrapper"><div class="grid-row-inner is-wide has-small_padding page_header_menu"><div class="page_header_menu-items-wrapper"><ul class="page_header_menu-items" data-role="menu"><li class="page_header_menu-item is-home"><a class="page_header_menu-link" href="https://www.toptal.com/designers"></a></li><li class="page_header_menu-item is-top-3-percent"><a class="page_header_menu-link" href="https://www.toptal.com/top-3-percent">Top 3%</a></li><li class="page_header_menu-item is-why"><a class="page_header_menu-link" href="https://www.toptal.com/why">Why</a></li><li class="page_header_menu-item is-clients"><a class="page_header_menu-link" href="https://www.toptal.com/clients">Clients</a></li><li class="page_header_menu-item is-enterprise"><a class="page_header_menu-link" href="https://www.toptal.com/enterprise">Enterprise</a></li><li class="page_header_menu-item is-community"><a class="page_header_menu-link" href="https://www.toptal.com/community">Community</a></li><li class="page_header_menu-item is-blog"><a class="page_header_menu-link" href="https://www.toptal.com/designers/blog">Blog</a></li><li class="page_header_menu-item is-about"><a class="page_header_menu-link" href="https://www.toptal.com/about">About Us</a></li><li class="page_header_menu-item is-join"><a class="button is-green_candy is-small page_hader_menu-button" data-role="companies_apply_button" href="https://www.toptal.com/designers/ui" onclick="window.googleAnalytics.trackEvent(event, &quot;BlogCTAs&quot;, &quot;ClickedOnHeaderCTA&quot;, &quot;ClickedOnHeaderCTA&quot;);">Start hiring</a></li><li class="page_header_menu-item is-join"><a class="button is-green_candy is-small page_hader_menu-button" href="https://www.toptal.com/designers/join">Apply as a Designer</a></li><li class="page_header_menu-item is-login"><a class="button is-light is-small page_hader_menu-button is-login" href="https://www.toptal.com/users/login">Login</a></li><li class="page_header_menu-item is-contacts"><ul class="page_header_menu-contact-items is-replaceable"><li class="page_header_menu-contact-item is-contact">Questions?</li><li class="page_header_menu-contact-item is-contact"><a class="link is-dotted page_header_menu-contact-link" href="https://www.toptal.com/contact">Contact Us</a></li><li class="page_header_menu-contact-item"><a class="page_header_menu-contact-link is-social is-facebook" href="https://www.facebook.com/toptal" target="_blank"><span class="page_header_menu-contact-link-icon"></span></a></li><li class="page_header_menu-contact-item"><a class="page_header_menu-contact-link is-social is-twitter" href="https://twitter.com/toptal" target="_blank"><span class="page_header_menu-contact-link-icon"></span></a></li><li class="page_header_menu-contact-item"><a class="page_header_menu-contact-link is-social is-google_plus" href="https://plus.google.com/+Toptalllc/" target="_blank"><span class="page_header_menu-contact-link-icon"></span></a></li></ul></li></ul></div><div class="blog_search" data-view="quick_search#search_field" data-vertical="Designer"><form class="blog_search-form" data-role="form"><input autocomplete="off" class="blog_search-field" data-role="field" name="text" placeholder="Search Topics" type="text" /><button class="button is-tiny blog_search-submit"><span class="blog_search-submit_icon"></span></button></form><div class="blog_search-suggestions" data-role="suggestions_wrapper"></div><div class="blog_search_results" data-role="results" style="display: none;"></div></div><a class="button is-green_candy is-tiny for-page_header_menu page_header_menu-hire" data-role="companies_apply_button" href="https://www.toptal.com/hire?interested_in=designers&amp;skill=ui">Hire a designer</a></div></nav><nav class="blog-simple-header grid-row page_header_menu-wrapper is-fixed" data-role="sticky_menu_wrapper"><div class="grid-row-inner is-wide page_header_menu has-padding"><div class="page_header_top-logotype_wrapper"><div class="page_header_top-logotype"><a class="logo is-big is-link" href="https://www.toptal.com/designers"></a></div><div class="page_header_top-main_title"><b>Hiring?</b> Toptal handpicks <b><a href="https://www.toptal.com/designers/ui" onclick='window.googleAnalytics.trackEvent(event, "BlogCTAs", "ClickedOnHeaderHeadline", "ClickedOnHeaderHeadline")'>top UI designers</a></b> to suit your needs.</div></div><nav class="page_header_top-nav_wrapper"><ul class="page_header_top-nav" data-role="menu"><li class="page_header_top-nav_item"><a class="button is-green_candy is-small page_header_top-nav_link is-button" data-role="companies_apply_button" href="https://www.toptal.com/designers/ui" onclick="window.googleAnalytics.trackEvent(event, &quot;BlogCTAs&quot;, &quot;ClickedOnHeaderCTA&quot;, &quot;ClickedOnHeaderCTA&quot;);">Start hiring</a></li><li class="page_header_top-nav_item"><a class="button is-small is-light page_header_top-nav_link is-button" href="https://www.toptal.com/users/login">Log in</a></li></ul></nav></div></nav></div></header><main class="layout-main"><header class="grid-row has-top_border has-bottom_border post_cover is-post"><div class="grid-row-inner is-wide has-big_padding blog_title for-show"></div></header><article class="grid-row is-transparent"><div class="grid-row-inner is-wide"><div class="post_title"><div class="post_title-header"><p class="post-reading_time" data-view="content#reading_time" data-minutes="10">10 min read</p><h1 class="post_title-text">Chatbot UX - Design Tips and Considerations</h1></div><a class="post_title-back" href="https://www.toptal.com/designers/blog">View all articles</a></div></div></article><section class="grid-row has-top_border is-transparent has-no_border" data-view="" id="main_content"><div class="grid-row-inner has-medium_padding two_columns_layout is-wide"><div class="two_columns_layout-content"><div class="post is-full"><div class="post_meta-wrapper post_header"><div class="post_header-triangle"></div><div class="post_avatar post_meta-avatar"><img width="50" class="post_avatar-image" src="https://uploads.toptal.io/user/photo/649761/small_ca9465dbd4235716f4e4e02b6cd292c7.jpg" /></div><div class="post_meta is-full"><div class="post_meta-author"><p>by <strong><a class="link is-blue" target="_blank" href="https://www.toptal.com/designers/resume/merve-postalcioglu">Merve Postalcıoğlu</a></strong> - Designer
@ <a class="link is-blue" target="_blank" href="https://www.toptal.com/">Toptal</a>
</p>
</div><div class="post_meta-tags"><a rel="nofollow" href="https://www.toptal.com/designers/blog/tags/productdesign">#ProductDesign</a> <a rel="nofollow" href="https://www.toptal.com/designers/blog/tags/ui">#UI</a> <a rel="nofollow" href="https://www.toptal.com/designers/blog/tags/uxdesign">#UXDesign</a></div></div><ul class="social_share is-horizontal is-small is-centered_on_mobile for-blog_post_heading" data-hashtags="UXDesign,UI,ProductDesign" data-rss-url="https://www.toptal.com/designers/blog.rss" data-url="https://www.toptal.com/designers/ui/chatbot-ux-design" data-view="layout#social_share" data-youtube-channel-url="https://www.youtube.com/channel/UCNqm_euTHZz3o5OnKhUS-oA"><li class="social_share-item is-counter" title="Total number of shares"><span class="social_share-item_num" data-role="counter_num">0</span><span class="social_share-item_text" data-role="counter_text">shares</span></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;twitter&quot;}" data-type="twitter" title="Share on Twitter"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/twitter_83c6d4.png" width="50" /></a></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;facebook&quot;}" data-type="facebook" title="Share on Facebook"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/facebook_dc66c9.png" width="50" /></a></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;linkedin&quot;}" data-type="linkedin" title="Share on LinkedIn"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/linkedin_b923c3.png" width="50" /></a></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;google_plus&quot;}" data-type="google_plus" title="Share on Google Plus"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/google_plus_355fb0.png" width="50" /></a></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;stumbleupon&quot;}" data-type="stumbleupon" title="Share on StumbleUpon"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/stumbleupon_fc7c35.png" width="50" /></a></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;pocket&quot;}" data-type="pocket" title="Save to Pocket"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/pocket_e4260c.png" width="50" /></a></li></ul><div class="post_meta-extra"></div></div><div class="content_body" data-insert-middle-content="true" data-view="content#body"><p>Designers have been creating graphical user interfaces (GUI) for over 50 years. However, venturing into conversational user interfaces (CUI) is entering into uncharted territory. CUI is a new wave of human-computer interaction where the medium changes from graphical elements (buttons and links) to human-like conversation (emotions and natural language).</p>

<p>Conversational user interfaces are often chatbots—software that mimics a conversation with a real person via text or voice. Chatbots can be used for product recommendations, to book a ticket, order food, and so on. Instead of tapping buttons on a screen to find an answer, users can simply ask the bot a question, like “What’s the latest news on the NBA?” or, “How much money do I have in my account?”</p>

<p>Integrating a customer support chatbot that can respond to common customer queries and provide assistance 24/7 significantly reduces employment costs for companies who implement the systems, as their customer support agents then only need to deal with the complex questions a chatbot is unable to handle.</p>

<p>Conversational interfaces allow companies to create rapid, helpful customer interactions (often more so than with an app or website) and many companies have been quick to adopt chatbots. According to a <a href="https://www.eiuperspectives.economist.com/technology-innovation/artificial-intelligence-real-world-0">study by the Economist</a>, 75% of more than 200 business executives surveyed said AI will be actively implemented in their companies before 2020.</p>

<p><img src="https://uploads.toptal.io/blog/image/127318/toptal-blog-image-1539030981785-76e320cdc520d0db20af8b1c79962b69.jpg" alt="Burberry customer service chatbot UX" /></p>

<div class="pop_out_box is-full_width" style="font-size:1em; text-align: center">Burberry created a Facebook Messenger bot that provides customer service support and offers answers to FAQs through categorized options. </div>

<p>Two years ago I was working at a bank and had the <a href="https://www.toptal.com/designers/resume/merve-postalcioglu#project=bank-chatbot-for-facebook-and-website&amp;image=1">opportunity</a> to dive deep into chatbot UX design. The bank had been employing live agents to provide customer support on Facebook but decided to use the newly launched Facebook Messenger API to create a chatbot that would offer basic banking features, such as loan calculation, credit card suggestions, customer support, and branch or ATM locations.</p>

<p>Because of the general lack of information and framework around chatbot experience design at the time, I decided to take notes that I could use in future chatbot projects. Although <a href="https://www.toptal.com/designers/ui/designing-a-vui">voice user interface</a> (VUI) is often part of chatbot design, this particular project used only text, so in this article, we’ll focus on text-based chatbots.</p>

<p>Here’s a set of tips and best practices for <a href="https://www.toptal.com/designers/ux">designers</a> who are interested in crafting superior chatbot experiences.</p>

<h2 id="tip-1-learn-about-the-platform">Tip 1: Learn About the Platform</h2>

<p>A chatbot can be designed either within the constraints of an existing platform or from scratch for a website or app.</p>

<p>On one hand, designing a chatbot that is plugged into a company’s website or mobile app gives designers the freedom to create a custom branded experience. Designers can create custom buttons, color palettes, and other components to meet specific needs. It’s an opportunity to build unique <a href="https://www.toptal.com/designers/ux/never-call-yourself-ui-designer">UI solutions</a> that fit all use cases within brand guidelines.</p>

<p><img src="https://uploads.toptal.io/blog/image/127319/toptal-blog-image-1539030997142-62b9029fdf10e6497217d561e6936570.jpg" alt="Lemonade chatbot design" /></p>

<div class="pop_out_box is-full_width" style="font-size:1em; text-align: center"><a href="https://www.lemonade.com/">Lemonade</a> is a home insurance provider that custom-built their chatbot to follow branded UI guidelines and to meet specific use cases on both their mobile app and website.</div>

<p>On the other hand, chatbots can be created through platforms such as Facebook Messenger, Slack, Kik, or Telegram. These platforms offer ready-made elements, such as discovery, suggestions, payments, and ordering. They also provide (with some limitations) visual components for formatting, such as fonts, image sizes, etc.</p>

<p>For instance, <a href="https://messenger.fb.com/developers">Messenger Bot’s</a> quick reply element has a character limit for its response buttons. The conversation is subsequently limited to the platform’s capabilities. In these situations, designers have to be more creative with vocabulary than with typical design elements, like button size and color.</p>

<p><img src="https://uploads.toptal.io/blog/image/127320/toptal-blog-image-1539031006091-fe5f7c59e3d13be5c06d44cf2c6e532b.jpg" alt="FB Messenger quick reply chatbot ui" /></p>

<div class="pop_out_box is-full_width" style="font-size:1em; text-align: center">This example is created in <a href="https://app.botsociety.io/">Botsociety</a> chatbot prototyping tool. Quick reply elements often follow the platform's capabilities and a designer crafts the flow and language accordingly.</div>

<p>Designers must understand the capabilities, limitations, and opportunities of the platform they’re working on well before starting the design process. It’s also important to be realistic, and balance project aims with design constraints. The product team may have great ideas for the chatbot, but if the UI elements aren’t supported on the platform, the conversation flow will fail.</p>

<p>Our chatbot project kicked off with a medley of ideas that the team was really excited about. But because it was to be built as a Messenger bot, we had to eliminate the ideas that wouldn’t work technically. As a Scrum team, we all went to the Messenger Developer site and immersed ourselves in the available features. We found multiple options for creating our flows that successfully delivered on our initial ideas.</p>

<h2 id="tip-2-frame-the-bots-purpose">Tip 2: Frame the Bot’s Purpose</h2>

<p>The first thing to do when starting any design project is to set a purpose. Is it for weather forecasting? Suggesting clothes? Having a friendly chat? <a href="https://www.toptal.com/designers/chatbot-designers">Chatbot designers</a> should begin by identifying the value a chatbot will bring to the end user, and reference it throughout the design process. It’s here that UX designers add <a href="https://www.toptal.com/designers/ux/ux-design-misconceptions-and-myths">great</a><a href="https://www.toptal.com/designers/ux/ux-design-misconceptions-and-myths"> value</a> in framing the scope of the project through user-centered design techniques, such as research and ideation.</p>

<p>When I started designing the banking bot, <a href="https://www.usabilitybok.org/contextual-inquiry">contextual inquiry</a> was an insightful way to understand real conversations between agents and customers, and it helped to define the purpose of our chatbot. I also conducted ideation workshops that helped our team create a meaningful scope that was crafted collaboratively with employees in different areas of the project, including business, development, and management. Everybody was empowered to give their opinion, and we were able to bring focus to what really mattered.</p>

<p>It’s important to keep in mind that the purpose of the bot can iteratively evolve based on user feedback. For example, in 2016, KLM Airlines created a Facebook Messenger chatbot originally intended to help users book tickets. Over time, they expanded the bot’s purpose “to guide you through everything you need to bring to your destination.” The KLM bot now helps users with all their travel needs, including arranging for visas and sending reminders to bring medicine.</p>

<p><img src="https://uploads.toptal.io/blog/image/127321/toptal-blog-image-1539031016900-2a8342974a061c94f9365cb76b1e2de6.jpg" alt="KLM Messenger Chatbot App menu" /></p>

<div class="pop_out_box is-full_width" style="font-size:1em; text-align: center">KLM's enhanced menu items offer far more functionality than appeared in the original bot design. </div>

<h2 id="tip-3-set-a-tone-of-voice">Tip 3: Set a Tone of Voice</h2>

<p>Chatbots revolve around conversations. They are essentially an imitation of any typical social interaction. Users are generally aware that chatbots don’t have feelings, yet they prefer a bot’s responses to be warm and human, rather than cold and robotic.</p>

<p>Consider a real conversation between a customer and an agent. The agent is a human being who can constantly adapt their voice, body language, and vocabulary based on a customer’s behavior and their responses. A bot, on the other hand, has predefined response patterns. It is important to remain conscious of how the tone may affect a user’s experience.</p>

<p>In order for a chatbot to be well-received, its intended users must be thoroughly researched so the designer can give it an appropriate personality. Personality cards are a method that provides consistency and helps to articulate the nuances of a chatbot’s tone of voice. Which words can the bot say? Which words shouldn’t be said? What type of emojis can the chatbot send? By choosing a clearly defined tone of voice, designers can look at the data for every conversation that is created.</p>

<p><img src="https://uploads.toptal.io/blog/image/127322/toptal-blog-image-1539031027058-1d99fbbd457a7de9c302cc6139a3f1e0.jpg" alt="Chatbot tone of voice comparison conversational UX" /></p>

<div class="pop_out_box is-full_width" style="font-size:1em; text-align: center">Chatbots demonstrate personality through tone of voice. Above is a set of diverse tones of voice from The New York Times, Spotify and PennyCat.</div>

<p>When creating the tone of voice for my bank client, we recognized that emojis have become ingrained in casual chatting, and are often used to describe feelings. Because of our bank customer’s profile, we were very selective when choosing the emojis we used. We chose only a few that could contribute to a sincere dialog that remained explicitly professional.</p>

<h2 id="tip-4-create-user-flows-that-make-a-difference-in-the-users-life">Tip 4: Create User Flows That Make a Difference in the User’s Life</h2>

<p>Chatbots offer a different type of interaction from websites or mobile applications. According to a global study by <a href="https://www.greenberginc.com/">Greenberg</a>, 80% of adults and 91% of teens use messaging apps daily. Chatting is clearly an important part of modern human interaction.</p>

<p>Only 33% of chatbots are created to revolutionize new use cases. Many bots are solving irrelevant uses cases simply because companies want to follow the chatbot technology wave. According to a survey by <a href="https://www.liveperson.com/">LivePerson</a>, 2 out of every 3 companies utilizing chatbots use them (in some instances unnecessarily) for the service they are most typically employed: customer support.</p>

<p>Chatbots can add value in ways that are impossible to generate with a website or mobile app. In practice, when creating a user flow for a chatbot, it’s important that designers think out of the box to uncover some of the hidden benefits of texting.</p>

<p>While defining use cases for our chatbot, in order to create a new loan calculation flow that didn’t exist on the website previously, I took inspiration from real conversations between bank relationship managers and customers. When the flow was integrated into the chatbot, it was used more frequently than the existing calculation method, proving the value of our new use case.</p>

<p>Another example of a new chatbot experience was created by designer <a href="https://azumbrunnen.me/">Adrian Zumbrunnen</a>. He designed a full-page chatbot to welcome first-time visitors to his website and gave users the option of getting in touch at the very beginning of the interaction, making it easy for them to send him a message. Adrian reported that traffic grew to 1000%! And in just 48 hours, he got over 250 emails from people who chatted with the bot.</p>

<p><img src="https://uploads.toptal.io/blog/image/127323/toptal-blog-image-1539031043584-10cc33d2f8a43c147d67e078060f82f6.jpg" alt="Adrian Zumbrunnen chatbot UX design" /></p>

<div class="pop_out_box is-full_width" style="font-size:1em; text-align: center">Adrian Zumbrunnen's personal website chatbot explores the variety of ways human-computer interactions can be designed. </div>

<h2 id="tip-5-guide-the-users-with-detailed-chatbot-ux-design">Tip 5: Guide the Users with Detailed Chatbot UX Design</h2>

<p>Conversation possibilities are endless. When users first come to chat with a bot, they can ask anything they want. However, this can cause problems for advancing a dialog using predetermined responses. Designers must take charge and design a use flow that will lead users through the intended conversation.</p>

<p>One of the <a href="https://www.interaction-design.org/literature/article/user-interface-design-guidelines-10-rules-of-thumb">heuristic principles</a> of user interface design is to provide enough guidance for users to know where they are in the system, and what is expected of them. During a conversation, it’s important that each question be very clear so they can understand what type of information needs to be entered.</p>

<p>For instance, in order to start a fluent dialog and avoid veering out of the bot’s purpose, the intention of the chatbot should be clearly described in the welcoming message.</p>

<p>Open-ended questions allow users to respond in ways the chatbot may not support, so instead of using open intents, closed intents will keep users on the flow. Additionally, to avoid a dead end conversation, add buttons offering specific answers that are targeted to the user.</p>

<p><img src="https://uploads.toptal.io/blog/image/127324/toptal-blog-image-1539031054645-23a0ede4bf80b37c78990102108ee211.jpg" alt="UX collective chatbot UX welcome message" /></p>

<div class="pop_out_box is-full_width" style="font-size:1em; text-align: center"><a href="http://uxchat.me/">UX Bear's</a> welcome message instantly guides the user in understanding how the bot can be used. The quick reply UI buttons keep the conversation within the scope of the chatbot design.</div>

<p>When designing the banking chatbot, a question required the user to enter a money amount. When we launched the chatbot, we saw that everybody responded slightly differently: ‘20000’ ‘20.000’ ‘20,000’ ‘20000tl’ ‘20000lira.’ To streamline the inconsistencies, we had to choose between adding all the possibilities to our markup language so it would accept each version, or give clear directions on how the user should enter the amount.</p>

<h2 id="tip-6-plan-for-misunderstandings">Tip 6: Plan for Misunderstandings</h2>

<p>The most painful part of interacting with a chatbot is misunderstanding. Many chatbots use advanced <a href="https://www.toptal.com/algorithms/how-to-build-a-natural-language-processing-app">NLP</a> (Natural Language Processing) in the background, while others are based on a simple decision tree logic. Chatbot technology is not yet capable of understanding every user response well enough in order to reply in a meaningful way—no matter how perfectly the script is written, under challenging situations, it will most likely fail.</p>

<p>Having a creative solution is one of the most powerful things a designer can do. When designing a chatbot, the designer must create fallback scenarios. Jakob Nielsen, the creator of the <a href="https://www.interaction-design.org/literature/article/user-interface-design-guidelines-10-rules-of-thumb">10 Heuristics</a> for User Interface Design, argues that “Designers should assume users are unable to understand technical terminology, therefore, error messages should almost always be expressed in plain language to ensure nothing gets lost in translation.”</p>

<p><img src="https://uploads.toptal.io/blog/image/127325/toptal-blog-image-1539031064754-3bad098343e0e487c2ab91efa031ca24.jpg" alt="Fynd Messenger Bot Fail Responses chatbot design" /></p>

<div class="pop_out_box is-full_width" style="font-size:1em; text-align: center"><a href="https://www.messenger.com/t/gofynd">Fynd</a> Messenger chatbot designers created multiple fail responses to avoid sounding like a broken record. </div>

<p>Misunderstandings are inevitable and in every case, they need a planned response that doesn’t become repetitive when the chatbot fails more than once. One way to avoid this is by changing the way the chatbot responds. A designer can create different fail responses that give the sense of a real conversation.</p>

<p>Additionally, a chatbot’s response can strategically guide the user back to the existing flow. Providing alternative buttons when a chatbot fails is a way to bring the user back to the conversation.</p>

<p><img src="https://uploads.toptal.io/blog/image/127326/toptal-blog-image-1539031084356-bfcc262375d2bffdf01425efa6045258.jpg" alt="Google assistant fail responses chatbot UX" /></p>

<div class="pop_out_box is-full_width" style="font-size:1em; text-align: center"><a href="https://assistant.google.com/platforms/phones/">Google Assistant</a> fail response and quick replies offer the user options that relate to the intended conversation.</div>

<h2 id="tip-7-track-and-analyze-user-behavior">Tip 7: Track and Analyze User Behavior</h2>

<p>UX designers love user data and how it can enhance a user experience. Similar to a website or an application, a chatbot needs to be tracked and analyzed in order to iteratively improve.</p>

<p>The best way to track data is by using an analytic platform for chatbots. Analytic platforms and analytic APIs, such as <a href="https://botanalytics.co/">Botanalytics</a>, provide information on how the chatbot was used, where it failed, and how the users interacted with it. They can also include the total number of users, user retention, most used flows, words from users that the chatbot cannot understand, and so on.</p>

<p>One way to gather data on user satisfaction is through success surveys that can be applied to chatbots. When users reached the end of a conversation with our banking chatbot, they were presented with a simple survey question so we could know if the information was satisfactory or not.</p>

<p>This survey was a dialog like the rest of the conversation; users could select their answer from quick reply buttons, as well as send a free-form feedback message. It was very beneficial in the effort to improve our chatbot and understand the user’ pain points.</p>

<p>Google Assistant offers a similar way to receive constant feedback. A thumbs up and thumbs down emoji appear as quick reply buttons so users can respond at any point. This way, if the user isn’t satisfied with the chatbot’s response, they can send a thumbs down emoji or a feedback message.</p>

<p><img src="https://uploads.toptal.io/blog/image/127327/toptal-blog-image-1539031099756-544a3c5b5a52f12b672c8217c9d646bd.jpg" alt="Fynd Messenger chatbot UX design survey emojis" /></p>

<div class="pop_out_box is-full_width" style="font-size:1em; text-align: center"><a href="https://assistant.google.com/platforms/phones/">Google Assistant</a> feedback emojis make it very easy for users to indicate how helpful they found a response. This type of data is crucial to improving the chatbot experience.</div>

<h2 id="shifting-the-design-mindset">Shifting the Design Mindset</h2>

<p>Chatbots arrived onto the scene suddenly, and it doesn’t seem likely they will be going away any time soon.</p>

<p>Designing chatbots requires a big shift in the way designers think about these new interfaces. Though designers have a wide range of tools and skills at their fingertips, they must adjust their perspective in order to adapt to the shift and strive to improve their competency with conversational interfaces.</p>

<div align="center">• • •</div>

<h3 id="further-reading-on-the-toptal-design-blog">Further reading on the Toptal Design Blog:</h3>

<ul>
  <li><a href="https://www.toptal.com/designers/product-design/design-thinking-business-value">The Value of Design Thinking in Business</a></li>
  <li><a href="https://www.toptal.com/designers/user-experience/guide-to-successful-enterprise-design">Collaborative Design - A Guide to Successful Enterprise Product Design</a></li>
  <li><a href="https://www.toptal.com/designers/ux/product-strategy-guide">Product Strategy: A Guide to Core Concepts and Processes</a></li>
  <li><a href="https://www.toptal.com/designers/product-design/customer-journey-maps">Customer Journey Maps - What They Are and How to Build One</a></li>
  <li><a href="https://www.toptal.com/designers/prototyping/minimum-viable-prototype">Ditch MVPs, Adopt Minimum Viable Prototypes (MVPr)</a></li>
</ul>
<div class="post_key_learnings for-post"><h2 class="post_key_learnings-heading" data-disable_middle_content_placement="true">Understanding the Basics</h2><div class="post_key_learnings-item" data-animation-speed="450" data-hide-button="false" data-initial-state="expanded" data-view="ui#expander"><span class="post_key_learnings-item_arrow is-expanded" data-role="button"></span><h3 class="post_key_learnings-title is-expanded" data-disable_middle_content_placement="true" data-role="button">What is the use of chatbot?</h3><p class="post_key_learnings-body" data-role="content">Users can use chatbots to get product recommendations, learn daily updates, book a ticket, order food and so on. Instead of pushing buttons on a screen to find an answer, users can simply interact by asking the bot a question, like “What’s the latest news in the NBA?” or “How much money do I have in my account?” </p></div><div class="post_key_learnings-item" data-animation-speed="450" data-hide-button="false" data-initial-state="collapsed" data-view="ui#expander"><span class="post_key_learnings-item_arrow is-collapsed" data-role="button"></span><h3 class="post_key_learnings-title is-collapsed" data-disable_middle_content_placement="true" data-role="button">Is Siri a chatbot?</h3><p class="post_key_learnings-body is-hidden" data-role="content">Yes. Siri is considered a chatbot. Chatbots can be a strictly a screen-based interaction of graphical user interface design made of text, buttons, and animations. They can also be voice-activated and made of voice user interface design. Both use conversational user interfaces for human-computer interactions.</p></div><div class="post_key_learnings-item" data-animation-speed="450" data-hide-button="false" data-initial-state="collapsed" data-view="ui#expander"><span class="post_key_learnings-item_arrow is-collapsed" data-role="button"></span><h3 class="post_key_learnings-title is-collapsed" data-disable_middle_content_placement="true" data-role="button">Is Alexa a chatbot?</h3><p class="post_key_learnings-body is-hidden" data-role="content">Yes. Alexa is a chatbot. Chatbots can be a strictly a screen-based interaction of graphical user interface design made of text, buttons, and animations. They can also be voice-activated and made of voice user interface design. Both use conversational user interfaces for human-computer interactions.</p></div><div class="post_key_learnings-item" data-animation-speed="450" data-hide-button="false" data-initial-state="collapsed" data-view="ui#expander"><span class="post_key_learnings-item_arrow is-collapsed" data-role="button"></span><h3 class="post_key_learnings-title is-collapsed" data-disable_middle_content_placement="true" data-role="button">Why is UI important?</h3><p class="post_key_learnings-body is-hidden" data-role="content">UI design allows users to interact with a digital system in order to accomplish a purpose. A user interface is comprised of the visual elements that contribute to a well-conceived user experience that will improve a user’s life in some way. </p></div><div class="post_key_learnings-item" data-animation-speed="450" data-hide-button="false" data-initial-state="collapsed" data-view="ui#expander"><span class="post_key_learnings-item_arrow is-collapsed" data-role="button"></span><h3 class="post_key_learnings-title is-collapsed" data-disable_middle_content_placement="true" data-role="button">What is a conversational user interface?</h3><p class="post_key_learnings-body is-hidden" data-role="content">Conversational user interfaces (CUI) mimic a conversation between humans by using a computer to carry out one end of the conversation. It uses natural language processing or decision tree logic to respond to user messages in a tone of voice that takes on human qualities, such as warmth and humor.</p></div><div class="post_key_learnings-item" data-animation-speed="450" data-hide-button="false" data-initial-state="collapsed" data-view="ui#expander"><span class="post_key_learnings-item_arrow is-collapsed" data-role="button"></span><h3 class="post_key_learnings-title is-collapsed" data-disable_middle_content_placement="true" data-role="button">What is a Messenger chatbot?</h3><p class="post_key_learnings-body is-hidden" data-role="content">If a chatbot is built within an existing app, such as Facebook Messenger, there’s no need for the user to install several apps for each conversation—the user can chat with different brands within the single app. </p></div><div class="post_key_learnings-item" data-animation-speed="450" data-hide-button="false" data-initial-state="collapsed" data-view="ui#expander"><span class="post_key_learnings-item_arrow is-collapsed" data-role="button"></span><h3 class="post_key_learnings-title is-collapsed" data-disable_middle_content_placement="true" data-role="button">What is the UX design process?</h3><p class="post_key_learnings-body is-hidden" data-role="content">The UX design process links business and commercial goals to user needs and experience. UX design is based on user data that can enhance a user experience. UX designers add great value in framing the scope of the project through research and ideation techniques. </p></div></div><div class="blog_author_big_banner is-active" data-ga-action="ClickedOnHireTheAuthor_bottom" data-ga-label="chatbot-ux-design" data-view="content#bottom_banner"><h2>About the author</h2><div class="skill_talent for-blog_post"><div class="skill_talent-extra"><a class="skill_talent-photo_wrapper" href="/designers/resume/merve-postalcioglu"><img alt="Merve Postalcıoğlu" class="skill_talent-photo" src="https://uploads.toptal.io/user/photo/649761/large_ca9465dbd4235716f4e4e02b6cd292c7.jpg" /><div class="skill_talent-photo_hint">View full profile &raquo;</div></a><div class="blog_author_big_banner-cta"><a class="button is-green_candy is-default is-full_width is-fixed skill_talent-hire" data-role="banner_link" href="https://www.toptal.com/hire?interested_in=designers&amp;skill=ui">Hire the Author</a></div></div><div class="skill_talent-main"><a class="link skill_talent-name" href="/designers/resume/merve-postalcioglu">Merve Postalcıoğlu, Bulgaria</a><div class="clearfix"><div class="skill_talent-member_since">member since November 20, 2017</div></div><div class="skill_talent-skills" data-view="skill_talent#tags"><a class="tag skill_talent-skill" data-role="tag" href="https://www.toptal.com/designers/sketch">Sketch 4</a><a class="tag skill_talent-skill" data-role="tag" href="https://www.toptal.com/designers/adobe">Adobe Experience Design (XD)</a><a class="tag skill_talent-skill" data-role="tag" href="https://www.toptal.com/designers/ios">iOS</a><a class="tag skill_talent-skill" data-role="tag" href="https://www.toptal.com/designers/ux">Ideation Workshops</a><a class="tag skill_talent-skill" data-role="tag" href="https://www.toptal.com/designers/user-research">User Research</a><a class="tag skill_talent-skill" data-role="tag" href="https://www.toptal.com/designers/ux">User Interviews</a><a class="tag skill_talent-skill" data-role="tag" href="https://www.toptal.com/designers/user-flows">User Flows</a><a class="tag skill_talent-skill" data-role="tag" href="https://www.toptal.com/designers/ux">UX Design</a><a class="tag skill_talent-skill" data-role="tag" href="https://www.toptal.com/designers/product-design">Product Design</a><a class="tag skill_talent-skill" data-role="tag" href="https://www.toptal.com/designers/prototyping">Prototyping</a><a class="tag" data-role="more" href="/designers/resume/merve-postalcioglu" style="display: none;">+<span data-role='count'>&nbsp;&nbsp;</span> more</a></div><div class="skill_talent-description">Merve is a senior UX and product designer who’s created designs in a variety of work environments (agile and waterfall), teams and fields such as finance, chatbot, intranet, social responsibility, and social networking subjects. She’s also extremely knowledgeable about user research and usability tests. Merve’s very communicative and she’s able to work with people across different teams such as developers, analysts, and product owners. <a class="link" href="/designers/resume/merve-postalcioglu">[click to continue...]</a></div></div></div></div><div class="post-join"><a class="button is-white_and_green is-default is-full_width" href="https://www.toptal.com/designers/ui">Hiring? Meet the Top 10 Freelance UI Designers for Hire in October 2018</a></div><div class="template" data-role="middle_content_template" data-template="{&quot;html&quot;:&quot;&lt;div class=\&quot;embeddable_form-wrapper for-post\&quot; data-role=\&quot;blog_subscribe\&quot; data-view=\&quot;blog_subscribe#form\&quot;&gt;&lt;form action=\&quot;/blog/subscription\&quot; class=\&quot;embeddable_form\&quot; data-entity=\&quot;blog_subscription\&quot; data-remote=\&quot;\&quot; data-view=\&quot;form#form\&quot; method=\&quot;post\&quot;&gt;&lt;div class=\&quot;embeddable_form-step is-email_form is-current\&quot;&gt;&lt;div class=\&quot;embeddable_form-row is-label\&quot;&gt;&lt;div class=\&quot;embeddable_form-label_title\&quot;&gt;Like what you&amp;#39;re reading?&lt;/div&gt;&lt;div class=\&quot;embeddable_form-label\&quot;&gt;Get the latest updates first.&lt;/div&gt;&lt;/div&gt;&lt;div class=\&quot;embeddable_form-row form-field is-email_field\&quot;&gt;&lt;input autocomplete=\&quot;off\&quot; class=\&quot;input is-medium\&quot; data-role=\&quot;email\&quot; name=\&quot;blog_subscription[email]\&quot; placeholder=\&quot;Enter your email address...\&quot; type=\&quot;text\&quot; /&gt;&lt;input name=\&quot;blog_subscription[vertical]\&quot; type=\&quot;hidden\&quot; value=\&quot;designers\&quot; /&gt;&lt;input name=\&quot;from_widget\&quot; type=\&quot;hidden\&quot; value=\&quot;true\&quot; /&gt;&lt;/div&gt;&lt;div class=\&quot;embeddable_form-row is-submit\&quot;&gt;&lt;input class=\&quot;button is-green_candy is-default is-full_width\&quot; data-loader-text=\&quot;Subscribing...\&quot; data-role=\&quot;submit\&quot; type=\&quot;submit\&quot; value=\&quot;Get Exclusive Updates\&quot; /&gt;&lt;/div&gt;&lt;div class=\&quot;embeddable_form-row is-privacy\&quot;&gt;&lt;div class=\&quot;embeddable_form-privacy\&quot;&gt;&lt;div class=\&quot;embeddable_form-privacy_icon\&quot;&gt;&lt;/div&gt;&lt;div class=\&quot;embeddable_form-privacy_text\&quot;&gt;No spam. Just great articles &amp;amp; insights.&lt;/div&gt;&lt;/div&gt;&lt;/div&gt;&lt;/div&gt;&lt;div class=\&quot;embeddable_form-step is-confirmation\&quot; data-place=\&quot;@blog_subscribe\&quot; data-role=\&quot;confirmation\&quot;&gt;&lt;div class=\&quot;embeddable_form-row is-label is-success\&quot;&gt;&lt;div class=\&quot;embeddable_form-label_title\&quot;&gt;Like what you&amp;#39;re reading?&lt;/div&gt;&lt;div class=\&quot;embeddable_form-label\&quot;&gt;Get the latest updates first.&lt;/div&gt;&lt;/div&gt;&lt;div class=\&quot;embeddable_form-row is-success\&quot;&gt;&lt;div class=\&quot;embeddable_form-label is-header\&quot;&gt;Thank you for subscribing!&lt;/div&gt;&lt;div class=\&quot;embeddable_form-label\&quot;&gt;Check your inbox to confirm subscription. You&#39;ll start receiving posts after you confirm.&lt;/div&gt;&lt;/div&gt;&lt;div class=\&quot;embeddable_form-row is-success\&quot;&gt;&lt;ul class=\&quot;social_share is-horizontal\&quot; data-rss-url=\&quot;https://www.toptal.com/designers/blog.rss\&quot; data-url=\&quot;https://www.toptal.com/designers/blog\&quot; data-view=\&quot;layout#social_share\&quot; data-youtube-channel-url=\&quot;https://www.youtube.com/channel/UCNqm_euTHZz3o5OnKhUS-oA\&quot;&gt;&lt;li class=\&quot;social_share-item is-counter\&quot; title=\&quot;Total number of shares\&quot;&gt;&lt;span class=\&quot;social_share-item_num\&quot; data-role=\&quot;counter_num\&quot;&gt;0&lt;/span&gt;&lt;span class=\&quot;social_share-item_text\&quot; data-role=\&quot;counter_text\&quot;&gt;shares&lt;/span&gt;&lt;/li&gt;&lt;li class=\&quot;social_share-item\&quot;&gt;&lt;a class=\&quot;social_share-item_link\&quot; data-role=\&quot;link\&quot; data-track-click=\&quot;SocialShareButtonClicked\&quot; data-track-default-data=\&quot;{&amp;quot;network&amp;quot;:&amp;quot;twitter&amp;quot;}\&quot; data-type=\&quot;twitter\&quot; title=\&quot;Share on Twitter\&quot;&gt;&lt;img class=\&quot;social_share-item_image\&quot; height=\&quot;50\&quot; src=\&quot;https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/twitter_83c6d4.png\&quot; width=\&quot;50\&quot; /&gt;&lt;/a&gt;&lt;/li&gt;&lt;li class=\&quot;social_share-item\&quot;&gt;&lt;a class=\&quot;social_share-item_link\&quot; data-role=\&quot;link\&quot; data-track-click=\&quot;SocialShareButtonClicked\&quot; data-track-default-data=\&quot;{&amp;quot;network&amp;quot;:&amp;quot;facebook&amp;quot;}\&quot; data-type=\&quot;facebook\&quot; title=\&quot;Share on Facebook\&quot;&gt;&lt;img class=\&quot;social_share-item_image\&quot; height=\&quot;50\&quot; src=\&quot;https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/facebook_dc66c9.png\&quot; width=\&quot;50\&quot; /&gt;&lt;/a&gt;&lt;/li&gt;&lt;li class=\&quot;social_share-item\&quot;&gt;&lt;a class=\&quot;social_share-item_link\&quot; data-role=\&quot;link\&quot; data-track-click=\&quot;SocialShareButtonClicked\&quot; data-track-default-data=\&quot;{&amp;quot;network&amp;quot;:&amp;quot;google_plus&amp;quot;}\&quot; data-type=\&quot;google_plus\&quot; title=\&quot;Share on Google Plus\&quot;&gt;&lt;img class=\&quot;social_share-item_image\&quot; height=\&quot;50\&quot; src=\&quot;https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/google_plus_355fb0.png\&quot; width=\&quot;50\&quot; /&gt;&lt;/a&gt;&lt;/li&gt;&lt;/ul&gt;&lt;/div&gt;&lt;/div&gt;&lt;/form&gt;&lt;/div&gt;&quot;}"></div></div><div class="blog-comments"><div id="disqus_thread_container"><div id="disqus_thread"><div class="d-noscript-comments"><h3>Comments</h3></div></div></div><script>function isIos() {
  return /(iPad|iPhone|iPod)/g.test(navigator.userAgent);
}

function adjustHeightInIos() {
  if (isIos()) {
    var height = $('#disqus_thread').outerHeight();
    $('#disqus_thread_container').height(height);
  }
}

if (isIos()) {
  var el = document.getElementById('disqus_thread_container');
  el.style.height = '1px';
  el.style.overflow = 'hidden';
  el.style.width = '100%';
}

function disqus_config() {
  this.callbacks.onNewComment = [function() {
    $.post('/blog/comments/on_create');
    adjustHeightInIos();
  }];

  this.callbacks.onReady = [adjustHeightInIos];
}

var disqus_shortname = 'toptal';
var disqus_identifier = 'ui/chatbot-ux-design';

(function() {
  var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
  dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
  (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
})();</script><noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript><a class="dsq-brlink" href="https://disqus.com">comments powered by <span class="logo-disqus">Disqus</span></a></div></div></div><div class="two_columns_layout-extra"><div class="blog-block-wrapper"><div class="blog-block-header">Subscribe</div><div class="blog-block"><div class="blog-block-row"><div class="embeddable_form-wrapper is-horizontal" data-role="blog_subscribe" data-view="blog_subscribe#form"><form action="/blog/subscription" class="embeddable_form" data-entity="blog_subscription" data-remote="" data-view="form#form" method="post"><div class="embeddable_form-step is-email_form is-current"><div class="embeddable_form-row is-label"><div class="embeddable_form-label_title">Free email updates</div><div class="embeddable_form-label">Get the latest content first.</div></div><div class="embeddable_form-row form-field is-email_field"><input autocomplete="off" class="input is-medium" data-role="email" name="blog_subscription[email]" placeholder="Enter your email address..." type="text" /><input name="blog_subscription[vertical]" type="hidden" value="designers" /><input name="from_widget" type="hidden" value="true" /></div><div class="embeddable_form-row is-submit"><input class="button is-green_candy is-default is-full_width" data-loader-text="Subscribing..." data-role="submit" type="submit" value="Get Exclusive Updates" /></div><div class="embeddable_form-row is-privacy"><div class="embeddable_form-privacy"><div class="embeddable_form-privacy_icon"></div><div class="embeddable_form-privacy_text">No spam. Just great articles &amp; insights.</div></div></div></div><div class="embeddable_form-step is-confirmation" data-place="@blog_subscribe" data-role="confirmation"><div class="embeddable_form-row is-label is-success"><div class="embeddable_form-label_title">Free email updates</div><div class="embeddable_form-label">Get the latest content first.</div></div><div class="embeddable_form-row is-success"><div class="embeddable_form-label is-header">Thank you for subscribing!</div><div class="embeddable_form-label">Check your inbox to confirm subscription. You'll start receiving posts after you confirm.</div></div><div class="embeddable_form-row is-success"><ul class="social_share is-horizontal" data-rss-url="https://www.toptal.com/designers/blog.rss" data-url="https://www.toptal.com/designers/blog" data-view="layout#social_share" data-youtube-channel-url="https://www.youtube.com/channel/UCNqm_euTHZz3o5OnKhUS-oA"><li class="social_share-item is-counter" title="Total number of shares"><span class="social_share-item_num" data-role="counter_num">0</span><span class="social_share-item_text" data-role="counter_text">shares</span></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;twitter&quot;}" data-type="twitter" title="Share on Twitter"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/twitter_83c6d4.png" width="50" /></a></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;facebook&quot;}" data-type="facebook" title="Share on Facebook"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/facebook_dc66c9.png" width="50" /></a></li><li class="social_share-item"><a class="social_share-item_link" data-role="link" data-track-click="SocialShareButtonClicked" data-track-default-data="{&quot;network&quot;:&quot;google_plus&quot;}" data-type="google_plus" title="Share on Google Plus"><img class="social_share-item_image" height="50" src="https://assets.toptal.io/assets/front/static/public/primitives/social/share_bar/google_plus_355fb0.png" width="50" /></a></li></ul></div></div></form></div></div></div><div class="blog-block-header">Trending articles</div><div class="blog-block"><nav class="blog-trending"><a class="post is-preview blog-trending-item" href="/designers/ui/chatbot-ux-design"><span class="post_cover is-preview"><noscript><img class="post_cover-image" src="https://uploads.toptal.io/blog/cover_image/120713/side_list_cover-image_0-f9b834e0f3b94515b237bbd6add8d90b.png" /></noscript><span class="post_cover-image" data-role="deferred" data-src="https://uploads.toptal.io/blog/cover_image/120713/side_list_cover-image_0-f9b834e0f3b94515b237bbd6add8d90b.png"></span></span><span class="post-preview"><span class="post-title">Chatbot UX - Design Tips and Considerations</span><span class="post_meta"><span class="post_meta-date">less than a minute ago</span></span></span></a><a class="post is-preview blog-trending-item" href="/designers/business-website-design/b2b-ux-solutions"><span class="post_cover is-preview"><noscript><img class="post_cover-image" src="https://uploads.toptal.io/blog/cover_image/120711/side_list_cover-image_0-022f4e100d6b8f8dc5a39e735a3b97c2.png" /></noscript><span class="post_cover-image" data-role="deferred" data-src="https://uploads.toptal.io/blog/cover_image/120711/side_list_cover-image_0-022f4e100d6b8f8dc5a39e735a3b97c2.png"></span></span><span class="post-preview"><span class="post-title">B2B UX – Common Obstacles and Attainable Solutions</span><span class="post_meta"><span class="post_meta-date">5 days ago</span></span></span></a><a class="post is-preview blog-trending-item" href="/designers/ux/design-system"><span class="post_cover is-preview"><noscript><img class="post_cover-image" src="https://uploads.toptal.io/blog/cover_image/120708/side_list_cover-image_0-ca3c3ddf36ee6bf8f9238272901561fa.png" /></noscript><span class="post_cover-image" data-role="deferred" data-src="https://uploads.toptal.io/blog/cover_image/120708/side_list_cover-image_0-ca3c3ddf36ee6bf8f9238272901561fa.png"></span></span><span class="post-preview"><span class="post-title">Understanding Design Systems and Patterns</span><span class="post_meta"><span class="post_meta-date">7 days ago</span></span></span></a><a class="post is-preview blog-trending-item" href="/designers/visual/visual-designer-vs-graphic-designer"><span class="post_cover is-preview"><noscript><img class="post_cover-image" src="https://uploads.toptal.io/blog/cover_image/120705/side_list_cover-image_0-d3ce20d1c081ac66cb114ecfc6223ebf.png" /></noscript><span class="post_cover-image" data-role="deferred" data-src="https://uploads.toptal.io/blog/cover_image/120705/side_list_cover-image_0-d3ce20d1c081ac66cb114ecfc6223ebf.png"></span></span><span class="post-preview"><span class="post-title">Visual Designers vs Graphic Designers - Who Does What and Why (with Infographic)</span><span class="post_meta"><span class="post_meta-date">12 days ago</span></span></span></a><a class="post is-preview blog-trending-item" href="/designers/sketch/zeplin-sketch-workflow"><span class="post_cover is-preview"><noscript><img class="post_cover-image" src="https://uploads.toptal.io/blog/cover_image/120701/side_list_cover-image_0-8e9291dcd77c8b0fb9b5a4a1ba3f51a6.png" /></noscript><span class="post_cover-image" data-role="deferred" data-src="https://uploads.toptal.io/blog/cover_image/120701/side_list_cover-image_0-8e9291dcd77c8b0fb9b5a4a1ba3f51a6.png"></span></span><span class="post-preview"><span class="post-title">Zeplin Sketch Plugin – The Workflow Bridge Between Design and Engineering</span><span class="post_meta"><span class="post_meta-date">14 days ago</span></span></span></a><a class="post is-preview blog-trending-item" href="/designers/product-design/productive-design-critique-guide"><span class="post_cover is-preview"><noscript><img class="post_cover-image" src="https://uploads.toptal.io/blog/cover_image/120699/side_list_cover-image_0-07d75cf96fe8e268a83386193ef47f44.png" /></noscript><span class="post_cover-image" data-role="deferred" data-src="https://uploads.toptal.io/blog/cover_image/120699/side_list_cover-image_0-07d75cf96fe8e268a83386193ef47f44.png"></span></span><span class="post-preview"><span class="post-title">Tips for a Productive Design Critique</span><span class="post_meta"><span class="post_meta-date">19 days ago</span></span></span></a><a class="post is-preview blog-trending-item" href="/designers/prototyping/minimum-viable-prototype"><span class="post_cover is-preview"><noscript><img class="post_cover-image" src="https://uploads.toptal.io/blog/cover_image/120697/side_list_cover-image_0-b2b3870ac9cc9cc7249fba4a91049a71.png" /></noscript><span class="post_cover-image" data-role="deferred" data-src="https://uploads.toptal.io/blog/cover_image/120697/side_list_cover-image_0-b2b3870ac9cc9cc7249fba4a91049a71.png"></span></span><span class="post-preview"><span class="post-title">Ditch MVPs, Adopt Minimum Viable Prototypes (MVPr)</span><span class="post_meta"><span class="post_meta-date">21 days ago</span></span></span></a><a class="post is-preview blog-trending-item" href="/designers/graphic/design-plagiarism"><span class="post_cover is-preview"><noscript><img class="post_cover-image" src="https://uploads.toptal.io/blog/cover_image/120695/side_list_cover-image_0-f24ab841c8b77c08d45c06a9809a739b.png" /></noscript><span class="post_cover-image" data-role="deferred" data-src="https://uploads.toptal.io/blog/cover_image/120695/side_list_cover-image_0-f24ab841c8b77c08d45c06a9809a739b.png"></span></span><span class="post-preview"><span class="post-title">Following Trends: Homage vs. Design Plagiarism</span><span class="post_meta"><span class="post_meta-date">26 days ago</span></span></span></a></nav></div><div class="blog-block-header">Relevant Technologies</div><div class="blog-block"><div class="blog-block-row"><ul class="blog-relevant"><li class="blog-relevant-item"><a class="link is-blue" href="https://www.toptal.com/designers/product-design">Product Design</a></li><li class="blog-relevant-item"><a class="link is-blue" href="https://www.toptal.com/designers/ux">UX</a></li><li class="blog-relevant-item"><a class="link is-blue" href="https://www.toptal.com/designers/ui">UI</a></li></ul></div></div><div class="blog-block has-no_background blog_banner for-author blog_author_banner" data-ga-action="ClickedOnHireTheAuthor_lateral" data-ga-label="chatbot-ux-design" data-view="content#sidebar_banner"><div class="blog-block-header">About the author</div><div class="blog_author_banner-photo_wrapper"><img alt="Merve Postalcıoğlu" class="blog_author_banner-photo" src="https://uploads.toptal.io/user/photo/649761/large_ca9465dbd4235716f4e4e02b6cd292c7.jpg" /></div><div class="blog_author_banner-content" data-role="author_content"><div class="blog_author_banner-name"><a href="/designers/resume/merve-postalcioglu">Merve Postalcıoğlu</a></div><div class="blog_author_banner-role">Designer</div><div class="blog_author_banner-about" data-role="author_about">Merve is a senior UX and product designer who’s created designs in a variety of work environments (agile and waterfall), teams and fields such as finance, chatbot, intranet, social responsibility, and social networking subjects. She’s also extremely knowledgeable about user research and usability tests. Merve’s very communicative and she’s able to work with people across different teams such as developers, analysts, and product owners.</div><div class="blog_author_banner-content_footer"></div></div><div class="blog_author_banner-cta"><a class="button is-green_candy is-default is-full_width" data-role="banner_link" href="https://www.toptal.com/hire?interested_in=designers&amp;skill=ui">Hire the Author</a></div></div></div></div></div></section></main><footer class="hide_in_webview"><section class="grid-row has-solid_blue_bg page_footer_map-wrapper"><div class="grid-row-inner has-huge_padding page_footer_map"><div class="page_footer_map-content">Toptal connects the&nbsp;<a href="https://www.toptal.com/top-3-percent">top&nbsp;3%</a> of&nbsp;freelance talent all over&nbsp;the&nbsp;world.</div></div></section><section class="grid-row page_footer_sample_profile-wrapper"><div class="grid-row-inner has-big_padding"><h2 class="header is-row">Toptal Designers</h2><div class="skills_list"><ul class="multi_column_list qa-skills_list"><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/creative-direction">Creative Directors</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/freelance">Freelance Designers</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/graphic">Graphic Designers</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/illustration">Illustrators</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/logo">Logo Designers</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/mobile">Mobile App Designers</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/product-design">Product Designers</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/ui">UI Designers</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/ux">UX Designers</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/visual">Visual Designers</a></li><li class="multi_column_list-item"><a class="multi_column_list-link" href="https://www.toptal.com/designers/web">Web Designers</a></li></ul><div class="skills_list-see_all_wrapper"><a class="button is-tiny is-white is-uppercased" href="https://www.toptal.com/designers"><div class="skills_list-see_all_icon for-designers"></div>See more freelance designers</a></div></div></div></section><div class="skills_enterprise_link"><a class="skills_enterprise_link-url" href="/enterprise">Learn how enterprises benefit from Toptal experts.</a></div><section class="grid-row has-top_border page_footer_join-wrapper" id=""><div class="grid-row-inner has-padding page_footer_join"><h2 class="page_footer_join-header">Join the Toptal community.</h2><div class="page_footer_join-spacer"></div><nav class="page_footer_join-actions"><div class="page_footer_join-item"><a class="button is-green_candy is-big is-fixed page_footer_join-button" href="https://www.toptal.com/hire?interested_in=designers&amp;skill=ui">Hire a designer</a></div><div class="page_footer_join-item is-or">or</div><div class="page_footer_join-item"><a class="button is-green_candy is-big is-fixed page_footer_join-button" href="https://www.toptal.com/designers/join">Apply as a Designer</a></div></nav></div></section><section class="grid-row page_footer_links-wrapper"><div class="grid-row-inner is-wide has-big_padding"><nav class="page_footer_links"><section class="page_footer_links-column is-1"><h3 class="page_footer_links-column_header">Highest In-Demand Talent</h3><ul class="page_footer_links-list"><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/ios">iOS Developers</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/front-end">Front-End Developers</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/designers/ux">UX Designers</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/designers/ui">UI Designers</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/finance/financial-modeling">Financial Modeling Consultants</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/finance/interim-cfos">Interim CFOs</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/project-managers/digital">Digital Project Managers</a></li></ul></section><section class="page_footer_links-column is-2"><h3 class="page_footer_links-column_header">About</h3><ul class="page_footer_links-list"><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/top-3-percent">Top 3%</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/clients">Clients</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/developers">Freelance Developers</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/designers">Freelance Designers</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/finance">Freelance Finance Experts</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/project-managers">Freelance Project Managers</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/about">About Us</a></li></ul></section><section class="page_footer_links-column is-3"><h3 class="page_footer_links-column_header">Contact</h3><ul class="page_footer_links-list"><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/contact">Contact Us</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/press-center">Press Center</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/careers">Careers</a></li><li class="page_footer_links-item"><a class="page_footer_links-link" href="https://www.toptal.com/faq">FAQ</a></li></ul></section><section class="page_footer_links-column is-4"><h3 class="page_footer_links-column_header">Social</h3><ul class="page_footer_links-list"><li class="page_footer_links-item for-social_link"><a class="page_footer_links-social_link is-facebook" href="https://www.facebook.com/toptal">Facebook</a></li><li class="page_footer_links-item for-social_link"><a class="page_footer_links-social_link is-twitter" href="https://twitter.com/toptal">Twitter</a></li><li class="page_footer_links-item for-social_link"><a class="page_footer_links-social_link is-google" href="https://plus.google.com/+Toptalllc/">Google+</a></li><li class="page_footer_links-item for-social_link"><a class="page_footer_links-social_link is-linkedin" href="https://www.linkedin.com/company/toptal">LinkedIn</a></li></ul></section></nav></div></section><section class="grid-row page_footer_legal-wrapper"><div class="grid-row-inner has-medium_padding page_footer_legal is-wide"><div class="logo-wrapper page_footer_legal-logotype"><a class="logo is-mini is-link" href="https://www.toptal.com/">Toptal</a><p class="logo-motto is-mini">Hire the top 3% of freelance talent</p></div><ul class="page_footer_legal-links"><li class="page_footer_legal-links_item is-copyright"><p class="page_footer_legal-copyright">© Copyright 2010 - 2018 Toptal, LLC</p></li><li class="page_footer_legal-links_item has-right_margin"><a class="page_footer_legal-link" href="https://www.toptal.com/privacy">Privacy Policy</a></li><li class="page_footer_legal-links_item"><a class="page_footer_legal-link" href="https://www.toptal.com/tos">Website Terms</a></li></ul></div></section></footer></div><div class="layout-overlay" data-view="layout#overlay"></div><div data-view="bounce_modals#events"><div data-view="bounce_modals#modal"></div></div><div class="notification-container" data-view="notifications#service"></div><script>setTimeout(function () {
  classNameWithFont = document.documentElement.className + ' wf-active'
  document.documentElement.className = classNameWithFont
}, 0);</script><script src="https://assets.toptal.io/assets/public-e3b92ae4d80dde446f0fe1c606e52edb68b3417d.js"></script><script src="https://assets.toptal.io/assets/blog-e3b92ae4d80dde446f0fe1c606e52edb68b3417d.js"></script><script src="https://assets.toptal.io/assets/cookie_banner-e3b92ae4d80dde446f0fe1c606e52edb68b3417d.js"></script><div class="cookie_banner-container" data-allow="Got it" data-cookie-policy-type="privacy_shield" data-message="By continuing to use this site you agree to our &lt;a href=&#39;https://www.toptal.com/cookie-policy&#39;&gt;Cookie Policy&lt;/a&gt;." data-reload="false"></div><script>Widgets && new Widgets.CookieBanner(document.querySelector('.cookie_banner-container'))</script><div class="layout-counters"><script>if (typeof(window.Widgets) !== 'undefined') {
  var appId = 'UA-21104039-1';
  if (appId.length > 0 && !(window.googleAnalytics instanceof Widgets.GoogleAnalytics)) {
    window.googleAnalytics = new Widgets.GoogleAnalytics(
      appId,
      'auto',
      false
    );
    window.googleAnalytics.bucketRole('', '');

    if (typeof(window.gon) !== 'undefined' && gon['ga_settings']){
      window.googleAnalytics.grouping(gon['ga_settings']['group']);
    }

    if (typeof(window.gon) !== 'undefined' && gon['chameleon_current_experiments']) {
      for (var experiment_key in gon['chameleon_current_experiments']) {
        var experiment = gon['chameleon_current_experiments'][experiment_key];
        if (experiment.google_analytics_dimension !== null) {
          window.googleAnalytics.set(experiment.google_analytics_dimension, experiment.variant_key);
        }
      }
    }

    window.googleAnalytics.trackPageview();
    window.googleAnalytics.track15secondsRead();
  }
}</script><script async="" defer="" src="https://cdn.distiltag.com/api/v1/script/A6qhozMiYLpV2VKc8wSHaEmc3saOMhcrxAFcCFAt?GA_TID=UA-21104039-1&amp;GA_CDI=14" type="text/javascript"></script><noscript><img src="https://cdn.distiltag.com/api/v1/noscript/A6qhozMiYLpV2VKc8wSHaEmc3saOMhcrxAFcCFAt?GA_TID=UA-21104039-1&amp;amp;GA_CDI=14" /></noscript><script>// We are checking if window.analytics has the track function in case some dom element has the id equal analytics
if (!window.analytics || typeof window.analytics.track !== 'function') {
  // We do this because if some dom element has id equal analytics we need to override it, otherwise it wouldn't set analytics right
  window.analytics = undefined
  !function(){var analytics=window.analytics=window.analytics||[];if(!analytics.initialize)if(analytics.invoked)window.console&&console.error&&console.error("Segment snippet included twice.");else{analytics.invoked=!0;analytics.methods=["setAnonymousId", "trackSubmit","trackClick","trackLink","trackForm","pageview","identify","group","track","ready","alias","page","once","off","on"];analytics.factory=function(t){return function(){var e=Array.prototype.slice.call(arguments);e.unshift(t);analytics.push(e);return analytics}};for(var t=0;t<analytics.methods.length;t++){var e=analytics.methods[t];analytics[e]=analytics.factory(e)}analytics.load=function(t){var e=document.createElement("script");e.type="text/javascript";e.async=!0;e.src=("https:"===document.location.protocol?"https://":"http://")+"cdn.segment.com/analytics.js/v1/"+t+"/analytics.min.js";var n=document.getElementsByTagName("script")[0];n.parentNode.insertBefore(e,n)};analytics.SNIPPET_VERSION="3.0.1";
  analytics.load('jnS4QsHOCAOeG6XvMDCjD9n9bAcQ53Mb');
  }}();
}
(function() {
  function readVisitorIdCookie() {
    var cookieName = 'visitor_id=';
    var cookies = document.cookie.split(';');
    for (var i = 0; i < cookies.length; i++) {
      var cookie = cookies[i].replace(/^\s+|\s+$/g, '');
      if (cookie.indexOf(cookieName) === 0) {
        return cookie.split('=')[1];
      }
    }
  }
  analytics.setAnonymousId(readVisitorIdCookie());
  
  analytics.page('posts#show');
})();</script><script async="" defer="" id="hs-script-loader" src="//js.hs-scripts.com/2799924.js" type="text/javascript"></script><script>var _hsq = window._hsq = window._hsq || [];
</script><script>!function(f,b,e,v,n,t,s)
{if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};
if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];
s.parentNode.insertBefore(t,s)}(window,document,'script',
'https://connect.facebook.net/en_US/fbevents.js');

fbq('init', '463369723801939');
fbq('track', 'ViewContent');</script><noscript><img height="1" src="https://www.facebook.com/tr?id=463369723801939&amp;ev=ViewContent&amp;noscript=1" width="1" /></noscript><iframe frameborder="0" height="1" scrolling="no" src="https://www.attributiontracker.com/tracker/account_visit?tt_visit=1" width="1"></iframe><script>(function(A, d, S, t, a, g, e) {
  A['AdstageAnalytics'] = a;
  A[a] = A[a] || function() {
    (A[a].q = A[a].q || []).push(arguments)
  };
  A[a].l = 1 * new Date();
  g = d.createElement(S), e = d.getElementsByTagName(S)[0];
  g.async = 1;
  g.src = t;
  e.parentNode.insertBefore(g, e);
})(window, document, 'script', '//assets.adstage.io/analytics.js', '_as');
_as('create', 'e2dd65eb-07a1-4d93-874a-fe6dac5a8b64');
_as('send', 'pageview');</script><script>_bizo_data_partner_id = "8663";
(function() {
  var s = document.getElementsByTagName("script")[0];
  var b = document.createElement("script");
  b.type = "text/javascript";
  b.async = true;
  b.src = (window.location.protocol === "https:" ? "https://sjs" : "http://js") + ".bizographics.com/insight.min.js";
  s.parentNode.insertBefore(b, s);
})();</script><noscript><img alt="" height="1" src="//www.bizographics.com/collect/?pid=8663&amp;fmt=gif" style="display:none;" width="1" /></noscript></div><div id="breadcrumbs" class="breadcrumbs"><span itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url" href="https://www.toptal.com/"><span itemprop="title">Home</span></a></span> &rsaquo; <span itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url" href="https://www.toptal.com/developers/blog"><span itemprop="title">Blog</span></a></span> &rsaquo; <span itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb"><a class="current" itemprop="url" href="/designers/ui/chatbot-ux-design"><span itemprop="title">Chatbot UX - Design Tips and Considerations</span></a></span></div></body></html>